Komplete Kontrol S series MK1 keyboards End Of Life

Jeremy_NI
Jeremy_NI Customer Care Posts: 8,801 mod
edited December 2023 in Komplete Kontrol

We’re writing to let you know we will be ending software support for MK1 of the Komplete Kontrol S-Series keyboard controller on October 12, 2023

Starting with the upcoming release of Komplete Kontrol 3.0, future NI software releases will no longer be compatible with the MK1. Please do not attempt an update to version 3.0 when it is released on October 12. Both versions can't live side by side on your system.

You will still be able to use your MK1 keyboard with Komplete Kontrol 2.9 (or lower), which includes Apple Silicon and VST3 support. However, we will no longer maintain older versions of Komplete Kontrol and cannot guarantee they will be supported by future versions of your computer’s operating system.

We occasionally need to retire older products like the MK1 in order to focus our resources and development efforts on building new, innovative products and features. In this case, our decision comes alongside the launch of our new MK3 keyboards. With MK3, we are introducing next-generation software with many new features that require significant team resources. This means we are not able to continue working to maintain older versions.

We would like to thank you for your long-lasting commitment to Native Instruments and our Komplete Kontrol keyboards. Below, you’ll find a list of FAQs with detailed information on this change.


FAQ


Why has NI decided to retire software support for the Komplete Kontrol S-Series MK1?

The Komplete Kontrol MK1 keyboards are built on a legacy tech stack that is now over a decade old and no longer compatible with the new features we are introducing. As with all technology companies, our resources are not unlimited; it is not possible for us to continue the maintenance of all our older software while also focusing on research, innovation, and supporting new product releases and features. 


What does this mean for the latest version of the software? 

From October 12, 2023, we will start to introduce new features and improvements to our software that are not compatible with Kontrol S-Series MK1. These software changes will arrive first in Komplete Kontrol 3.0 and Kontakt 7 and expand from there.

The current MK1 experience will be “frozen in time”, so the last compatible versions of our software will remain available but unsupported. This means that future operating system updates on your computer could affect MK1 compatible NI software. You will need to stay on your current operating system version if you want to avoid damaging updates.


Will MK1 customers still be supported?

If your hardware is still under warranty and you experience a hardware defect, you will receive full hardware support as part of the warranty obligation.


How long will my MK1 still work? 

We are not removing any existing features from the MK1. You will still be able to use it with the last compatible version of Komplete Kontrol software 2.9, which has already been updated to support the latest versions of Mac OS (including Apple Silicon), Windows, and VST3.


What happens if I accidentally upgrade to the latest version of Komplete Kontrol software?

If you accidentally upgrade beyond version 2.9, you can download the 2.9.6 installers below:

Komplete Kontrol 2.9.6 for mac

Komplete Kontrol 2.9.6 for Windows

What happens if I need to upgrade to the latest Komplete Kontrol Software for my other NI keyboard?

You will only be able to access one version of the software moving forward. If you upgrade Komplete Kontrol for your MK2 or MK3 keyboard, it will break compatibility with your MK1, which will function in MIDI mode.

If you have other questions, we'll leave this thread open and will try to answer them or get the answers.

«13456743

Comments

  • Vagus
    Vagus Member Posts: 393 Pro

    My thoughts would be, after launching MK1 in 2014, and then MK2 some years later, there's an end-of-life limit to any hardware, and nearly ten years is reasonable.

    The vast majority of users will be on MK2 and above, and these will still work with KK 3.0 - if that means more features for the vast majority of users, I'm all for that.

  • Gorilla Texas
    Gorilla Texas Member Posts: 42 Member

    Is the sampler bug fixed for Studio One? If not count us users out!

  • Vagus
    Vagus Member Posts: 393 Pro

    Ten years for a technology product is a long time, but as the post says, it means end-of-life for development, not support or warranty. This doesn't mean everything will stop working this week - it means active software support will end. That's a normal part of software/hardware hybrid.

    Apple does about 3-4 years support, google does four years, and just announced seven ears. Ten years is very much an outlier.

    KK 2.9 will still allow usage, but the technology has been vastly superseeded. To clarify, I'm also a Maschine MK3 user.

  • LostInFoundation
    LostInFoundation Member Posts: 3,993 Expert
    edited October 2023

    I’m not saying other companies are doing better.

    Anyway…just guessing where you take your infos… my 8 yo iPad with latest iPadOS installed is saying differently. Not defending Apple here…probably they are the worst (see the millionaire fine they had to pay because they discovered they slowed down older devices with every new OS in order to make them obsolete…thing that they are still doing imo).

    But my mommy taught me something: if you are in the middle of murderers, it doesn’t make the fact you kill someone less deplorable.

    Btw: a mouse is software/hardware hybrid. Should I throw away my perfectly working one?

  • Tomboman
    Tomboman Member Posts: 29 Member

    Does that also mean the Kontrol Series MK3 will be released on October 12th? :)

  • Vagus
    Vagus Member Posts: 393 Pro

    Opinions are there to be shared - I'm not trying to limit anyone's ability to share their opinions - I just have a different one from you, and from experience of working with product with finite time on the market, and software that needs to support it; there is always an end date, but I'd suggest NI won't have made this decision if more than 10% of the market still used MK1.

    Continuing to support hardware that's nearly ten years old, and a small subsection of an active userbase isn't good business. Ni are providing a workaround with 2.9 download, meaning those keyboards will work as long as the OS is viable.

    If you want new features, then you upgrade - just like you would with a phone. Or a mouse. (This is intended as a joke).

  • LostInFoundation
    LostInFoundation Member Posts: 3,993 Expert

    Yes, it was a good discussion and as I said I value your opinion too.

    Btw: thank you for the insight about the 10%. Even on this I would not be too sure (probably it is something more in the line of “less than 10% of users still BUYING NI are using it”, but in any case it’s a good info from someone who worked in the field

  • Vocalpoint
    Vocalpoint Member Posts: 668 Pro

    Sampler bug still happens in MKII as well.

    NI is/was aware of it and maybe it's fixed on Oct 12 or maybe not. I am going to remain hopeful...

    VP

  • LostInFoundation
    LostInFoundation Member Posts: 3,993 Expert

    Mot important thing: it’s still happening in 2.9.4. Therefore it will never be fixed for MK1 users.

    Well…no need to wait if it will stop working in 3 days: it is already not working for Studio One users. And never will be

  • Vocalpoint
    Vocalpoint Member Posts: 668 Pro

    Yes - if you are a MK1 user - you are frozen on 2.94 and that is that.

    But I am on MKII and hoping that this is fixed in 3.x starting Oct 12.

    I should also ask - what "bug" is it that we are talking about?

    Mine is specifically watching Komplete Kontrol load my loops and samples in the internal AUDIO plugin rather than the internal SAMPLER plugin - which makes me a bit cranky have to switch it everytime.

    But maybe the "bug" being referenced here is something else entirely?

    VP

  • LostInFoundation
    LostInFoundation Member Posts: 3,993 Expert
    edited October 2023

    Things are “a little bit” worst with latest Studio One…have a look at this thread

    Having to freeze at 2.9.4 because of mk1, I would not accept even a bug like yours. But the problem is things are way more serious: having to freeze there, it would mean not being able to use NI softwares at all.

    As I said, the minimum they could do is making last usable version PERFECT. But it will not happen

This discussion has been closed.
Back To Top