Setting up external sound card to Traktor Pro 3 mk3

Options

Hi,

I want to use my Apollo Twin audio interface as the sound card when I DJ with the Traktor Pro MK3. I do not however see the Apollo Twin as an option when I go to settings>audio setup>audio device. Its only listed Traktor MK3 and the Mac.

I know there is an artivle about using an external sound card, but that didn´t help me.

Any tips?

Thanks, in advance :)

Comments

  • Isotoxin
    Isotoxin Member Posts: 129 Advisor
    Options

    DJ with Traktor Pro MK3? 🤔

  • Sebastian B
    Sebastian B Member Posts: 23 Member
    Options

    Sorry :) S4 MK3.


    Aditional info. I can adjust the volume through my Apollo Twin Interface, as I have connected the output of the S4 to the input of the Apollo. Does that mean Im using the Apollo Interface as the Soundcard? It doesn´t show up in the Audio Setup..

  • c0nsul
    c0nsul Member Posts: 301 Pro
    Options

    You can set your Apollo as audio interface in Traktor´s preferences --> Audio Setup. After this, you have to set your input/output routings in preferences.

    This way, your controller´s audio interface is bypassed and not used in Traktor.

  • Isotoxin
    Isotoxin Member Posts: 129 Advisor
    edited September 2023
    Options

    This is the way.

    Try to use other audio interface named MAC. I think this is the one, with default drivers. You can try to use:

    UAD Downloads (uaudio.com) to update drivers. Yes, even on MAC You NEED to update drivers and sometimes firmware for audio interface (if it supports it). This ****** like "You dont need to install drivers on MAC" is irrelevant for at least 5 last years.

    Maybe afterwards You will see your audio interface with a different name.

  • 6xes
    6xes Member Posts: 674 Pro
    Options

    try creating a aggregate device, and see if the aggregate device shows up in the list...

    just be aware as ive run into an issue with Traktor... when dealing with aggregate devices, if your outputs or inputs of the aggregate device are greater than 14 then traktor crashes...

    so basically your aggregate devices input&outputs have to be on the first 14 slots if using EXT

  • Sebastian B
    Sebastian B Member Posts: 23 Member
    Options

    Thank you so much, @Isotoxin ! An update of the apollo software, and the UAD Interface is showing in the audio menu.


    One aditional question - when using an external audio interface, is it possible to use the headphone volume knob on the S4? I notice that the master volume and the headphone can only be adjusted via the interface.

  • Isotoxin
    Isotoxin Member Posts: 129 Advisor
    edited September 2023
    Options

    LOL. On Windows Traktor crashes ONLY if I try to select the higher port. 😅But no problems for the the audio device to just have more outputs/inputs.

  • Isotoxin
    Isotoxin Member Posts: 129 Advisor
    Options

    Unfortunately, I don't know how master volume/headphones knobs on the S4 works. If they are in direct control to audio interface in the S4 itself, I don't think You can do anything about this. But maybe You can try to map them to Traktor software knobs as a midi controller?

  • Sebastian B
    Sebastian B Member Posts: 23 Member
    Options

    Dear @Isotoxin

    Im not sure if I understand. As of now, the master volume and the HP vol. is inactive, as I have routed the audio output to the apollo twin. Its the latter that control the master and the HP vol now. Are you saying that I might map these functions from the Apollo to the vol. knobs on the S4?

  • Isotoxin
    Isotoxin Member Posts: 129 Advisor
    edited September 2023
    Options

    Have You selected EXTERNAL or INTERNAL mixing mode? Because You just need to use INTERNAL mixing with outputs to master and headphones to Your Apollo Twin audio interface (picture attached with my single output on Yamaha AG03).

    And the output in the Traktor application is still controlled by virtual knobs. You can try to map these knobs to KONTROL S4 MK3 unused audio knobs. But I'm not sure are they MIDI mappable or just direct control of S4 audio interface. I have not used S4.


  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,945 mod
    Options

    The hardware knobs can't be (re-)mapped and are dedicated controls for the S4's soundcard monitor output.

  • Sebastian B
    Sebastian B Member Posts: 23 Member
    Options

    @Isotoxin

    Hi,

    im in internal mixing mode.

    on my screen I can’t see the volume control, like the one your red arrow is pointing at. Is there a hide/show feature for this?

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,945 mod
    Options

    Go to Preferences➔Mixer.

    Select (check) crossfader.


Back To Top