How to stop Traktor automatically changing the audio interface to Traktor Kontrol device upon start?

Options
DanteBen
DanteBen Member Posts: 10 Member

Just a quick one, I can't seem to find any way to stop the Traktor Kontrol S4 being set as the audio interface automatically. There was a dialog box that came up asking if I wanted it to change automatically once, and I must have said to never ask again and said yes. It's very frustrating as I have to change audio interface every time I start the app.

Any ideas? I'm sure it's probably in a config file somewhere.

Answers

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,860 mod
    edited August 2023
    Options

    Maybe this will do it. 🍁

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,737 mod
    Options

    Try to connect a different audio interface and assign it as an audio device in Preferences. Then restart Traktor and connect NI hardware again and the pop-up message should appear again. Otherwise you might need to delete the TraktorSetting.tsi file and let Traktor create a new one next time it is started.

  • DanteBen
    DanteBen Member Posts: 10 Member
    Options
  • DanteBen
    DanteBen Member Posts: 10 Member
    Options

    Tried that, still changes to the Kontrol S4 automatically. I get that it’s a useful setting for some users, but once it’s locked in it would be nice to change without having to delete your settings.

    Maybe I can edit the settings file rather than deleting it. I will investigate.

  • jacques
    jacques Member Posts: 8 Member
    Options

    @DanteBen any luck? I just bought a reloop RMX 95 which I use as external mixer and for now I am using an S2 to control my decks and I am running into the same issue.

Back To Top