Native Access 3.1.0 and dependency / dependencies installation

2

Answers

  • Walt Hubis
    Walt Hubis Member Posts: 12 Member

    Thanks Jeremy,

    It was worth a try but still have the same issue with the error message:

    Reverting back to 1.14.1 which seems to work fine.

  • Walt Hubis
    Walt Hubis Member Posts: 12 Member

    Update: Seems to work fine, except I just upgraded to 14 and I can't install the Ozone 10 suite (see ticket #3564842). Other content seems to work fine.

    So now I have purchased a product which I can not use because of this issue.

    I'm a firmware engineer for an SSD manufacturer, but I use NI for music I write for some podcasts I engineer. If there's something technical we can try (e.g., any sort of windows 10 manipulations) please let me know.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Walt Hubis You're already in contact with our specialists, I can't help you more than them.

  • Walt Hubis
    Walt Hubis Member Posts: 12 Member

    I thought that you were the specialist I was dealing with?!

    Who is the specialist I need to be dealing with?

    I'm looking at my system logs and there are definitely issues with NTKDaemon Service permissions, specifically it appears that one of the processes involved does not have permissions for Local Activation permission for the COM server:

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

    {2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}

     and APPID

    {15C20B67-12E7-4BB6-92BB-7AFF07997402}

     to the user FASTWALT2\Walt Hubis SID (S-1-5-21-3411884936-3380481647-969111362-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

  • Walt Hubis
    Walt Hubis Member Posts: 12 Member

    FYI: I was able to get Native Access 3.1.0 installed and running by doing a Windows reinstall (kept my apps and info, just rebuilt the OS). Seems to work just fine now.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Walt Hubis Well, I'm helping on the forum but we have a dedicated support section, that you used and one of my colleagues took care of you by email. Thnaks for the update.

  • stlrbrt@yahoo.com
    [email protected] Member Posts: 1 Member

    using NTKDaemon 1.9.0 Setup PC

    need help

  • tr@nz
    tr@nz Member Posts: 2 Member

    I have the same issue as Walt. Ozone will not install because it needs Native Access v2 (apparently). However, when downloading Native Access it downloads v 3.1.0 (not v2) and v 3.1.0 hangs when logging in. v1.4 works smoothly, except for installing Ozone. I am a Windows 10 Pro user but am not about to reinstall my OS for this bug.

  • Kaldosh
    Kaldosh Member Posts: 265 Advisor

    I personally have no bug anymore and startong time is fine,

    What seems to do the trick for me is to have NIHostIntegrationAgent and NTKDaemon added to Login Items in Users and Groups section ot System Settings. By default, NTKDaemon was not added in the first place

  • echopathy
    echopathy Member Posts: 1 Newcomer

    Same 'grant permissions' error on my Windows 10 desktop attempting to install NA 3.1.0 .. My laptop works well on Windows 10 with it.. No issues. I've tried everything under the Sun from gpedit.msc to Daemons 1.7 - 1.9 .. Been working with NI tech support for a couple months now. They keep sending me direct installers from some Google Drive.. Wish I had full access to that :) Support is responsive and cool.. But something clearly is not working here.

    My desktop (ideally) would be up to speed with my laptop. Unfortunately, the solution is to rollback to NA 1.4 .. Which shows no updates available for my purchased libraries .. unlike My laptop's NA2 (or 3.1.0) ..

    Updates available currently on my laptop (Windows 10 NA 3.1.0) =

    Updates available currently on my desktop? (Windows 10 NA 1.4) =

    I've deleted the Native Access.xml file and everything .. I just want my laptop and desktop to be on the same page if possible.. Thanks! Danny B

  • Wlodzislaw
    Wlodzislaw Member Posts: 7 Member

    Half a year later and still the same problem. Latest Windows 11, no way to download Kontakt 7 via Access 2. Tried all possible advice and got a response with links to the same advice, although I have clearly written that it does not work. Software for musicians that requires looking at demons, logs, and messing up with gpedit in the system is simply not acceptable.

    I have removed all NI Access 2 files and reverted to the old access. This allowed me to download Kontakt 7 + new library. Unfortunately, older instruments do not work now properly: Native American Flutes of Clint Goss, and a few others that worked in previous versions. Disaster ...

  • PoorFellow
    PoorFellow Moderator Posts: 1,572 mod
    edited July 2023 Answer ✓

    Actually they have come a long way in solving a lot of problems. But even if they have not solved your problem then you ought not go back and try to revive a thread that is no longer about a present version of Native Access. Version is now 2/3.4.0 .

    Don't get me wrong ! : I did exactly what you did back when it was Native Access 2.X . It was clearly riddled with problems and I for months reverted to version 1 and used that and only very recently upgraded to version 2/3.4.0 (download page says 2 , version say 3.4.0).

    At present it appear to me that N.I. have manged to iron most their problems making the Native Access run and work but it also appears to me that they have not been able to make an installer process that can manage to clean up after previous problems made by previous versions and install attempts , not to mention that their N.I. registry tool is simply not up to the task either - ought really be a N.I. cleaner that would both clean registry and hard drive from any traces of previous installations in as much as that it mostly appears that that is most peoples problem that they have to spend a lot of time doing that to get things to run. And which you yourself has noticed that it is simply not reasonable if the average user have to be a Windows or Mac software trouble-shooting 'expert' !

    For what it is worth then as already implied then most people here appear to get their things to run by deep cleaning their system from previous Native Access and NTKDaemon installations. If you can not get the Native Access 3.4.0 to run yourself then you should get support to help you by contacting support ! , however please notice that they are swamped with requests due to the recent sale and the many new customers and the many upgrades made !

    Otherwise here is an adapted copy of my 'standard advice' by now :

    IMPORTANT : prior to any computer tinkering then please at least make a Restore Point , and prior to tinkering with registry take a back up of that. Also generally it'd always advisable to backup the whole system drive once in a while or at least if you got something that you do not want to loose if you mess up anything !

    You can not be sure that Native Access 1 will work (it's more or less considered as obsolete by N.I.) so you need to upgrade to Native Access 2 /(3.4.0) . As for the N.I. reg-tool then it does not actually do it's job properly as far as I am concerned. Also after an un-install there may be files left on your hard drive. Also , please check in Task Manager to see if you have the NTKDaemon process running despite you having uninstalled the app or may have failed to install new..

    What I did myself were to uninstall Native Access , then kill process NTKDaemon and run the N.I. reg-tool : ref. NI Uninstall RegTool_64bit : https://support.native-instruments.com/hc/en-us/articles/115003509269-Fixing-Software-Update-Installation-Issues-Windows-

    to remove Native Access and NTKDaemon from registry , then delete all directories named Native Access from drive and all instances of NTKDaemon - including destinations such as (can not remember which exactly but also depends on version I think - 1 or 2) (Mentioned destinations are Windows 10 , not having Win 11 I can not confirm it for Win 11) :

    C:\Users\<user name>\AppData\Local\ and C:\Users\<user name>\AppData\Local\Native Instruments

    C:\Users\<user name>\AppData\Roaming\ and C:\Users\<user name>\AppData\Roaming\Native Instruments

    C:\ProgramData\ and C:\ProgramData\Native Instruments

    C:\Program Files\ and C:\Program Files\Native Instruments

    C:\Program Files\Common Files\ and C:\Program Files\Common Files\Native Instruments


    Then I cleaned the registry using the free CCleaner (use with caution and remember to backup the registry first - CCleaner only backup alterations)  (CCleaner is free but accused by some to be 'bloatware' and generally the use of registry cleaning tools are highly discouraged by N.I)(hence the backup suggestions also) Ref.  :https://support.native-instruments.com/hc/en-us/articles/209544929-Notes-on-Using-Registry-or-Property-List-Cleaning-Utilities

    Then I used Windows registry editor to then remove any left traces of 'Native Access' and 'NTKDaemon'

    And then confident that all traces of Native Access and NTKDaemon were removed from from both drive and registry and that the NTKDaemon process were no longer running after startup then I installed Native Access 2 / 3.4.0 (run install as Admin !) : https://www.native-instruments.com/en/specials/native-access-2/   OR https://www.native-instruments.com/en/support/downloads/

    Again :

    If you can not get the Native Access 3.4.0 to run yourself then you should get support to help you by contacting support !

  • Wlodzislaw
    Wlodzislaw Member Posts: 7 Member
    edited July 2023

    Wow, thank you for such excellent advice. When you download NI Access 2 they do not tell you that the old version should be removed first. So far using old Access I have managed to download Kontakt 7, Factory Lib 2, and Ethereal Earth, and all is running fine. The only thing I cannot install is the third-party libraries, like Native American Flutes of Clint Goss, excellent free flutes, but they do not run if I open nki file, at least not on my computer. You can easily find it on his Flutopedia.com site under resources.

    I wonder if anyone has tried to run it in K7. If it is possible I may go through the cleaning procedure and reinstallation, but if it will not work I will rather wait for NI to provide tools for automatic cleaning.

Back To Top