Maschine Plus - Stems of Same Length

satbirkira
satbirkira Member Posts: 9 Newcomer

I have a song done in song mode, it's time to move this into ableton. I put the whole thing into a loop using shift-loop and then select the first section to the last. I file export by sound, and I make sure split by section is turned off (which is what I want because I don't want 100 stems, I just want one for each sound), but the stems come out different lengths. I want the stems all to be the same length, the length of the entire song. Why? Because when I put it into ableton, the lengths are different so I have to line everything up again, which is near impossible when you have song sounds that aren't quantized. Unfortunately, the stem is created from the point when a sound first is introduced, not when the song started.

How do I export all sounds at full song length?

Tagged:

Best Answer

  • Uwe303
    Uwe303 Moderator Posts: 2,911 mod
    Answer ✓

    ok warping is then on top a problem of ableton, but you now resolved it and i wish you lots of fun and creativity

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,911 mod
    edited February 2023

    Hello,

    have you tried to set it to export the "loop range" and set the loop range of course accordingly, from start to a bit behind the last section.

  • satbirkira
    satbirkira Member Posts: 9 Newcomer

    Hi. I'm not sure I understand. Could you explain a bit more about what you mean by "loop range of course accordingly" and "start to a bit behind the last section."?

  • Uwe303
    Uwe303 Moderator Posts: 2,911 mod
    edited February 2023

    in song/arraner mode you press and hold "shift + loop", then you set start to 1:1:1 (encoder 1)and length a bit behind the last section or as needed. Then you go to export and set it to export the loop (what you´ve set) - I always set it behind the last section ends because some sounds can go longer and i want them to totally release and i have a bit silence at the end too

  • satbirkira
    satbirkira Member Posts: 9 Newcomer
    edited February 2023

    This doesn't solve the issue. The issue is that I want silence to fill the stem before the first sound plays. If your sound first appears half way into the song, then the stem is half the length of the song instead of the full length. That way, when I put everything in ableton, everything is perfectly lined up and plays out exactly like it would in machine + in song mode.

  • Uwe303
    Uwe303 Moderator Posts: 2,911 mod

    Have you actually tried it? As far as I remember it starts to render all sounds right away from start marker. But i can make a test.

  • satbirkira
    satbirkira Member Posts: 9 Newcomer
    edited February 2023

    I solved the problem. Yes I've been trying it for 2 days now, the problem is Ableton Live. When you import stems from machine, it will automatically set the 1:1:1 marker when the sound first starts. I followed this to fix it: https://www.youtube.com/watch?v=qMNwyWp7ScY


    I also had a problem where machine plus stems play at wrong tempo (too fast) in ableton. The solution is to turn off auto warp long samples in the preferences, and then import the stems.

  • Uwe303
    Uwe303 Moderator Posts: 2,911 mod
    Answer ✓

    ok warping is then on top a problem of ableton, but you now resolved it and i wish you lots of fun and creativity

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @satbirkira Do you still need help on this one? It seems that you found a solution. I'm not sure if it would fit your workflow and if that would make things faster or easier but maybe you could try to route your Maschine tracks to Ableton tracks and render the tracks / stems in Ableton:


  • satbirkira
    satbirkira Member Posts: 9 Newcomer

    @Jeremy_NI I had no idea this was possible. It's interesting, but I found the sound that stems out from maschine plus and the one that stems out from maschine 2 sound a bit different, even though the maschine plus has all it's effects bypassed as well. Could the engines differ?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @satbirkira Ah! That's also interesting, to be honest, I have no idea, never had the opportunity to compare. It could be there are small differences on the engine. I'll ask around!

Back To Top