S61 Mk2 Keybed Doesn't Initialize

SuperTRev
SuperTRev Member Posts: 89 Member

When running the Komplete Kontrol VST in FL Studio; booting up the project with the plugin in it, and turning on the keyboard... the keybed doesn't work until I first push the MIDI button and then back to the KK mode (by pushing the 'Plugin' or 'Browser' button).

The lightguide won't work and it won't send note messages. It's dead until I first 'initialize' the keybed by going into MIDI mode first. This happens 90% of the time, but sometimes it just up and works fine, without any reason it worked that time. It's strange. Does anyone know why this is?

Best Answer

  • SuperTRev
    SuperTRev Member Posts: 89 Member
    Answer ✓

    Ya I just figured out that if I set the 'sleep mode' keybed from 'off' back to 'note' and just transpose it all the way down so the lights are off, this also solves the problem. So now I still have a one button press sleep mode.

«1

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,886 mod

    Hello,

    that's maybe because you have not selected a track with kk in it when opening the project?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @SuperTRev If you open Komplete Kontrol in standalone, can you post a screenshot of the selected MIDI inputs & outputs?

  • SuperTRev
    SuperTRev Member Posts: 89 Member

    I tried clicking around with all kinds of things in FLS, but nothing seems to activate the keybed, except for me pushing those onboard buttons. Thanks anyway.

  • SuperTRev
    SuperTRev Member Posts: 89 Member

    I only have the one input selected. I forgot which drivers are for what, except I remember that I have EXT -1 set up in FLS to use the MCU driver for transport controls.


  • Uwe303
    Uwe303 Moderator Posts: 2,886 mod
    edited October 2022

    Have you set the keyboard up as mackie control? I mean the DAW port from the S61. https://support.native-instruments.com/hc/en-us/articles/4406832231441-How-to-Integrate-KOMPLETE-KONTROL-with-Your-DAW

  • SuperTRev
    SuperTRev Member Posts: 89 Member

    Here's the FLS MIDI settings. KK - 1 I have in the output to 'send master sync' for the tempo clock.

    I discovered that the 'Instance' button also initializes the keybed.


  • Uwe303
    Uwe303 Moderator Posts: 2,886 mod

    Seems correct to me, the ext channels are for the physical midi in out on the back of the keyboard

  • SuperTRev
    SuperTRev Member Posts: 89 Member

    Ya. This wasn't an issue before and it's strange. If the setup is wrong you would think it wouldn't work at all ever, but it does work after going to MIDI mode and back. And randomly it just works without having to do that.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @SuperTRev You should tick the Komplete Kontrol DAW port for input and output, also the Komplete Kontrol 1 as output. Doesn't that make a difference in FL Studio?

  • SuperTRev
    SuperTRev Member Posts: 89 Member

    Those were already enabled. And the 'SYNC' label means the KK -1 output is sending master sync to the keyboard.

    The only NI driver that isn't enabled is the EXT - 1. I forgot what that does; thought it's for the MIDI thru or something.

  • Uwe303
    Uwe303 Moderator Posts: 2,886 mod

    Try port 102 for the in and out DAW ports, in the FL forum they say you need to set that port for mackie control - maybe that helps

  • SuperTRev
    SuperTRev Member Posts: 89 Member

    Oh. Well, the transport controls were already working. Oddly I didn't have it set to sync. Now I enabled that. No idea what clock the play button was using to blink the metronome. I didn't realize it wasn't synced.

    Tried port 102 and it didn't seem to change anything, but I will take your word on it supposed to be there, so I will leave it.

    It's just two button presses, but it's the principle that bugs me. This problem shouldn't be happening. It's been fine without this issue for like a year now. I haven't used it a lot, so it's not like it's beat up.

  • Uwe303
    Uwe303 Moderator Posts: 2,886 mod

    Mackie Control Universal | Forum (image-line.com) found it here, right now i install a trial and see it myself, i also saw while install, that you can wipe all old settings, so maybe that could be a solution for you, or at least worth a try

  • SuperTRev
    SuperTRev Member Posts: 89 Member

    The transport controls aren't the issue here. The keyboard not initializing its keybed on bootup is the issue.

    The transport controls have always worked for me. Although I have no idea why the author of the controls decided to disregard the metro, tempo, undo and quantize buttons. And to not use the 'loop' button as the pattern/song mode toggle, having the endless encoder button press as the grid snap toggle instead, but ok.

    I just double checked and this same problem is happening in the KK standalone app. So I will reinstall it and see if that fixes it.

  • Uwe303
    Uwe303 Moderator Posts: 2,886 mod

    I know but the mackie is important, so komplete kontrol knows what channel you have selected and then can automatically focus to it, and if kk is loaded there focus on that instance of kk - as far as I know. I also can't find a way that it works, if i select the mixer, for example, i can use the 4d encoder to go through the tracks but it doesn't focus on kk if it is loaded on a track i select. But it should be if i remember correctly.

Back To Top