Why is every other hit louder (using Mouse clicks)?

Ghost_Train
Ghost_Train Member Posts: 21 Member
edited August 2022 in Battery 4

Battery4 - Windows 1064bit pro - Ableton Live 11

Every other hit is louder when using mouse clicks to trigger them. (midi controller does not do this) Its the same on every kit and sound ive tried. The only way to prevent it is to wait almost 1 second before next trigger. I cannot find a way to disable this in Battery. Its drivin me mad. Mad I tell you.

Tagged:

Best Answer

  • Ghost_Train
    Ghost_Train Member Posts: 21 Member
    Answer ✓

    Alright. Good news. I found out how to make it stop doing this, but you have to redo it every time you load a new kit. THANKFULLY this covers all pads in the kit and does not have to be done for each pad individually.

    Setup tab

    Set Voices to 1

    Set Fade to 0

    I wonder why support was unable to help me with this. They made me think there is nothing I can do about it and to accept it because its a cool feature I should enjoy. I'll let them know.

«1

Answers

  • Uwe303
    Uwe303 Moderator Posts: 3,010 mod

    Hello,

    i tried it, and really, if i press a cell two times fast with a mouse click, the voice count goes up to three instead of two, that´s definitely not how it should be . In some cases, if i press not that fast, it counts 2 voices but is louder, but in both cases i guess it´s a layer effect so volume goes up. Maybe something to report.

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    I tried to replicate here (Ableton 11, Win 10 etc.) and did not experience this issue. So not quite sure what the issue might be...🤔🤔

  • Ghost_Train
    Ghost_Train Member Posts: 21 Member
    edited June 2022

    I think i'll report it then, if i can figure out where to do that. Thanks for letting me know.

  • Ghost_Train
    Ghost_Train Member Posts: 21 Member

    Report on the issue has been submitted.

  • Beetleborg93
    Beetleborg93 Member Posts: 12 Member

    This is super annoying especially when putting together kits. If I remember correctly, there was a thread about this a long time ago saying something about battery not being velocity sensitive to mouse clicks but don't quote me I can only vaguely remember.

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    Mouse clicks do not generate different velocities based on mouse positions on the cell. There is a setting in preferences that allow you to set a specific mouse click velocity. I don’t think this is what the OP is having issue with… it appears that his mouse clicks “Are” generating different velocities, but in a random way!

  • Ghost_Train
    Ghost_Train Member Posts: 21 Member
    edited June 2022

    I got a reply from support:

    "Thanks for reaching out. I am sorry to hear you are experiencing issues with our products. It is actually not a bug, it is a feature. This is called - Round Robin. And it was implemented in order to give the it a more human feeling, instead of havin the same velocity value everytime."

    This doesn't seem right at all to me. What would be the point of only having velocity alternate between normal and louder every other click ONLY for sample preview? No one performs with single mouse click, and if they did why would they want volume problems? It doesn't really make sense to me. If its a feature they should at least add a toggle in Preference; Mouse Click Volume Problems: On/Off

    I'm still not buying it though because there are other Battery users who do not have the issue and have said this is a bug when I show them. Will support actually pass it to the devs for review so it can actually get fixed?

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert
    edited June 2022

    If you go to the editor tab, you can see the velocity layers and the samples loaded in each layer… you can preview the layers by enabling “Trigger” and the click on the layers to see if there is a sample loaded that might be causing the issue, round robin should play a hit at the relative same velocity (volume)…being that you state it is a “Big” difference that does not sound right to me either. Also, post a specific kit that this happens on although you said “Every Kit I Tried”


    Edit: Sorry, misstated how round robin works in Battery... it is actually designed to trigger multiple cells one at a time using a single note/key in an order you specify. Round Robin does not work on an individual cell (at least according to the manual). Do post a kit as an example so we can determine "Bug" or "By Design"

  • Beetleborg93
    Beetleborg93 Member Posts: 12 Member

    Not to be negative here but I wouldn't count on this being fixed, especially with it being considered a feature as support has told you. I experience the same problem not matter what kit is being used or if I use my own samples. Battery is long overdue for an update in my opinion so I've moved to another plugin mostly.

  • Ghost_Train
    Ghost_Train Member Posts: 21 Member
    edited June 2022

    It won't let me upload a clip on here unless its zipped. But here's an example.

  • Ghost_Train
    Ghost_Train Member Posts: 21 Member

    How old is Battery 4? That's really unfortunate. The only options for Mouse in preferences is to disable mouse clicks all together or the change the default velocity of the clicks, but nothing at all to disable the alternating volume.

  • Ghost_Train
    Ghost_Train Member Posts: 21 Member
    Answer ✓

    Alright. Good news. I found out how to make it stop doing this, but you have to redo it every time you load a new kit. THANKFULLY this covers all pads in the kit and does not have to be done for each pad individually.

    Setup tab

    Set Voices to 1

    Set Fade to 0

    I wonder why support was unable to help me with this. They made me think there is nothing I can do about it and to accept it because its a cool feature I should enjoy. I'll let them know.

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    It appears what you are hearing is due to the sample stacking due to the two clicks playing the sample simultaneously and the second click firing off prior to the first click sample is finished playing. So basically, it is summing the output of both sample playbacks.

    Battery 4 was release in 2013


    one thing you could try is assigning cells with "Long" playing samples to their own Voice group and then setting "Voices" to "1". that will kill the previous playback when clicking a second time.

  • Ghost_Train
    Ghost_Train Member Posts: 21 Member
    edited June 2022

    No its not stacking. While experimenting even if I wait before clicking again it always triggers louder on the second. It is not overlapping. Really its just silly by design and wish they'd add a toggle in preferences, but like mentioned I found out how to make it play normal. Posted just before your post. Thanks anyway

  • Uwe303
    Uwe303 Moderator Posts: 3,010 mod

    Absolutely, like i said you press once it counts one voice, you press twice fast, it counts three voices, so i guess the second click triggers two voices, makes it louder. But i normally don't play with the mouse and with midi everything is fine. Maybe it is a windows thing, you can set the speed somewhere for double clicks?

Back To Top