Tips: My products are showing up as DEMO in Native Access

Matt_NI Administrator Posts: 1,122 admin
edited February 12 in Native Access

Do you have products showing up as DEMO in your Native Access?

We'd like to share to everyone what are the three steps to consider to solve these issues.

In order:

1. You are not logged in using the right NATIVE ID

It may be that you're logged in via Native Access using another account (Native ID). Please sign in to your account on our website and make sure your products are listed in My Products & Serials (if they are, see steps 2 and 3).

Please keep in mind that Native Access does NOT display bundles but individual products. If you are unsure which products belong to the bundle you own, you can find a very detailed overview of our KOMPLETE versions over the years here:

Native Instruments Komplete Version

If you have multiple accounts or if you are unsure where your products have been registered, please reach out to our registration team.

2. Your activation fails because of corrupted or missing activation tokens

This can be solved by following the steps outlined here:

Native Access Error Message: "Activation failed...Internal error during activation"

Please note that If you can't carry out these steps, you might be missing a “Native Instruments” folder from your computer, located under:

MAC: Users > Shared

WINDOWS: Public > Documents

Please be aware that the folders might be hidden in the folder preferences. Here is how to have them appear if needed: Displaying Hidden Files and Folders on Windows

In this location please create a new folder and name it "Native Instruments", within that folder please create a new folder called "Native Access" and finally, within that an additional folder named "ras3"

The folder structure should then look like this:

Windows: C:\Users\Public\Documents\Native Instruments\Native Access\ras3

Mac OS: Macintosh HD > Users > Shared > Native Instruments > Native Access > ras3

Now please open Native Access (on Windows, as admin by right-clicking the "Native Access.exe" and selecting "run as Admin")

IMPORTANT: if you have moved or relocated your Public > Documents/Users > Shared"- folder to another drive, please undo that change.

3. You have corrupted XML files

This can be easily solved by simply deleting the corrupted XML files and restart Native Access.

You can do as follow:

  • For Mac, go to

Mac HD > Library > Application Support > Native Instruments > Service Center

  • For Windows, go to

C:\Program Files\Common Files\Native Instruments\Service Center

  • Delete the following .xml files:

Native Access.xml


  • Restart Native Access (new .xml files will be created automatically)

If you still see a DEMO warning or you are not sure on how to carry out these steps, please contact us using this form, we'll gladly assist you.



  • Chris Michael
    Chris Michael Member Posts: 6 Member

    hi all

    I’m so puzzled as my traktor pro 3 was working ok up until 2 weeks ago. Thought it may have expired so spent £89 on it. Still stays in demo mode

    tried everything above. Not sure what to do as support just close my file or don’t reply

    i miss my decks so much and wondering if this has happened to anyone else. Traktor pro installs but loops on activation. It’s not just traktor pro though it’s all the programs

    Thankyou for taking time to read and any help is appreciated

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,968 mod

    Isn't there a 4th reason, some products are so old they can't be activated? For example several of my Kore soundpacks show in NA as demo and I've never been able to fix that. Luckily it doesn't seem to stop them working, although the sample based ones have huge problems remembering paths.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod

    Hey @Kymeia Kore soundpacks are legacy products, they were discontinued a long time ago and their activation is not handled by Native Access.

  • JonPlaysBadly
    JonPlaysBadly Member Posts: 1 Newcomer

    Hi, I picked up Kontrol yesterday and registered without problem.

    I upgraded to Komplete 13 Ultimate, but Kontakt still says Demo and says I don't have the necessary base components.

    I AM indeed logged in correctly and I dont get any of the other error messages in part 2 or 3. Does Anyone have any idea?

  • Disco-in-my-punk
    Disco-in-my-punk Member Posts: 1 Member

    well, Berlin the right answer or solve is around here somewhere but i am not sure how to phrase this to find my fix.

    i have an old macbook on 10.11.6 El Cap, its still quite powerful for 11yo as it's a quad i7 late 2011 at 2.4ghz

    i want to keep using it, we waste so much in this world and i don't want to see it wind up as landfill.

    i can not seem to install my realtor 5/6 assets i.e. monark...molekular...polyplex...rounds and so on, all the reactor stuff from NIK12U because they are asking for service center and not native access. so how do i install them?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,968 mod

    I know, however most of them did activate using NA, it's just a few such as Absynth Spectral Expansion, that seem stuck in demo (not that it affects them functionally anyway).

  • NitroDublin
    NitroDublin Member Posts: 10 Member

    Hey Kymeia, I’ve just reinstalled all my Komplete 6 and Kore 2 and soundpacks, I’m on Mavericks and the Native Access for that OS is saying “not connected to internet”, how did you get the software working please?

  • crawley2000
    crawley2000 Member Posts: 1 Member

    I have upgrade to Komplete 14 Ultimate. My serial key is registered with all my other serial keys for my 8 or so NI products. All my programs are in DEMO in Native Access. It started with just the new expansion, but now, after 2 days, all my programmes in Native Access 2 are in DEMO. I have tried activating from Kontakt and Battery, these just ask for an activation, then send me back to Native Access and I do not know how to activate any of the programmes. I have tried the fixes above. I only have one email and one account. All was fine before the Komplete 14 Update. I now have no Native Instruments, and I am really frustrated and want my software back. I have been waiting since Wednesday for an email back, and had nothing. I really hope someone can help and is it something easy.

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    Did you register K14 in Native Access? If you check your Products and Serials page on the NI site it will let you know if it is properly registered or not. If it is, and none of the suggestions you have tried work, official support is the only way to resolve…and as far as that goes, try the Chat feature for Registration Support

    The hours may not be convenient, but the turnaround is way quicker than ticket support.

    Best of luck getting it sorted!

  • pranaearth
    pranaearth Member Posts: 50 Helper

    I have 3 products that are showing up as DEMO. Suggestions given here do not work. Still waiting to hear back from Support.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod

    @pranaearth As you can imagine our support is pretty busy at the moment, so our answering times are a bit delayed. What products are showing as demo ? Are these third party libraries ? Recent ? Old ?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod

    @pranaearth My colleagues got back to you with a possible solution did that work out ?

  • JesterMgee
    JesterMgee Member Posts: 2,683 Expert

    Well never thought id hit an issue with NA but here I am.

    I have Ultimate 13 on my account and in Native Access it shows under "All" 183 products which 80% I have never bothered to ever install or use.

    However I have just built a new machine and going through the installation and notice half the content is showing up as "Demo" with no way to seemingly fix it. I thought maybe some of it is displayed to "try" but there is no way to hide it or just view my "purchaased" content so I would think what shows under "ALL" is stuff I should have access too?

    For instance, Kontakt 6 has been installed and is showing as "Demo". I launch standalone and it asks me to register/buy etc but when I click Register it simply crashes Kontakt. I have uninstalled most stuff again but in the below screenshot content like Kinetik Toys also shows as Demo, thinking probably because Kontakt 6 is not working.

    This is Windows 11,. Kontakt 5 installs and works fine as do the expansions for it, seems Kontakt 6 is not installing correctly or something

    Kind of confused as to what is going on here

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod

    @JesterMgee I see that you contacted my colleagues already. Will keep an eye on it.

This discussion has been closed.
Back To Top