M+ standalone optimized Reaktor content from the community

17810121315

Comments

  • ozon
    ozon Member Posts: 1,226 Expert
    edited October 2022

    It’s not about custom patches… it’s mainly about modified Reaktor Ensembles that were created by NI or somebody else (and belong to them!) and mostly provided here:

    A new platform wouldn’t solve any problems related to ownership and copyrights.

  • ozon
    ozon Member Posts: 1,226 Expert

    With the Maschine+ 1.4 update available, what is your Reaktor version now and are your optimized ensembles still work?

    Mine is on 6.4.4 and most crash the M+ or don’t load or just don’t make any sound.

  • Flexi
    Flexi Member Posts: 366 Pro

    If that's the case, I am not updating.

  • tetsuneko
    tetsuneko Member Posts: 553 Guru

    That's a good point. Let me do the updates to both Maschine desktop and Maschine+ and I will get back to yall on this.

  • tetsuneko
    tetsuneko Member Posts: 553 Guru

    I'm happy to report that all the custom Reaktor content I've optimized still works and recalls in Maschine+ 1.4 OS! However there are now two caveats instead of just one:

    1) Never use a custom Reaktor instrument followed by a custom Reaktor fx! This might trigger an issue where your project mutes its audio on reload

    2) If you save any new presets for the custom instruments / fx, they will not load in Maschine desktop 2.15.1

    But I think this means that it's still possible to build new custom instruments & fx with Reaktor desktop 6.4.3, so at least new stuff can still be built, even if you cannot save Reaktor presets under Maschine+ 1.4 OS and still have them reload in Maschine desktop.

    That's great because I've been planning on optimizing a bode frequency shifter to the M+ soon 😎

  • ozon
    ozon Member Posts: 1,226 Expert

    Asking again, what is your Reaktor version? My guess is you’re still on 6.4.3.

  • tetsuneko
    tetsuneko Member Posts: 553 Guru
    edited May 2022

    6.4.3 on desktop, 6.4.4 in Maschine+

    Reaktor 6.4.4 desktop does not exist yet, its not even in beta AFAIK. It will be a while before we get it.

  • ozon
    ozon Member Posts: 1,226 Expert

    Ok, then it’s really odd that all the Ensembles optimized with 6.4.3 desktop work flawlessly with 6.4.4 on the M+ for you but they didn’t for me.

    I’ll have to revisit all of these Ens (I deleted most because they didn’t work) and check how they behave on the release version.

    If that doesn’t help, I could try to reinstall Reaktor on the M+.

    Unfortunately I don’t have time right now.

  • tetsuneko
    tetsuneko Member Posts: 553 Guru

    yes, sounds odd indeed. Are your Reaktor Factory Content ensembles (lazerbass, newscool etc) loading & recalling with sound perfectly?

    Perhaps NI support could help..?

  • ozon
    ozon Member Posts: 1,226 Expert

    @tetsuneko asked:

    yes, sounds odd indeed. Are your Reaktor Factory Content ensembles (lazerbass, newscool etc) loading & recalling with sound perfectly?

    Yes, factory ensembles are fine (loading and recalling), as well as some very old Ensembles from the User Library which I prepared myself (Howl, TickTock, MeanMachine, OkiComputer, JUNO-6).

    However, except for the already mentioned custom filter (R6C Nonlinear SVF), none of your Ensembles as well as others which previously worked for me (MrMONO, JUNO-60) can be loaded. M+ crashes while trying to load.

    Unfortunately there is no way I can reinstall Reaktor on the M+: The Uninstall button is greyed out for any default content.

  • Anthurium
    Anthurium Member Posts: 1 Newcomer
    edited May 2022

    Hey guys, thanks for your work on these - absolutely loving having the VHS suite and Space Echo in standalone mode!

    I spent a few hours last night trying to get these two working:

    https://www.native-instruments.com/en/reaktor-community/reaktor-user-library/entry/show/13739/


    But havent had any luck :(

    I can get them to show up in the browser of + by changing the meta data to effect, and mapped controls appear, but no audio passes through the effect.

    Any chance of a post detailing how i might approach adjusting these to work?

    I'd really like to use Reaktor to build some key utilities that i think + is missing, like sync'd autopan, and sync'd filter modulation. Never done any Reaktor builds before, so would be cool to know what the key is to making them compatible with +.

    And since i'm here, i came across this nice clouds style granular ensemble in the user library that is optimized for Maschine+, havent seen it shared here yet - very light on CPU too 😀

    https://www.native-instruments.com/en/reaktor-community/reaktor-user-library/entry/show/14331/

    --

    EDIT - went ahead and built my first Reaktor ensemble, a basic Autopan. Works great in the Maschine software, but i can't for the life of me get it to work on the +, it's driving me crazy. I'm also on 6.4.3 Reaktor software and 6.4.4 on the +. Other ensembles are still working though, so it feels like it's gotta be something else im doing wrong.

  • ozon
    ozon Member Posts: 1,226 Expert
    edited May 2022

    Update uploaded for OZON Stereo Width. New version allows to select which channel to use (Left/Right/Stereo).

    It's now called Stereo Utility and available from the Reaktor User Library here:

    Enjoy!

  • tetsuneko
    tetsuneko Member Posts: 553 Guru
    edited May 2022

    That lopass gate ens looks very tasty! I'll take a look at it as well. If it's just an audio effect without MIDI, should be trivial to optimize for Maschine+. Want to try this in addition to that Bode Frequency Shifter I was talking about earlier.

  • felipeazucares
    felipeazucares Member Posts: 26 Member

    I’ve followed the instructions here: https://octobird.org/the-ultimate-magic-way-to-get-your-reaktor-stuff-running-on-native-instruments-maschine/ and here : https://support.native-instruments.com/hc/en-us/articles/209544869-How-to-Optimize-your-REAKTOR-Ensembles-for-MASCHINE-2 but I’m yet to have any success getting anything working standalone yet. I’ver tried some of the factory library effects (classic vocoder) and had no luck. Tried the Serious Vocoder and other ensembles listed in this thread https://community.native-instruments.com/discussion/1836/user-reaktor-ensembles-on-maschine-standalone & don’t seem to be able to get any sound out of any them. I’ve even built a my own very simple sampler ensemble just to try the simplest instrument possible and no joy. It seems the moment I add a reaktor plug-in in to the slot and load an ensemble in I’m unable to get a signal out of the plug in. They all work in maschine when using the Plus in controller mode. I’ve got a full reaktor application licence v.6.4.4 (upgraded to be able to do this!) and am on system version 1.4.0.3 & Maschine version 2.15.1(R7) & firmware 0.16. Does anyone have any recommendations. Would dearly love to get on this train, but am having no success. Thanks in advance.

  • ozon
    ozon Member Posts: 1,226 Expert

    Contact support. I had a similar problem on my M+. The cause was Reaktor not properly updating to the most recent version. Support sent me a special reset file after which Reaktor was working correctly.

Back To Top