MacOS 14 Sonoma issues with Native Access

Options
1246

Answers

  • jluis7
    jluis7 Member Posts: 3 Member
    Options

    I was able to get this problem SOLVED by downgrading Native Access 2 to Native Access 1. I know it may sound weird, but the older version of Native Access DOES NOT HAVE PROBLEMS WITH SONOMA.

    After downgrading Native Access, I was able to update ALL of my NI apps and also re-install Kontak 7 (which was giving me issues). No longer my apps were stuck on updating.

    Perhaps NI should look at the Native Access code to get their current version up to speed.

    Since I am new to the forum, NI will not let me post a link. But if you just look on the support site and type: "How to Downgrade Native Access 2 to Native Access 1". You will find the steps there.

    I hope this helps some of you.

    Cheers!

  • mpc16
    mpc16 Member Posts: 1 Newcomer
    Options

    Vu le prix des logiciels de chez NI et le cycle de bêta de macOS, je trouve vraiment dommage que la compatibilité avec le dernier OS soit aussi long à arriver. Pourtant j’adore les produits de chez NI, mais la c’est vraiment plus que dommage.

  • tombuur
    tombuur Member Posts: 16 Member
    Options

    I concluded exactly the same things earlier in this thread. I don't understand why NI doesn't fix this major problem (NI Access unable to download) in a few days when it is working in an older version. There may be other compatibility problems to solve along the way, but those aren't as crucial as the failure to download which is actually means full stop.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,867 mod
    edited November 2023
    Options

    That's interesting, for me it was the other way round, when I first setup my M1 Studio Max (on Big Sur originally) NA just would not download some Kontakt libraries, switching to NA 2 solved that for me and I continue not to have problems with it now on Sonoma. Maybe it has something to do with the sequence of installing it since NA2 has been on my system since Big Sur? I can understand why it is harder for NI to fix stuff like this when user experiences differ so much, there seem to be many variables at play (things beta tests tend not to pick up as well as they are more about real world scenarios, not testing ones)

  • Jolarua
    Jolarua Member Posts: 1 Newcomer
    Options

    Hey, for all my folks out there running on Sonoma and having problems installing NI stuff with native access 2. httsupport.native-instruments.com/hc/es/articles/360000407909-Instaladores-de-Native-Access-para-versiones-anteriores-de-sistemas-operativos Try out installing this old version and re installing your stuff, I gave it a try and after many hours errors with all the official website recommendations it worked at first try.

  • viper9711
    viper9711 Member Posts: 110 Advisor
    Options

    No problems with Native Access at MacBook M1 Pro Sonoma 14.1.1

  • DonnyMacc
    DonnyMacc Member Posts: 7 Member
    Options

    I've tried downgrading NA from 2 to 1 but that didn't work for me unfortunately, just a "download failed unknown error" message.

    When I emailed support previously after @Jeremy_NI suggested they could provide installers for some applications I was simply told my only option was to downgrade Sonoma, I was a little disappointed with the response but thought a solution to this issue was just around the corner so didn't want to make a fuss.

    We're now heading towards the end of the year and still no idea when I'll be able to update any NI apps or packs.

  • harrismix
    harrismix Member Posts: 3 Member
    Options

    Surely the way around this is for them just to post on their website, direct download links that anyone can use who is having trouble with Native Access? why not just do that?

  • Vocalpoint
    Vocalpoint Member Posts: 1,110 Guru
    Options

    If that was a solution - it would have happened by now.

    VP

  • monkeytrix
    monkeytrix Member Posts: 1 Member
    Options

    Just ask for direct download links for the products that are supported and you will get a complete list.

  • howiem
    howiem Member Posts: 4 Newcomer
    edited December 2023
    Options

    OK - I've been struggling w downloading larger packages, with the Strad Cello proving a real problem. I'd get "Download Failed", hit Retry, and NA would instantly fail again, without seeming to make any attempt to resume the download. No brief "Calculating time remaining..." thing - just an instant retry->fail.

    But I managed to get it to download successfully just now by using a VPN, just for a minute. Switching on the VPN and then hitting Retry worked - the download resumed properly. After a minute or so I paused it, switched the VPN back off again and unpaused the download and it completed successfully.

    I've probably spend a couple of hours retrying / deleting broken downloads / etc over the last few days, but this, finally, seems to have solved the problem. For me at least.

    So: switching on a VPN can unstick the Download Failed loop. Which makes me wonder if it's an ISP caching issue. May be a clue, @Jeremy_NI - perhaps you may need to add a nonce [or similar] to the requests to artifacts-cdn.native-instruments.com to avoid caching issues?

  • abadr
    abadr Member Posts: 1 Newcomer
    Options

    Just adding that I connected to Nord VPN (I have a private IP - not sure if that makes a difference) allowed me to install everything through the latest version of Native Access. So, likely some kind of networking issue that NI need to update their app for in Sonoma. FWIW I left the VPN connected for the entire download.

    Hope this helps others.

  • mbishop
    mbishop Member Posts: 3 Member
    edited December 2023
    Options

    FWIW, this is what comes out of my log when it fails…

    I don't know if this is of assistance @Jeremy_NI . I'm happy to run any further tests to help troubleshoot.

    [info] [2023-12-12 15:46:45] "0x16d287000":DaemonMessenger.h:253 IN   00800041EC   MSG: REQUEST: ResumeDownloadRequest for DeploymentID: 8e928eac-828c-490b-a189-ee18fffeee6b
    [info] [2023-12-12 15:46:45] "0x16dceb000":DaemonMessenger.h:253 OUT   00800041EC   MSG: RESPONSE: SuccessResponse
    [warning] [2023-12-12 15:46:45] "0x16d65b000":Tracker.cpp:257 No context found for DeploymentID: 8e928eac-828c-490b-a189-ee18fffeee6b
    [info] [2023-12-12 15:46:45] "0x16da2f000":EventPublisher.cpp:238 PUBLISH: EVENT: Download Queue Changed
    [info] [2023-12-12 15:46:45] "0x16da2f000":EventPublisher.cpp:238 PUBLISH: EVENT: DownloadStarted (DeploymentID: 8e928eac-828c-490b-a189-ee18fffeee6b, Upid: 153af726-e8ea-4355-9550-92189a7955d6)
    [warning] [2023-12-12 15:46:45] "0x16d313000":ProductDownloader.cpp:444 Download 8e928eac-828c-490b-a189-ee18fffeee6b failed with error could not parse Metalink document. Moving to failed queue
    [warning] [2023-12-12 15:46:45] "0x16d65b000":Tracker.cpp:303 No context found for DeploymentID: 8e928eac-828c-490b-a189-ee18fffeee6b
    [info] [2023-12-12 15:46:45] "0x16da2f000":EventPublisher.cpp:238 PUBLISH: EVENT: DownloadFailed (DeploymentID: 8e928eac-828c-490b-a189-ee18fffeee6b, Upid: 153af726-e8ea-4355-9550-92189a7955d6, Error: 13)
    [info] [2023-12-12 15:46:46] "0x16d287000":DaemonMessenger.h:253 IN   00800041ED   MSG: REQUEST: ActiveDeploymentsRequest
    [info] [2023-12-12 15:46:46] "0x16dceb000":DaemonMessenger.h:253 OUT   00800041ED   MSG: RESPONSE: ActiveDeploymentsResponse (Deployments count: 2)
    


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,965 mod
    Options

    @howiem @mbishop Native Access 3.8.0 was just released and brings compatibility for Sonoma and various bug fixes. I invite you to install the latest update and see if your issues are gone. If not please contact my colleagues here: http://bit.ly/NIsupport_install

    More info here:

    Native Access 3.8.0 now live!

    Official update status - Native Access (current version: 3.8.0)

Back To Top