New Battery 4 update crashes Studio One in Native and Rosetta mode

momos Member Posts: 18 Member
edited January 2023 in Battery 4


the newest update to Battery 4 crashes Studio One.

Steps to reproduce:

It happens with Studio One 5 and 6 with Rosetta and without Rosetta mode. Both newest version.

1.) Open an older (perhaps saved as a VST2 project????) project where Battery 4 has the bug off missing samples like this:

2.) Doesn't matter what you click, "Skip Missing", "Search Spotlight" etc. it will crash always.

3.) After Battery opens, click either the "x" button on the upper right corner or select any of the other instruments in the top tab menu.

4.) Studio One will crash immediately


  • momos
    momos Member Posts: 18 Member

    So it's actually unusable for me right now because almost all of my projects have the "Missing Files" bug where I have to search them first.

  • EC333
    EC333 Member Posts: 2 Newcomer

    I've got the same problem running Battery in the latest version of Ableton 11 Suite on a Mac. I get the 'Missing Samples' notification, then when I press any one of the search buttons it begins searching then crashes Ableton. Happens every time since I downloaded the latest update. It's not the first bug I've encountered using Battery but it's by far the worst. I'm guessing I'll have to try rolling it back to an earlier version. I stopped using it about a year ago after it started getting flaky but I've got hundreds of older projects that use it. It's a nightmare. If anyone has a solution I'd love to hear it.

  • momos
    momos Member Posts: 18 Member

    I am in contact with the support and they were able to reproduce the issue and are aware of it.

    Of course the couldn't say when it will be fixed but I am sure they are working on it.

  • EC333
    EC333 Member Posts: 2 Newcomer

    1. Delete the User Preference (PLIST) File

    1. Go to the following location of your computer:
    2. Macintosh HD > Users > *Your User Name* > Library > Preferences
    3. Note: The User Library is a hidden folder on macOS. See this article for instructions to access this hidden system location.
    4. Search through the Preferences folder at this location, to find the plist file for the NI product that is crashing. The plist file will be named in this format:
    5. com.native-instruments.*PRODUCT NAME*.plist
    6. Delete only the plist file for the NI product that is crashing.
    7. Note: Deleting other plist files could result in unexpected behaviour with other applications.
    8. Reopen your NI software to check that the issue has been resolved.

    This worked for me. You might have love with it. Still the same old ball ache of having to search for missing files almost every time I open an instance of Battery but at least it has stopped crashing Ableton.

  • momos
    momos Member Posts: 18 Member

    Doesn't work for me sadly. But thanks anyways.

  • Mr. Watt
    Mr. Watt Member Posts: 1 Newcomer

    Same issue here. It also crashes when loaded inside of komplete kontrol when I try to close that window as well. Seems to just be the vst3 version at this point of both that's causing the issue.

Back To Top