No sound to my speakers from Kontrol s2 using traktor pro 3

Kota dean
Kota dean Member Posts: 3 Newcomer
edited January 2023 in Traktor Software & Hardware

Hi Guys,

would really appreciate some advice, I'm usung a kontrol s2 with traktor pro 3. I have sound coming out of my headphones but not my speakers.

This is my configuration, it looks like it's set up correctly but as said no sound from speakers on headphone.


any help would be very much appreciated.


TIA

Best Answer

  • lord-carlos
    lord-carlos Member Posts: 2,054 Expert
    Answer ✓

    Traktor only supports one audio interface at a time.

    Best is to connect everything to the DJ controller.

    You can also do some software magic with ASIO4all or voicemeeter. But it never really worked for me without audio dropouts.

Answers

  • Leleerre
    Leleerre Member Posts: 9 Member

    Hello,

    give some more info ...

    where did you connect the speakers?

  • Kota dean
    Kota dean Member Posts: 3 Newcomer

    Thanks for getting back to me

    laptop win 11 intel core i7 16gb ram

    My speakers are plugged into focusrite. If I change my audio setting to audio device to focusrite then I get sound out of my speakers but then I don't get sound out of my headphones. headphones are plugged into my S2 controller.

    In output routing mixing mode is set to internal

    output monitor set on monitor left and right

    output master set to master left mand right

    I have no other options in those settings.

    Thanks


    Lee

  • lord-carlos
    lord-carlos Member Posts: 2,054 Expert
    Answer ✓

    Traktor only supports one audio interface at a time.

    Best is to connect everything to the DJ controller.

    You can also do some software magic with ASIO4all or voicemeeter. But it never really worked for me without audio dropouts.

  • Kota dean
    Kota dean Member Posts: 3 Newcomer

    Dude, you have literally stop me from having a breakdown :-) you sir are most certainly a lord!!

    That's solved my problem..... Thank you

Back To Top