NA cant find 32bit plugins - repair not possible. Can I ignore?

Options
Murat Kayi
Murat Kayi Member Posts: 433 Pro
edited February 2022 in Native Access

Hi,

for a while now NA complains it's not able to locate 32bit versions of plugins. Mostly it's the Komplete effects, but sometimes bigger suites like Battery.

Now, everything runs smoothly when I use it. I am on a 64bit PC so I basically couldn't care less wether the 32 bit plugins are there or not. But it's a nuisance. The two folders are right next to each other, duly configured in the prefs, too. What's going on, here? Can I safely ignore this?

Tagged:

Best Answer

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert
    Answer ✓
    Options

    The issue here is that the Update Installers for some products do not remover a specific registry key that makes NA think that the 32 bit plug is missing when it is actually not available (due to deprecation of 32bit).

    the registry key is:

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Native Instruments\{product name here}

    in node for the product, look for an entry called "InstallVSTDir" and delete it. (backup the registry first just in case) and NA will no longer indicate that the product requires Repair.

    Hope that helps!!!

    P.S. NI is aware of the issue!

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,655 Expert
    Options

     Can I safely ignore this?

    Yeah, I do

  • Murat Kayi
    Murat Kayi Member Posts: 433 Pro
    Options

    Ok, but will it ever end?

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert
    Answer ✓
    Options

    The issue here is that the Update Installers for some products do not remover a specific registry key that makes NA think that the 32 bit plug is missing when it is actually not available (due to deprecation of 32bit).

    the registry key is:

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Native Instruments\{product name here}

    in node for the product, look for an entry called "InstallVSTDir" and delete it. (backup the registry first just in case) and NA will no longer indicate that the product requires Repair.

    Hope that helps!!!

    P.S. NI is aware of the issue!

  • Murat Kayi
    Murat Kayi Member Posts: 433 Pro
    Options

    Ok, will check and report back. Thanks!

  • Murat Kayi
    Murat Kayi Member Posts: 433 Pro
    Options

    So, this solved it, as I also reported in the other thread (the topic there is slightly different, I just had the impression that several problems around the installation might be connected, but maybe they are separate problems). Thank you very much!

Back To Top