Komplete Kontrol Software no sustain, what could it be?

Leyend23
Leyend23 Member Posts: 2 Newcomer
edited November 2022 in Komplete Kontrol

When I connect a MIDI controller to the KK software the sustain pedal does not work; instead, KK software seems to automatically re-map the sustain pedal/CC 64 signal to left knob on the screen (affecting what ever effect might be set for the instrument that is loaded).


Here a few things I have tried or to note:

Confirmed that MIDI Controllers are sending CC 64 (using a MIDI monitor app).

Confirmed that CC 64 is setup as CC# for Sustain inside the instruments that opens in KK software (E.g. Alicia’s Keys).

MIDI Controllers work fine when used “directly” within another software (E.g., Kontakt 5).

The knob that moves (in KK) when sustain is pressed is NOT set to CC 64.

Deleted the KK software and reinstalled it.

Using a MAC.

Tried M32 and others non-NI controllers (same outcome).


 IF I set the Instrument and the MIDI controller to use a different CC message for sustain then the sustain will work fine. This is not solution for me, since M32 is my only controller that can change that CC messages for sustain. Also, it will be tedious to change CC for all instruments. (just saying this to help other better understand where my issue could be).

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,946 mod
    Answer ✓

    Check the following: 

    • Open Komplete Kontrol in standalone with your keyboard connected.
    • Click on the MIDI icon
    • Double check that no button or any other parameter is set to MIDI CC 64 (sustain)
    • To be sure, you can reset the MIDI template to default by clicking the + sight on the left.

     Now disconnect the keyboard, click on the MIDI logo, 

    • Check if there isn’t any MIDI CC64 assigned to any of the knobs :
    • Click on the x to unassign any CC message.
    • Repeat the process for the buttons :


Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,946 mod
    Answer ✓

    Check the following: 

    • Open Komplete Kontrol in standalone with your keyboard connected.
    • Click on the MIDI icon
    • Double check that no button or any other parameter is set to MIDI CC 64 (sustain)
    • To be sure, you can reset the MIDI template to default by clicking the + sight on the left.

     Now disconnect the keyboard, click on the MIDI logo, 

    • Check if there isn’t any MIDI CC64 assigned to any of the knobs :
    • Click on the x to unassign any CC message.
    • Repeat the process for the buttons :


  • Leyend23
    Leyend23 Member Posts: 2 Newcomer

    Thanks a lot @Jeremy_NI , that fixed my sustain pedal assignment issue.

  • xspiritmental
    xspiritmental Member Posts: 2 Newcomer

    thank you for this, however on my version i don't have that icon on the top right. i tried for 5 days and i can't get my sustain pedal to work. i tried the polarity settings (no switch so the on and off holding down pedal trick).

    tried reconfiguring the midi without the icon to port A. still nothing. my pedal works fine however in record mode, it doesn't keep my sustained notes after i record. could really use help before purchasing another pedal. i tried on the komplete kontrol s49, i'm using s61 and it does the same thing which leaves me to believe it isn't my pedal.

    if i can just get to that icon to reconfigure the pedal that might work, however i cannot get it :(.

    thank you kindly.

    spirit


  • xspiritmental
    xspiritmental Member Posts: 2 Newcomer

    i've seem to manage a bit of sustain through komplete kontrol however, now kontakt is not sustaining. same issue. thank you so much.

    spirit

  • isaacdynys
    isaacdynys Member Posts: 3 Newcomer

    Mine looks different. The midi icon is different, and there's no option to reset midi mapping. I'm so lost. I've tried so many things. Do I need a different keyboard or sustain pedal?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,946 mod

    @xspiritmental I'm really sorry, I just saw your comment now. Please read my post carefully, you get the MIDI 5 pin logo icon only when the keyboard is NOT connected. Do you still need assistance on this? You don't mention in which DAW this happens.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,946 mod

    @isaacdynys Yes, the layout changed a bit with Komplete Kontrol 3.0. What keyboard and what sustain pedal are you using?

Back To Top