NA 3 works fine but offers me to update, should I ?

Kaldosh
Kaldosh FranceMember Posts: 91 Tri
edited November 4 in Maschine

I installed last update of Native Access and it seems to work much better thank you.

Though it offers me to update Maschine to 2.16 with all VST3 support M1 bells and wistles ....

Since I am on Mojave 10.14.6 (released July 21, 2021) on an Intel platform i7 8700k cpu...I see in the releases note that my computer should be minimum on Big Sur ?

This would push me to upgrade my whole working system for an insane amount.

Will this work anyway ? or is there a workaround ? I know vst 3 worked more or less fine on Mojave during tests , or is this just the end of the road for me ?


Thank you

Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod
    Answer ✓

    @Kaldosh These new updates are not officially supported, it means that it's not tested anymore by NI, if there is a bug or a malfunction of some sort with this OS, it will not get fixed. It can work but it's at your own risk. There is an ongoing debate whether we should offer these updates on unsupported systems in Native Access or not, or if we should provide it per request or knowledge base article with a proper disclaimer. For now they are still available in Native Access. Fortunately you read the release notes, not everybody does!

    If you tested it and it seems to work fine, then go for it, but keep in mind that at some point, things might break, so be careful when you save your projects. It might be a good idea to make some kind of backup of your projects where you know exactly what version was used and that it was working 100%. I hope this helps.

Answers

  • Jaheid19
    Jaheid19 Member Posts: 28 Sine

    In this article it says Intel Mac should transition just fine. but I found myself hesitant and asked the same question in my post.

    Are you able to cite the article that says the OS of Big Sur is the lowest requirement after this update?

    I've been researching all day and haven't come across that. Ive been running in OS Catalina 10.15.7 on a 2012 Intel Mac thus far in 2.15

  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri

    Printed from NA Maschine 2 release notes


  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri

    Same for Komplete Kontrol


  • D-One
    D-One PortugalModerator Posts: 796 mod
    edited November 4

    @Kaldosh said:

    This would push me to upgrade my whole working system for an insane amount.

    What do you mean insane amount? We have the same computer, no? I'm on Ventura right now and it didn't cost me any $.


    @Kaldosh said:

    Will this work anyway ? or is there a workaround ? I know vst 3 worked more or less fine on Mojave during tests , or is this just the end of the road for me ?

    Hard to say but it might. What do you mean VST3 worked during tests? VST3 is working on MacOS since forever, or are you talking about VST3 in Maschine?

  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri
    edited November 4

    Well I bought a nice Bundle from NI few years ago during a partnership with Waves which I didn't know came with their upgrade plan tied to OS upgrades. I still use most of them and whish not to pay any extras just to be allowed to use the same plugin on a different OS. I am still using older screens and my max res is 1920x1080 on one of the three. also, I don't need resizing and use the Zoom function from Mac Os if needed. i am using V10,11,12 versions and have about 33/34 Waves plugins .

    None of the Mac OS upgrade offers me better sounding music and rather keep tools I really use than new OS productivity updates for what I do. I am surpised from NI side as well to drop support so soon for Mojave.

    I didn't ask Waves though if their was a possibility to use my old plugins on newer system like any other manufacturers offfers. It's not like going from/to 32/64 bits like ( (sorry I want to laugh)).

    Indeed we have the same computer but probably not the same mouthes to feed 😉 , though, for many reasons there is always that way too unreasonable pressures making things turning so wrong I think .

    If anyone has feedback on if or how it runs on mojave please let me now, I won't be the one to try out 😋

    Thanks

  • D-One
    D-One PortugalModerator Posts: 796 mod
    edited November 4

    I'm still a bit confused... So, you can't update because your Waves bundle won't work on a newer OS? Not sure what screen resolution has to do with any of this tho.. I asked because if you're having issues with your Hackintosh I could help, since we have roughly the same system.

    I am surpised from NI side as well to drop support so soon for Mojave.

    They have been officially supporting only 3 versions for a long time but I understand it's annoying.


    Indeed we have the same computer but probably not the same mouthes to feed 😉 

    Only 2 mouths to feed here and the pandemic absolutely destroyed my financial stability since it was 2 years with zero work and the same bills, not sure what that has to do with anything but regardless good luck!

  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri

    Well, it all has to do with everything really, as you said, pandemic has been tough on everyboday and I can use all of my plugings but Waves if i update to next OS Catalina.

    And all the plugins I would have to upgrade would literally only bringing maybe a new UI and the right to use it (wich I already bought) and that is all. It is no V2 with no feature or anything and it was a purchase, not a subscription when I bought it . Anyway, I am not the first, I won't be the last .

    Also indeed I would have to redo it all over again regarding setup even though it is already well organised in case of formating OS, really Waves plugin are probably the only reason I am stuck here since 3 years

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod
    Answer ✓

    @Kaldosh These new updates are not officially supported, it means that it's not tested anymore by NI, if there is a bug or a malfunction of some sort with this OS, it will not get fixed. It can work but it's at your own risk. There is an ongoing debate whether we should offer these updates on unsupported systems in Native Access or not, or if we should provide it per request or knowledge base article with a proper disclaimer. For now they are still available in Native Access. Fortunately you read the release notes, not everybody does!

    If you tested it and it seems to work fine, then go for it, but keep in mind that at some point, things might break, so be careful when you save your projects. It might be a good idea to make some kind of backup of your projects where you know exactly what version was used and that it was working 100%. I hope this helps.

  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri

    @Jeremy_NI Thanks, I am actually testing few things and just realised that the last updated version of Maschine's seem to install the Standalone 2.16 version + Maschine Vst & Vst3 plugin but there is no Vst3 Version of Maschine 2 FX.vst3 plugin .

    Would it be a bug in the installer or did you simply not update the Maschine FX plugin ?

    As I am testing now, the Maschine FX.vst2 seem to be bugged by the installation of last Maschine 2.16 version and I get mapping bugs in Ableton so I don't know if it is just because I am on Intel platform, on Mojave or if it is simply a general bug in the release

Back To Top