Maschine Template, Controller Editor, NIHostIntegration

Kaldosh
Kaldosh FranceMember Posts: 91 Tri
edited October 14 in Maschine

Hi All,

Opening this thread as for some reason my Ableton Live 10 Studio template for MAschine Studio starts to behave strangely and lose informations on screen such as Track number, Device in focus, Device Bank Name for stock instruments etc etc.

I wonder if this could be the last Controller Editor Update which happened 10 days ago maybe.

I am working on downgrading to test that out but was wondering if anyone had this issue before.

If I restart computer it works again but loses it as soon as I switch devices.


Now, any help would be much appreciated

Peace !

Tagged:

Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @Kaldosh What version of Controller Editor are you using now? What version were you using before? I could post a link for an installer here.

  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri

    It says vers 2.7.6 which seems to be the last one to this date.

    Though I found 2.6.2 in legacy versions which is still be fine for my setup generation.

    So you think it comes from Controller editor ? Does it means that if I acquire an M+ I'll have to deal with different Controller editor versions ?

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    Well, we didn't have reports with Maschine Studio behaving different yet with Controller Editor 2.7.6, did downgrading fix the issue? If it's definitely an issue with 2.7.6 can you describe what happens in detail so we can try and reproduce the issue.

  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri

    I feel there is strange behaviour in Controller Editor with knobs touch button registration. I use to turn off the push section for a knob in CE when making my template just so it doesn't autoselect the secondary push section when mapping a knob .

    Though The only file I found was CE 2.6.2 though the previous stable version i used was 2.7.1 I. but I could probably be happy with that since if I'am not mistaken between the two version it is just new devices additions but no particular new feature ?

    Thanks

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @Kaldosh We'd need to get more info on your issue, possibly also a video showcasing the issue, if you're ok for that, I'll contact you by email.

  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri

    Sure no problem

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @Kaldosh Sorry to get back to you so late. I just realised you were on 10.14, right? What version of the Maschine software are you using?

  • Kaldosh
    Kaldosh FranceMember Posts: 91 Tri

    Last update 2.15.2

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @Kaldosh Here is the installer for 2.7.1: Controller Editor 2.7.1 for Mac

    Does this version work as expected ?

Back To Top