Traktor S2 midi mapping

Sakozzy
Sakozzy Member Posts: 6 Newcomer
edited February 27 in Mapping Traktor

Hey all,

Recently bought Traktor S2 MK3. I'm trying to midi map my 5 6 7 8 buttons to have more effects accessible at the same time, but I ran into a problem here. 

From the UI side, everything looks good. I can turn on and turn off the effect:

But I can't hear any changes while I'm mixing. Maybe you have an idea what I miss?


Originally, the device was a Generic keyboard (you can see that in the screenshot), but if I try to midi map on that device, I'm not able to use my Traktor S2, only a computer keyboard. So that is why I created a new device (S2MK3).


Thanks in advance for your help!

Tagged:

Comments

  • lord-carlos
    lord-carlos Member Posts: 2,318 Expert

    Can you upload the images to the forum? It seems you embedded them directly from gmail, that will not work. Unless you want to give us access to email account :P

  • Sakozzy
    Sakozzy Member Posts: 6 Newcomer

    Sorry, my bad:


    Hey all,

    Recently bought Traktor S2 MK3. I'm trying to midi map my 5 6 7 8 buttons to have more effects accessible at the same time, but I ran into a problem here. 

    From the UI side, everything looks good. I can turn on and turn off the effect:

    But I can't hear any changes while I'm mixing. Maybe you have an idea what I miss?


    Originally, the device was a Generic keyboard (you can see that in the screenshot), but if I try to midi map on that device, I'm not able to use my Traktor S2, only a computer keyboard. So that is why I created a new device (S2MK3).

    Thanks in advance for your help!

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,719 mod
    edited August 2022

    On that last page please click on one of the controls (Unit 1 for example) so we can see the values. Also please expand the window's width.

    Also make sure you only have one (1) S2Mk3 mapping in the dropdown list listed. And check the checkbox 'Override factory map' for every assigned control.

    Edit: Do you have FX3 channel toggle active for your deck? You will have to do this on the computer screen (for testing) but you can create an additional assignment for it. You will find the command in the mixer subsection.

  • Sakozzy
    Sakozzy Member Posts: 6 Newcomer

    @Sûlherokhh thank you for your reply. Here is a full-width screenshot:

    As you can see only one S2MK3 is in the list and FX3 channel is active.

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,719 mod

    I am sorry. What i also need to assess what is going on is

    1. a view of the center channel columns of the main screen, the one where equalizers and filters are shown,
    2. an expanded view of the preferences window, so the full length of the control lines (including conditions) is shown, although at least 'Unit On' doesn't have any and otherwise looks just the way it should.

    #1 is most important. There should be 4 check boxes for each deck, 1 for each FX Unit. Those need to be checked so that the audio is routed to the FX Units and back. 🦋

  • Sakozzy
    Sakozzy Member Posts: 6 Newcomer

    Thank you a lot. Hope that's okay, if you need anything else just let me know.



    Domas

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,719 mod

    On your screen there is a knob for GAIN, below that a knob for FILTER, aaaaand below that are four numbers in a box, 1, 2, 3 and 4.

    Press 3 for your deck. This will channel the audio of your deck to FX Unit 3.

    If you have any more trouble, let us know. 🍁

  • Sakozzy
    Sakozzy Member Posts: 6 Newcomer

    Amazing! Thank you a lot for your help! Cheers!

Back To Top