Anyone else having problems with Traktor & Beatport Link connecting right now?

d_j_m
d_j_m earthsideMember Posts: 24 Sine

Not sure why, it worked fine a couple of days ago. Just turned my S4 and laptop on ready to try out a new playlist I made on Beatport Link and it's not connecting with Traktor all of a sudden?

Anyone else having this problem?

Best Answer

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin
    Answer ✓

    Hi all, confirming that there was an issue on Beatport's side yesterday which caused a breakage.

    They've rolled back the update and everything should now be working as before.

Answers

  • Olivia Rose Mack
    Olivia Rose Mack Member Posts: 1 Noise
    edited June 15

    I am having this same issue with Traktor Pro 3. It connects to beatport Link by opening a browser and then sending me back to the traktor pro 3 app, but then it says "Could not retrieve the content of this playlist" for anything I try to play from beatport link.

  • d_j_m
    d_j_m earthsideMember Posts: 24 Sine

    Okay... i just saw someone else here saying they are having the same problem with Beatsource. This is super annoying. I really wanted to kick it with BPL tonight and play with some new stuff.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin
    Answer ✓

    Hi all, confirming that there was an issue on Beatport's side yesterday which caused a breakage.

    They've rolled back the update and everything should now be working as before.

  • xtc091157
    xtc091157 Dallas, TX, USAMember Posts: 2 Noise

    I am having this problem. The last message from this thread is two weeks ago. Is there still a problem with Beatport?

  • Lee Sexton
    Lee Sexton Member Posts: 3 Sine

    still an issue here, can#'t even link beatport to traktor 3.5.3 303

  • awol9000
    awol9000 Burnaby, BC, CanadaMember Posts: 25 Sine
  • Lee Sexton
    Lee Sexton Member Posts: 3 Sine

    update works with the beta version which sadly expires in a few days, totally points to the app being the issue if the beta version works fine.....not ideal

Back To Top