Native Access should not allow installation of incompatible versions

RichBass
RichBass Member Posts: 27 Member

I'd like to add a feature request similar to the 'Native Access should allow downgrading and removing an installation' request.

How about Native Access disallow the installation of incompatible versions altogether? I have an extremely minimal amount of time per week to use Maschine, and lately I've been burning most of that time trying to address crashes. I just want to make music, man!!!! Anyway, I'm about ready to give up and consider NI a lost cause for me as I do not have the time for this.

I found out later via search that for Monterey, I should be using an earlier version of Maschine! With so many of the various NI products I have, I do not have time to carefully consider each and every one to determine compatibility, but the way NA is today, this seems to be the best path. I do not have time for this. No, I want to just hit "Update All" and get back to making music. Free Mac utilities can detect my OS and processor and then limit my ability to 'upgrade' to incompatible versions, so I expect the same of a platform I've spent so much money on.

Comments

  • RichBass
    RichBass Member Posts: 27 Member

    Additionally, along these same lines, I should NOT have to scour the forum for a download link to a compatible version for my system. This should be plainly and easily available on the main downloads page (assuming it's not going to be addressed in Native Access).

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    Hi @RichBass already products that are not compatible with your OS won't show up in your Native Access. Curious which version of Maschine you're using? Cause it should be compatible with Monterey.

  • RichBass
    RichBass Member Posts: 27 Member

    Hi @Kaiwan_NI I was on 2.15.2, but it was not launching, so I reverted which seemed to work. But... now even 2.14.6 isn't launching. I asked via email support how to revert my Maschine+ to an earlier version and it was suggested that something on my Mac may in fact be changing something with Maschine that's causing it to not launch. I have no idea how to debug that, but if Native Access already handles this, then I guess this request is unnecessary! My apologies for the noise

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    @RichBass No worries. Btw I didn't know your original post is about Maschine+. Hope our support team can help solve the issue on your Mac.

  • RichBass
    RichBass Member Posts: 27 Member

    Hi @Kaiwan_NI , I've been dealing with simultaneous issues on both products. I wasn't expecting issues so it was more complexity than I was prepared to debug. Anyway, it looks like I need the Mac to be on 2.14 so I don't get crashing when browsing (M1 Mac here), and my Maschine+ issues were largely trying to get Maschine+ projects to work on the Mac, which are incompatible due to the version difference. I also had a memory card I was using in M+ suddenly die on me, so it's been a mess getting to a useable setup.

    I'm not going to declare victory yet, since I've abandoned using Maschine on Mac for now, but so far my M+ seems to be working! As to whether or not NA should allow 2.15 versions on M1 Macs is up to you. I'm not sure how many of us are having issues, or if I'm a member of an elite club :) But if this thread ended up as a ticket, you can close it out.

    Thanks!

Back To Top