Anyone experienced sampling issues in Maschine 2 using an M+ in Controller mode?

Options
44ronic
44ronic Member Posts: 5 Newcomer

I recently started using my Maschine Plus in Controller mode with Maschine 2 on my laptop (macOS Sonoma, M1).

However, for whatever reason, sampling an external device into the Maschine 2 software via the Maschine Plus audio interface inputs does not work correctly. The resulting sample sounds "corrupted" - with clicks, pops etc.

Weirdly, if follow exactly the same sampling process, but this time load Maschine 2 into Ableton Live 11 as a VST then sampling an external device into the Maschine 2 VST works just fine. Maybe the problem is somehow with Maschine 2 software directly communicating to the Maschine Plus audio interface since it works fine when sitting inside Ableton as a VST (where presumably Ableton handles the comms with the Maschine Plus audio interface).

I should also state that the Maschine+ in standalone mode (i.e. without a computer) samples external instruments just fine.

I am hoping somebody else has had this problem and make some suggestions. I have logged a support ticket with NI a couple of weeks back but had no meaningful response.

You can download my project here - Pad 1 was sampled with Maschine 2 running Standalone and Pad 2 sampled with Maschine 2 as VST inside Ableton. Both samples are the same source - a basic drum loop from Korg Gadget on my iPhone plugged directly into the Maschine Plus.

Best Answer

  • 44ronic
    44ronic Member Posts: 5 Newcomer
    Answer ✓
    Options

    I was away last week but have retried today after executing the following steps:

    1. Upgraded to Maschine 2.18.1
    2. Created a virtual audio driver in Audio MIDI Setup to combine Mic and Mac Speakers to one interface
    3. Changed all virtual audio drivers in Audio MIDI Setup to same sample rate
    4. Ran Sampling test on Mac audio interface successfully
    5. Ran Sampling test using Maschine Plus audio interface successfully

    I can't say for sure which step fixed the problem, but I'm happy to report that Sampling works without any artefacts now in both Maschine 2 Standalone and Maschine 2 as a VST.

    Thanks @D-One and @Jeremy_NI

Answers

  • D-One
    D-One Moderator Posts: 2,987 mod
    edited May 13
    Options

    You normalized the audio, right? I do not hear any pops or clicks it's just super duper low before normalizing and is very thin, sounds like it picked up the audio from headphone leak instead of input? Could you have recorded with the laptop mic instead of the M+ input? 🤔

    Is your M+ interface selected in Maschine Preferences>Audio?

  • 44ronic
    44ronic Member Posts: 5 Newcomer
    Options

    Aopreciate your help but yeah both samples are after I normalised. The very low input volume is common across all methods as we all know.

    I don’t believe there is headphone leakage (I didn’t use any in either scenario) and I took care to select the same Ext Stereo 1/2 M+ interface inputs in both examples. I also provided screen recordings to NI support to demonstrate my settings.

    looks like I’m out of luck and will have to wait for NI support….

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,394 mod
    Options

    @44ronic How are you connecting the M+ to the computer? Is it through a hub, have you tried a different USB cable, a different USB slot, a different hub?

    Did you try different sample frequencies? Does that make a difference?

  • 44ronic
    44ronic Member Posts: 5 Newcomer
    Options

    Tried multiple USB cables, both via a hub and directly to the Macbook. Also tried different frequencies and different buffer sizes. Makes no sense to me that I can sample using Maschine+ as an audio interface in Ableton, close Ableton, then open up Maschine 2 select the M+ as the audio interface and get a different result. When I get off work tomorrow, I will try a few more combos.

  • 44ronic
    44ronic Member Posts: 5 Newcomer
    Options

    No combination of USB cable or sample frequencies makes any difference. Seems to me like its an issue with the way that Maschine 2 s/w is interacting with MacOS Sonoma audio drivers. Sampling works fine when I use Maschine 2 as a VST in Ableton but this is not really convenient - nor what I'd expect from an AUD1,800 piece of hardware.

    After what seems like forever, NI support eventually got back to me and suggested to try a "normal" recording from the built-in microphone but there is not even an option in the Audio settings to do this.

  • D-One
    D-One Moderator Posts: 2,987 mod
    edited May 20
    Options

    Have you tried the new 2.18.1 version?

    You have a lot of virtual drivers installed, that might be triggering the recording bug, we had an issue related to aggregate devices that is supposed to be fixed. Check your MacOS Audio MIDI Setup app and see if all of those drivers are set to the same sample rate. (teams, hue, etc)

    Also, I can confirm the built-in Mic issue, Maschine does not show an option to select it. - IDK if this is a new issue or if it was always the case because in a Mac the internal Mic is a separate device and Maschine does not have the ability to use separate devices for input and output - What I do know is it works fine in Ableton.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,394 mod
    Options

    @44ronic Have you checked @D-One steps yet?

  • 44ronic
    44ronic Member Posts: 5 Newcomer
    Answer ✓
    Options

    I was away last week but have retried today after executing the following steps:

    1. Upgraded to Maschine 2.18.1
    2. Created a virtual audio driver in Audio MIDI Setup to combine Mic and Mac Speakers to one interface
    3. Changed all virtual audio drivers in Audio MIDI Setup to same sample rate
    4. Ran Sampling test on Mac audio interface successfully
    5. Ran Sampling test using Maschine Plus audio interface successfully

    I can't say for sure which step fixed the problem, but I'm happy to report that Sampling works without any artefacts now in both Maschine 2 Standalone and Maschine 2 as a VST.

    Thanks @D-One and @Jeremy_NI

Back To Top