Komplete Kontrol in Logic blank window upon opening

ADN 01
ADN 01 Member Posts: 4 Newcomer
edited January 4 in Komplete Kontrol

Hi all;

I have been using NI komplete for years now. Now I am slowly transferring my music out of Komplete line for, despite the idea being fine itself, the software being unreliable, unstable and unpredictable.

Komplete Kontrol software often presented some info that plugins are not present, sounds cannot be found etc. I was tempted by the poly touch keyboard and got the latest mk3 Kontrol hardware. Worst decision ever made! The hardware does need some special connections, not being able to connect to some of my mac studio ports and working more or less fine with others. Some plugins do show up fine some don't. When changing tracks in DAW with different KK instances I often get stuck with the first one. NI support advised me to get special USB-C hub (!!!) for it to work properly. Cannot believe... Of course, the software and hardware is up to date with two OS versions ago only and NO MODERN PROCESSORS, from two years ago!!! (M1 macs).

Now, after last Komplete Kontrol software update I cannot see window content If I close it and open it up again. Upon loading KK plugin in Logic everything is fine. Sounds load up, controls work fine. When I close the window and open it up again it is just black. No contents whatsoever. I have to reload the project for the contents of KK window to show up. Or... Open up another window over DAW window for the contents of the KK window to refresh and show up.

I imagine the current NI products are not destined to be used professionally, cannot imagine something like that on a concert or studio environment.

No other plug ins behave like that and I have lots of them. No other manufacturer forces me to use OS from couple of years ago or to upgrade to newer processors. For me now the process of abandoning NI software is underway. I regret upgrading to Kontrol mk3 line or my projects using KK wrapper.

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    Answer ✓

    Hey all, Komplete Kontrol 3.1.1 was released yesterday and addresses the issue, please update in Native Access.


Answers

  • sdx2r
    sdx2r Member Posts: 1 Newcomer

    Same for me nothing but a black window when opening the Komplete AU plug-in. It just happened without any reason. The funny thing is it opens well on Ableton. Please fix this !!! Logic Pro 10.7.9


  • ADN 01
    ADN 01 Member Posts: 4 Newcomer

    quick fix: open up another OS window over the black KK window (the new one must cover all the KK window) and get back to KK window again. Now it refreshed fine. Generally I was lucky to be able to downgrade to older KK Audio Unit (only one file) from my time machine backup) that does not have this problem...

    Still cannot understand how such fu*kup (and many more) is possible for a once decent company. Alas, no longer...

  • Kymeia
    Kymeia Member Posts: 3,454 Expert
    edited December 2023

    Looks like this may be related to this known issue that has been reported:

    Although I have not had a completely blank screen I do lose large chunks of it with some plugins, especially when moving between browser and plugin views.

    Still cannot understand how such fu*kup (and many more) is possible 

    The fact is sometimes it's not possible to know what changes are coming in other DAWS (because all companies tend to keep new developments trade secrets until after release). Looks like this one may be related to a change in the AU hosting API in Logic recently (which is why it doesn't happen in Live which still uses the older API). In this case, like many bugs, it is not one or the other companies 'fault' but rather a result of the complex and not always predictable interactions between host and plugin - it seems in particular the newer KK3 struggles graphically in Logic at the moment due to this. Hope there is a fix soon, but it might take some communication between both companies. NI are certainly aware of it though as the bug has been reported (by myself).

  • Maciej Repetowski
    Maciej Repetowski Member Posts: 369 Pro

    Apple is not without fault here. Logic has been buggy as of recent.

  • Diam
    Diam Member Posts: 200 Helper

    Experienced this issue a few times recently in standalone mode. Running KK 2.9.6, however don't recall it ever happening before. It just requires closing and reopening in my case. Keeping 2.9.4 in my archive in case it is anymore stable.

  • ivicam
    ivicam Member Posts: 18 Member
    edited December 2023

    @Kymeia

    The fact is sometimes it's not possible to know what changes are coming in other DAWS (because all companies tend to keep new developments trade secrets until after release). Looks like this one may be related to a change in the AU hosting API in Logic recently (which is why it doesn't happen in Live which still uses the older API). In this case, like many bugs, it is not one or the other companies 'fault' but rather a result of the complex and not always predictable interactions between host and plugin - it seems in particular the newer KK3 struggles graphically in Logic at the moment due to this. Hope there is a fix soon, but it might take some communication between both companies. NI are certainly aware of it though as the bug has been reported (by myself).

    It is probably related to the new AU hosting API used in Logic. It is also absolutely true that Apple should be a lot more transparent when it comes to their developer-related technologies.

    However, these kinds of bugs are probably also related to the fact that NI plugins were written many years ago and never properly adapted to modern Apple technologies and modern software in general. NI software is not macOS native software at all. It is bad old cross-platform software which is kind of hacked to work on macOS. Also, I am pretty sure that NI audio units are just repacked VSTs not really optimised for audio unit peculiarities. That's why it all breaks so often.

    Apple has different philosophy than Microsoft does with Windows. Apple moves forward and deprecates old stuff while MS tries to keep backward compatibility with Windows 95. And none of the two approaches is better than the other, both come with different trade-offs. I'd argue that Apple's approach is better for end users, but means a lot more work for developers. And if you choose to develop for Apple platforms, you have to accept how they work and update your software regularly. And you should really try to write native software, not some ugly hacks. I do understand if some small company can't afford to do that, but NI is a large corporation that makes pro software for huge industry. They absolutely must rewrite Komplete Kontrol, Kontakt and Reaktor from scratch (reusing low-level code, of course), if they want to stay competitive in future. And I can guess that their developers know that very well. However, investors don't want to back anything that doesn't immediately bring them a lot of cash. Short-term, those investors will get their money by making and selling new sound packs and similar products and not investing into foundations, but long-term they will destroy the company.

  • thej
    thej Member Posts: 3 Newcomer

    OMG. This actually works. Lol. I just open it up in another screen and then open my browser or something and come back to logic and volla the plugin works.

    Horrible piece of software and integration. Simple things they get wrong like, I have an s88 mk2 and when a plugin is loaded which has an on off switch for a parameter like "space". The knob has to be rotated a lot to change state. Lol. How can you be this bad?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited January 4

    Hey all, this issue was already reported: Plugin window sometimes just black in Logic since 3.1 / Bug KBDSW-7816

    We're investigating the issue, we were able to reproduce it and we're waiting for feedback from the devs. I'll close this thread now to streamline communication.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    Answer ✓

    Hey all, Komplete Kontrol 3.1.1 was released yesterday and addresses the issue, please update in Native Access.


This discussion has been closed.
Back To Top