How to lower Octave in Reaktor 6 on Mac qwerty

P-box
P-box Member Posts: 47 Member

Hi All,

iMAC Ventura 15 Reaktor 6

the question has been asked before, but the google links to the NI website do not direct to the correct (2017) thread. The manuals do not result a qwerty query. And general google searches do not solve the problem.

The tilde key to the left of numeral 1 does nothing.

Also, when I am in the Reaktor Builder Community subsection, and I put in a search, it responds with data from the entire NI website. Is there no way to filter questions to just the Reaktor section?

Living in a Micky Mouse world until help arrives,

Paul

Comments

  • colB
    colB Member Posts: 756 Guru

    try putting those google links into archive.org aka waybackmachine

  • Sunborn
    Sunborn Member Posts: 2,193 Expert


    Here is the direct link to the old forum at archive.org


    I also made a thread some months ago, to start copy and collect those old info, because archive.org is extremely slow and non-practical, but without much response...


  • colB
    colB Member Posts: 756 Guru

    It's difficult to get motivated by that when you were the people posting in those original threads, doing that over again, or wading though wayback machine to find links, feels a lot like unpaid work.

    It was a repository of years of community knowledge. It seems a lot of folk who were active in the old forum have basically left. Maybe that's just a coincidence.

    Anyway, I guess it's up to the newbies, when they find something interesting in the archives, to post a link here.

  • P-box
    P-box Member Posts: 47 Member

    @Sunborn

    Hi Sunborn,

    tried to state that I'd searched for and didn't find help. I saw the link you sent already, and that may be a character on a British keyboard, but it's not on a US MAc. It's the tilde key (~) to the left of the 1 key. And that does nothing.

    Still searching myself, but anyone else have a Mac?

  • Sunborn
    Sunborn Member Posts: 2,193 Expert
    edited December 2023

    @P-box

    There are no keyboard shortcuts for Octave up or down, neither for Mac, neither for Windows.

    REAKTOR 6 Diving Deeper

    Manual: Page 115 / Chapter 12 'Keyboard Shortcuts'.

    _____________________________________________________________

  • colB
    colB Member Posts: 756 Guru

    have you tried just pressing the keys one by one until one of them changes the octave?

  • P-box
    P-box Member Posts: 47 Member

    @colB @Sunborn

    Hi, And thanks to you both for responding.

    I should clarify, it is in Standalone mode that this pitch problem occurred on the Mac. It works fine in VST mode.

    @Sunborn : Yes, I did look at the Reaktor 6 Diving Deeper already, and was aware there was no defined keyboard shortcut. But it also does not any mention there or in any one of the Reaktor 5 or 6 manuals that a qwerty keyboard can be used for note pitch input, or how the qwerty keyboard is laid out. It does not follow the industry standard. Instead of ASD, etc being white keys and WE black keys, it uses ZXC, etc as white and SD as black with an upper register QWE, etc as white and 23, etc as black!? It is actually useful as the QWERTY keyboard then spans 2 octaves. But not very useful if it cannot be pitched back down!

    I have tried every combination of keystrokes (one and two keys at a time): Nothing.

    All I can say is what happened, which is that I was editing something, and instead of data entry, I believe I was hitting the "1" key in MIDI note entry mode, and heard the sample pitch transpose up a few times, resulting in all the note pitches being transposed up to the highest octave range. QWerty "Z" now corresponds to note 108, "X" to 110, etc

    If there's no other input from users, all I can think of is to uninstall and reinstall Reaktor, as I have no other idea how to solve the issue, and inserting a pitch drop macro in every single ensemble I use or create is just not an efficient workaround.

    @colB I also tried to use Wayback, but cannot seem to navigate the site. I keep getting errors, "this NI url has not been archived". (this is probably my error - but getting nowhere there).

    But if I have an updated Mac and Reaktor 6, I honestly can't figure out why another Mac user has not run into the same issue and resolved it. (?)

  • P-box
    P-box Member Posts: 47 Member

    Well, I closed and restarted Reaktor, and it reset. Absolutely simple fix.

    I still don't quite know why I can simply hit the "1" key for upward octave transposition but cannot transpose octaves back down.

    Still wondering where the Mac users are!

  • colB
    colB Member Posts: 756 Guru

    I think maybe this is a 'you' problem ;-p

    If there was a general mac bug with no octave down, folk would have been shouting from the rooftops about it (stereotypically, mac users are not known for their lack of entitlement or their shy retiring nature ;)).

    Maybe there is some problem with localisation in your OS settings or something. Like the OS is somehow confused about what type of keyboard you have, or maybe it's telling Reaktor the wrong thing, or Reaktor is confused, about the same thing. Maybe the setting was updated since Reaktor was installed, and Reaktor didn't get the memo... Also would be worth checking that all the Keys and Key combos work correctly on your keyboard - the octave down key is one of the obscure ones, so it wouldn't be surprising if it wasn't working and you hadn't noticed.

    Has it ever worked?

  • P-box
    P-box Member Posts: 47 Member

    I have not had Reaktor that long, and for months I was loading it as a VST in Ableton. It's only as I have been building more that I realized I could take advantage of the edit features with keystrokes in the standalone version. Within abletons protocol as a vst, it transposes fine up and down.

    It has never worked since I began using standalone. Transposes up just fine. Has same "malfunction" on my laptop Mac as on the desktop Mac. (?) But if I don't use the feature to transpose up, I don't need to worry. Or I con reset it by closing and restarting, as I said. I can live with it...

Back To Top