Sustain events disappear when changing sounds?!?

PROJECT
PROJECT Member Posts: 3 Newcomer
edited December 2023 in Maschine

Hi all,

Has anyone else encountered the recorded sustain events disappearing when changing the sound on a track?

Best Answer

  • PROJECT
    PROJECT Member Posts: 3 Newcomer
    Answer ✓

    D-One... Setup Is M1 Macbook pro, Maschine MK 3, S61 MK 1, Yamaha MO 8

    I tried it with the pedal in both keyboards... the same thing happens.

    The lane comes up under the velocity lane when I record the pattern but the Sustain lane option fully disappears as soon as I change the sound. I'll

    You're right about it being unacceptable to manually change it back after recording.

    Go figure... I just tried it again to check if the data was hidden and it was working as it should... sustain data stayed through the patch change.

    I was struggling with it all night so I know I'm not crazy. I'll have to test it further and submit a bug request as that's the only real explanation for why it's working now and it didn't 2an hour ago.


    Thanks for everyone's help! Much appreciated.

Answers

  • Milos
    Milos Member Posts: 1,811 Pro

    Well, yes, in a way...by using virtual controller, which is why I am never using it on my actual projects again.

    But from my experience, when it happened to me, i just did this:

    If you make the sustains while playing the instrument, and then they suddenly dissappear, you can just try to manualy add them back with the midi mapping or automation or RPN and some experimentation.

    Let me know if it helped.

  • PROJECT
    PROJECT Member Posts: 3 Newcomer

    Hello Milos, What do you mean 'by using virtual controller"?

    My recorded group was played with sustain and just picking a different patch makes the played sustain pedal events disappear.

    Are you saying this is normal Maschine behaviour? Should all the MIDI Data not just remain so the original performance remains the same?

    Thanks for replying BTW.

  • Milos
    Milos Member Posts: 1,811 Pro

    Not sure if this is the behaviour of that plugin, but again, if the sustain disappears after recording the track, just manually add the missing sustain inside the MIDI map or just increase the duration of the notes inside the piano roll to trick people that it is sustained!

    Let me know if it worked.

  • Milos
    Milos Member Posts: 1,811 Pro

    As for the virtuall controler, it is a Cakewalk thing, a terrible alternative for using the computer keyboard as a MIDI keyboard, the only thing that is bad inside that DAW, so I stopped using it and instead I downloaded the Midi piano inside my Samsung, then connected the phone to the laptop to use it as a Midi keyboard.

    Have a nice day!

  • d_a_n
    d_a_n Member Posts: 3 Newcomer

    Hi.

    I wonder if the sustain information would come back when you uploaded the initial patch?

  • Milos
    Milos Member Posts: 1,811 Pro

    About that, I am not sure...

  • D-One
    D-One Moderator Posts: 2,672 mod
    edited December 2023

    That sounds like a Bug, manually adding it back would not be acceptable to me.

    Explain your setup, how are you recording Pedal data? A regular MIDI keyboard? KKS?

    Are you sure they're gone completely? Maybe the modulation lane is simply not visible?

  • PROJECT
    PROJECT Member Posts: 3 Newcomer
    Answer ✓

    D-One... Setup Is M1 Macbook pro, Maschine MK 3, S61 MK 1, Yamaha MO 8

    I tried it with the pedal in both keyboards... the same thing happens.

    The lane comes up under the velocity lane when I record the pattern but the Sustain lane option fully disappears as soon as I change the sound. I'll

    You're right about it being unacceptable to manually change it back after recording.

    Go figure... I just tried it again to check if the data was hidden and it was working as it should... sustain data stayed through the patch change.

    I was struggling with it all night so I know I'm not crazy. I'll have to test it further and submit a bug request as that's the only real explanation for why it's working now and it didn't 2an hour ago.


    Thanks for everyone's help! Much appreciated.

  • Milos
    Milos Member Posts: 1,811 Pro


    I hope your issue gets solved, good sir!

Back To Top