I’m about to lose my mind

Aces
Aces Member Posts: 2 Newcomer

So a couple of months ago I bought komplete standard and weeks after that I noticed something weird with my libraries. For some reason kontakt 7 and all other libraries were not installed. Also I can’t install the updates into my internal ssd or my external ssds. I own many different brands of external ssds and nothing works. I forgot to mention I have an m1 Mac. I’ve contact customer service and they giving me an update cloud to download but Ive download it but no luck, it says that my libraries are not installed. Another support team told me that to make sure that my external ssds are compatible and I replied him yes they are and told him that it doesn’t even work if I do a full re install. I also told him that even if I add the libraries in my internal ssd it still won’t work. I’ve turned all permission to allow the product to work on my system. Nothing works, does any one have any suggestions because I’ve been left in a silence for a couple of days and I’m doing all I can having good terms with native instruments. Love their libraries and I really want to upgrade to ultimate but if it does not work and no help do then I’m gonna fight getting my money back from them because its false advertisement. It’s cost me time and I’ve submitted two tickets already.

Answers

  • PoorFellow
    PoorFellow Moderator Posts: 1,677 mod

    Making more tickets is counter-productive and only helps to create confusion. You also forgot tho mention that you are on Mac OS Ventura ?

    Personally I do not know very much about Mac but I have collected a lot of Mac user advice and feedback that I can post below here so that you can see if any of it triggers anything. :

    1) Check all folders in Download, Application and Content locations by doing Get Info in Finder for full Read and Write access permission. Click lock at bottom right to make changes.

    +

    2). Be sure Full Disk Access is granted for NI applications under System Settings> Privacy and Security> Then under "Privacy Section" scroll down to "Full Disc Access" right arrow. Will open up the NI apps, and you slide them all to "on".

    +

    If it fails immediately on download, it is probably disc write privileges, if it fails at last point in installation, probably Full Disc Access. When all is working you will see the temporary install folder for the app you are installing show up on your desktop. If you get that far, it should complete.


    Final Solution: For new MacBook Pro users or anyone using the M1 & M2 chips, Native Access will work as long as you have the permissions turned on under the privacy and security. So if you see Native Access and the other NTKDaemon on your list, make sure they are turned on and you see blue after you check them. If you don't see blue and if they don't appear in your drop down list under FULL DRIVE ACCESS then you will continue to have installation issues.


    Did everything explain above. Stil problem. Then formatting external disk to APFS. Everything works fine

    ( Notes on Hard Drive Formats on Mac Computers : https://support.native-instruments.com/hc/en-us/articles/214134545-Notes-on-Hard-Drive-Formats-on-Mac-Computers )


    This works - change your designated File Management folders in Native Access Preferences to a drive that is Mac OS Extended (Journaled) format. If you, like me, are trying to install using ExFat Samsung T7 SSD it will not work.


    I had the same issue here, and there was one additional step that solved this: I had to change the permissions for the desktop. For some reason, "everyone" did not have read and write permissions for the desktop, and that somehow prevented the dmg to do its thing.


    So

    (a) I gave full disk access for NI Access and NTK

    (b) changed the permissions to read/write for the destination folder

    (c) changed the permissions to read/write for the desktop

    and then it worked. Good luck guys!


    I've given full disk access to Native Access and the NTKDaemon, changed permissions on folders, and checked the APFS disk format, and the issues still happening. So I am not able to use or reinstall certain Kontakt libraries.


    Native Access's NTK Daemon: sometimes fails to install even with full disk access, also mutex issue

    https://community.native-instruments.com/discussion/9255/native-accesss-ntk-daemon-sometimes-fails-to-install-even-with-full-disk-access-also-mutex-issue


    Tips: Full Disk Access on Mac and why it matters

    https://community.native-instruments.com/discussion/368/tips-full-disk-access-on-mac-and-why-it-matters


    Ref. : Native Access - Dependency Installation on Mac

    https://community.native-instruments.com/discussion/11813/native-access-dependency-installation-on-mac


    If the issue persists even after the steps mentioned then please contact support: http://bit.ly/NIsupport_install

  • jt maher
    jt maher Member Posts: 80 Newcomer

    File a chargeback with your CC company. 120 days is usually your window of opportunity. But, I hope it works out with fixing the issue, that should be a last resort. Power to the consumer!

  • D-One
    D-One Moderator Posts: 2,748 mod
    edited December 2023

    Any external SSD should work, MacOS only had limited support for internal SSD's and that's not even possible on modern macs since SSD are soldered.


    Give proper details. What's your MacOS version? Ventura? Sonoma?

    For some reason kontakt 7 and all other libraries were not installed. Also I can’t install the updates into my internal ssd or my external ssds.

    What does this mean? Do you get an error when installing? Or it installs fine but doesn't show up in K7 ?

    What's the file format of your external SSD's? Check in Disk Utility (enable View>Show all devices), it should be APFS.


  • Aces
    Aces Member Posts: 2 Newcomer
    edited December 2023

    Thank you for your suggestions, I’ll go more in detail on some of the things I left out. I got a response a couple to days from native, I basically did a diagnosis and sent that towards the agent. I’m gonna wait for the agent’s response and then try out all these suggestions out.


    thanks again for reaching out everyone

Back To Top