Traktor 3.5.2 Application (not audio) Lagging on new MSI-ALpha /Ryzen 7 5800 / Windows 11 / 64GB RAM

JoeLava
JoeLava Member Posts: 11 Sine

Ryzen 7 5800H 64GB RAM 1TB SSD AMD Radeon RX6600M 8GB - Brand new. 265,000 songs on a brand new, 4 TB external Lacie hard drive connected to a Denon X1800 mixer. Multi-core support turned on. All songs have been analyzed

  • When a track is playing and I search for a song: I attempt to load it into an open deck and it locks up the app for 5-15 seconds. Thankfully, I worked around it and made decisions on a gig not to load with less than 30 seconds remaining on the song that was playing
  • When a track is playing and I search for a song: I go to a favorites list and attempt to load a song.... the same result as above
  • Searching for a song: When I move to "Track Collection" and search for a song, the search takes 5-8 seconds to complete. In older versions of Traktor, including Ver 1.X of Traktor Pro, this string search was almost instantaneous.

Thanks!

Tagged:
«1

Comments

  • Uwe303
    Uwe303 Moderator Posts: 516 mod

    Hello,

    why you connect the harddrive to the denon? I would try to directly connect it to the computer.

    Uwe

  • JoeLava
    JoeLava Member Posts: 11 Sine

    @Uwe303 Thanks for the comment. The external hard drive is connected via USB 3.0 to the laptop. The computer is connected via a USB 2.0 port to the Denon X1800. I have spent hours on the latency issues but with no success. I am not super technical, maybe a 7 out of 10. It sure feels like a database issue. I ran Traktor 1.XX for over 10 years on an old I3 (300,000 MP3) and the performance issues like I have described have never appeared

    New machine updates:

    Lates Bios and Driver updates applied as well.

    • Updated MSI laptop BIOS
    • Updated Denon 1800 driver to 1.05
    • Updated Denon X1800 firmware from 1.3 to 1.6
    • Snapshots below
    • Except for ntoskml.exe, the drivers seem to be staying below 1.0 MS BUT the Application performance issues remain. I do not think this is an audio quality nor a Denon interface issue. I know you are the pro! Thanks for the help


  • Uwe303
    Uwe303 Moderator Posts: 516 mod
    edited April 13

    Haha no I'm not a traktor expert but we have one here @Karlos Santos maybe he has an idea. Could be the external drive if it is a HDD but i doubt that. Have you tried with songs on the internal drive? Do you use the preparation list? You could try to find out the chipset and manually install chipset drivers that might help. And you could try airplane mode and set power profile to max.

    Uwe

  • Sûlherokhh
    Sûlherokhh GermanyMember Posts: 211 Saw

    Does your hard drive have to spin up before loading? If so, that's the delay, although it should not be more than 5 seconds.

  • alec.tron
    alec.tron Member Posts: 35 Tri
    edited April 14

    I also see the same since 3.5.x "attempt to load it into an open deck and it locks up the app for 5-15 seconds" on an Intel i7 proc with S4 mk3 usage too as a constant issue.

    This has now become a constant for a few months and this is with multiple externat HDDs which were absolutely fine with Traktor 3.4 and earlier beforehand. So I doubt it's a hardware failure on all of them all of a sudden, and this is an introduced issue in Traktor...

    c.

  • JoeLava
    JoeLava Member Posts: 11 Sine

    @Uwe303 @Sûlherokhh Thanks for the introduction. It can't be the hard drive. These same drives ran on the I3 and Tracktor 1.XX. They are USB 3.0 and their performance hit is barely noticeable on any admin tool that measures this

  • JoeLava
    JoeLava Member Posts: 11 Sine

    @alec.tron When Tracktor 1.XX moved to 2.XX and eventually 3.XX, there was clearly a change to the way the databases are managed (Indexing? ) I can run Virtual DJ with 1/10 the load of the application, less than 2 seconds ona search and NO lag on a load while other tracks are playing.@traktorhelp - Please do not make me spend $300 and over 12 years of working with Traktor to have to move to Virtual DJ - Gracias

  • JoeLava
    JoeLava Member Posts: 11 Sine

    @Karlos Santos Any ideas here?

  • Uwe303
    Uwe303 Moderator Posts: 516 mod

    I never have an issue with traktor 3 hanging while loading a track, but have you tried airplane mode, disable all wifi, network and BT stuff. Try to find chipset drivers and install them manually.

    Uwe

  • Kubrak
    Kubrak Member Posts: 1,017 Pulse

    Or virus scanner, firewall? And is it all audiofiles or just certain type?

  • JoeLava
    JoeLava Member Posts: 11 Sine

    @Uwe303 - Thanks. Although my laptop is a PC and not a MAc, I have tried disabling the network and BT - No success. I did reach out to MSI (laptop manufacturer) for updates on chipsets.

    @Kubrak It is ALL audio types. I will check on the firewall and I will turn off the virus scanner. thanks for trying to help here!

  • JoeLava
    JoeLava Member Posts: 11 Sine

    @Sûlherokhh The drives are USB3.0 with permissions set to performance. All four I have tried are brand new to less than two years old. - No success here my friend :(

  • Karlos Santos
    Karlos Santos United KingdomModerator Posts: 136 mod

    Sorry guys I'm strictly Mac only - I have never owned a Win PC so my knowledge of tweaking is very minimal.

    What I would say is over a quarter of a million tunes in the track collection on an external drive maybe an issue. I remember folks on the old forum having issues with this kind of number of tracks on external drives.

    Can you put some tracks on the internal drive of the laptop and see if you have similar issues?

    You could also create a new test collection and only include 50,000 tracks on the external drive just to see if the larger quantity of music is the issue.


    I do know a local DJ that has more than 250,000 tracks on external drives that and he has no issues but unfortunately he's on Mac.

  • Uwe303
    Uwe303 Moderator Posts: 516 mod

    Just tell me the exact model of the laptop and i can maybe send you a link to the drivers.

    Uwe

  • JoeLava
    JoeLava Member Posts: 11 Sine

    @Uwe303 The model is "Alpha 17 B5EEK" - The drivers page is here. To my knowledge, they are up to date

    https://www.msi.com/Laptop/Alpha-17-B5EX/support?sub_product=Alpha-17-B5EEK#bios

Back To Top