Issues with Traktor Pro 3 and Windows 10 AMD Ryzen 9 (8 Cores)

Hello everybody,

i own the Traktor Software since years, but had some issues with my laptop and decided to buy a new Laptop. It is a ASUS ROG Zephyrus GA501I with an AMD Ryzen 9 Processor and Windows 10 64 bit. I am using also the S4 MKII for audio interface and to control the software.

The Laptop is brandnew, but unfortunatelly i have issues while using the Traktor Software (using the latest version of Traktor of course).

Suddenly the sound tempo slows down and the sound is distorted. Once this happen i am not able to control the software anymore. only close and restart solves the problem.

I found an youtube video where exactly this issue is shown:

It is really strange because the laptop is brandnew.

I really need some help. Thanks a lot!

Kind Regards

Alexander Masur

Answers

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    Hi @Alexander Masur welcome to the NI online community! Can you try the troubleshooting steps in this article to see if they help solve your issue?

    My Native Instruments Hardware Device is Not Recognized

    I know the title isn't exactly your issue, but it's a great place to start diagnosing the problem.

  • djrodneyday
    djrodneyday Member Posts: 1 Newcomer

    I have the AMD omen Hp I use a z2 traktor I have no issues. I am thinking about getting the kontrol s8 will let you know if I have any issues.

  • Anthony123
    Anthony123 Member Posts: 1 Newcomer

    Hello everyone, just bought a new computer (HP 16 GB with Ryzen 5 5500u).

    Was unsure to buy it, because it´s almost impossible to find Info about AMD Ryzen in combination with Traktor Pro3. But it works perfect !!! If there´ll be any issues i´ll let y´all know ;).

  • DJM (Sagar)
    DJM (Sagar) Member Posts: 45 Helper

    Hi @Alexander Masur

    What drivers are you using in the audio setup, and which firmware is installed on your S4 mk3 ?

  • isaac martinez
    isaac martinez Member Posts: 1 Member

    hola chicos a mi me paso lo mismo al principio me fue bien pero luego me daba micro cortes y probando con la latencia y todo me fallaba igual.

    ahora descargue la nueva version la 6.2 y actualice todo espero que ahora vaya bien mi procesador es un amd ryzen 5 5600 h a alguien le pasa lo mismo?

  • Dj_Vd
    Dj_Vd Member Posts: 12 Member

    Did you already found solution a problem? Please create a new topic!

  • Ilya_Planete
    Ilya_Planete Member Posts: 1 Newcomer

    Have PC ryzen 1600x 32gb

    My friend have lenovo 4300u 8gb

    Both have this issue sometimes, cannot change track in deck....

    Still no solution, will search

Back To Top