Traktor Pro 3 and Maschine 2 Won't Launch

Hidi
Hidi Member Posts: 7 Member

Apologies if this is a duplicate or anything, I tried to do a search but couldn't find any post similar to the issue I've been having.


I have been unable to launch both Traktor Pro 3 and Maschine 2 after rebooting my computer once several weeks ago.

When I launch Traktor or Maschine, a task shows up in task manager, but no window ever opens, and in addition the task has no CPU or Disk draw.

As well, the log seems to show that traktor never gets past the initial startup, and my log is exclusively these 4 lines every time I launch traktor:

Traktor also does not produce a crashlog when it fails to start

I am using Traktor Pro 3.9.0 currently, I was using this version fine without issue as well before the issue started happening.

In trying to debug this issue, I have taken all of the steps I've tried with my S4 MK3 and Maschine MK3 unplugged and with the drivers uninstalled so as to try and rule out the issue being hardware related.

I've also generally been trying to get Traktor working again primarily, so most of the steps I've tried were specifically trying to get Traktor to launch again since the issue seems linked to both applications for some reason.


I have tried all the steps in the support article titled "My NI Software Crashes at Startup (Windows)" but none of these had any effect on the issue:

specifically I tried;

  • Deleting the USER registry entries for Traktor, uninstalling traktor, rebooting, and reinstalling
  • Deleting my traktor collection file and database (traktor never gets to the point to repopulate either of these)
  • Ensuring I'm running the latest version of windows
  • Updating my graphics drivers (I also tried installing an older version of the graphics drivers, neither had any effect)
  • Ensuring I only have one monitor plugged in, and the default scaling is set to default
  • Disabling my anti-virus
  • Running Traktor as administrator
  • Ensuring all of my audio devices are set to the same sample rate (I tried setting everything to 44100 and 48000, neither had any effect on the issue)
  • Updating my sound card drivers (I downloaded the latest soundcard drivers from the manufacturers website, but this had no effect either)


Outside of that I also tried completely removing everything Native Instruments related, including the documents NI folder, the appdata NI folders, the programfiles NI folders, and the NI registry entries, and everything related to Native Access before restarting my PC and then reinstalling everything.


I also tried running my PC in safe mode and launching traktor, but that didn't have any effect either.

I also have backup installations of Traktor 3.8.0, 3.6.1, and 3.5.3, but all of those backup installs have the same issue and won't start.


If any more information is needed I'd be happy to provide it, I'm at a loss for how to fix this outside of a complete reinstall of windows, however this will be the 3rd time in the last year that I've had to do a fresh install of windows because Native Instruments software specifically was having issues.

I would really like to be able to resolve this without having to do another reinstall of windows and to take the long time to get all my tools setup again on the new install.

Best Answer

  • Hidi
    Hidi Member Posts: 7 Member
    Answer ✓

    Mmm, yeah at this point I think I've run out of options. I went back and forth with NI support over the past week as well and they're telling me to reinstall windows.

    It's frustrating that I've had so many issues with Native Instrument's software to cause me to have to do a reinstall of windows so often like this, I like the hardware a lot, the software is nice, but the stability is very frustrating to deal with.


    Thank you for the suggestions and assistance, it was very appreciated o/

«1

Answers

  • Sunborn
    Sunborn Member Posts: 2,134 Expert

    This is clearly a Windows related error, not Traktor's, or at least that's my impression from what you wrote.

    You need to provide some more details about your system, which Windows version you have, GPU info, and what other programs are running when your computer starts. It looks like some kind of incompatibility.

  • 6xes
    6xes Member Posts: 568 Pro

    check to see if the 2 services are running

    NTKDaemon & NIHardware service... restart them if possible

  • Hidi
    Hidi Member Posts: 7 Member

    Both services were running, I tried restarting them but the issue is still the same

    I'm running windows 10 pro, I'm running an RTX 2070 Super and Ryzen 7 3700X

    On startup I have Voicemeter, Plex, Steam, Logi Hub, and ShareX launch, I'm not sure if any of those would contribute to this problem though, my startup programs haven't changed for a long time before this issue occurred.

    I should also clarify that the windows reinstalls I had to do in the past were from completely different issues from the one I'm having currently, the first was a bluescreen that would randomly occur and show up in event viewer as being caused by the NIHardware Service, but that was around a year ago. I forgot what the second reinstall was for, but it was a different issue from the one I'm having now.

  • Sunborn
    Sunborn Member Posts: 2,134 Expert

    Hello,

    • 1) At first, please try this one:

    Delete your Traktor Settings.tsi file. Traktor will create a new one. It is located in your Documents at:

    C:\Users\*user*\Documents\Native Instruments\Traktor (version number).

    Open Traktor. Hopefully this works.

    If this not works and since, as i see, you already have done almost any known recommendation, then we have to go deep down the rabbit hole...

    • 2) So, lets see what is running!

    Voicemeter is perfectly OK. Actually, it is the only program who makes sense to run everytime you open your PC. ShareX is ok too, but definitely not a program that should always run in the background from the time you open your PC, unless you are creating screenshots all day.

    The other 3: Plex is for streaming movies, Steam is an absolute cr*p (unless you have specific reasons to use it) and Logi Hub is for games. All have nothing to do with music creation, so please disable them temporarily in order to troubleshoot your system and find out what is wrong.

    So, after disabling those, restart you PC and try open Traktor again.

    Note: A technical advice if i may. Reinstalling Windows to solve 3rd party software problems is not a solution. As in 99.99% never!

    • 3) That's all for now. If nothing of those fix your problem, then we will check the Windows Services. After that, the remaining possibility should be a Scheduled Task.
  • Hidi
    Hidi Member Posts: 7 Member

    I would delete the traktor settings file, but traktor never gets to the point that it actually creates a settings file so I can't follow that step.

    I disabled plex, steam, and logi hub and restarted my PC, but that did not have any effect on the issue.

  • Sunborn
    Sunborn Member Posts: 2,134 Expert
    edited July 2023

    uh... ok. So you mean that a traktor settings file does not exist in your NI Documents folder? This means that Traktor was never actually run successfully, not even once.

    Ok, then please do this:

    Go to the backup folder of your latest previous version (3.8.0 ?)

    Copy everything (all folders and all files) and paste them inside the 3.9.0 folder. If there is any files there, replace them. If there is no such folder yet, create it by yourself.


    EDIT: Even better, copy the entire "Traktor 3.8.0" folder, paste it in your C:\Users\*user*\Documents\Native Instruments\ folder and rename it to "Traktor 3.9.0". Then start Traktor.

  • Hidi
    Hidi Member Posts: 7 Member

    Yeah like I mentioned with the log, Traktor starts to start up, but never successfully gets anywhere past that point.

    I did make a backed up copy of my entire 3.9.0 folder from when traktor was working before I wiped everything NI related, I copied that over into the 3.9.0 folder in the native instruments documents folder, that didn't have any effect on the issue though.

    I tried doing it with my old 3.8.0 folder as well and no difference

  • 6xes
    6xes Member Posts: 568 Pro

    it is diffucult to diagnose the problem you are having....

    my last guess given that you have tried many other avenues to solve the issue...

    is your windows 10 system is somewhat corrupted, but this is merely a guess, if for instance your windows system is on a HDD... as opposed to a SSD then a corrupted windows system becomes a inevitablility, as power shutdowns can cause the surface of the HDD platter to become scratched and play havoc with your system, thinking that it can be fixed, however a scratched surface platter is not so easily remedied

    A good lesson i learnt while going through many teething problems be with windows/maschine/audio software etc etc... was to create duplicates drive(backingup whole drives)..

    im particularly sold on the samsung SSD drives as the software Data migration tool makes it easy backing up whole drives onto samsung SSDs...

    system drive(HDD) ----> samsung SSD

    be aware this doesnt transfer the other way,,, for example

    Samsung SSD ----> any other drive type does not work... data migration software only works with samsung SSD to samsung SSD or any system drive ----> samsung

    all that said...

    another method i used to fix system errors...

    is using a program by tweaking.com called windows repair... this program is not free,

    but it has fixed my system drive and other peoples when i have run it on their computers, i know my money was well spent on that product... as bluescreens are a random occurrence, and you never know when you need a program that will just work!!


    Nothing worse than re-installing everything!! which is why i have these mechanisms as a backup!! We've all been down this road with Windows $hit'n itself..

  • Sunborn
    Sunborn Member Posts: 2,134 Expert
    edited July 2023

    Ok. Here is what you are saying:

    "I did make a backed up copy of my entire 3.9.0 folder from when Traktor was working before I wiped everything NI related"

    So, some things are pretty obvious here, tell me if i am wrong on something, because the whole case is such a mess-up that we could try solutions for a year and never solve the problem!:

    1- Your Traktor 3.9 was working at some point. Correct?

    2- Then you suddenly decided to wipe out anything related to NI? Correct? (...assuming that this is correct, then why on earth would anyone do such a thing???)

    Ok, now assuming that both of the above questions are correct, please answer this:

    1- Do you have a Windows System Restore, from before the day that the problem started? If you do have one, then please restore it.

    2- Did you used a specific program from NI (NI Uninstall RegTool_64bit) to remove registry entries? Or did you make it your shelf by using a registry tool? If not, then now it is a good idea to use it. See how, here: https://support.native-instruments.com/hc/en-us/articles/115003509269-Fixing-Software-Update-Installation-Issues-Windows-

    3- Before use the above tool, please let me know what exactly is installed right now (by Native Instruments)? Because maybe the correct thing is to remove everything and start from scratch.

    __________________________________________________________________________________________________________


    EDIT: OK i forgot this. Please for now, ignore ALL the above (we will return on those, later), and do this!

    We need to check Services and Scheduled Tasks, before we go in such trouble. So, please download this tool:


    Run it as Administrator, then hide all default Microsoft entries, scan your system and then, make 2 screenshots, one from the tab Services and one from the tab Scheduled Tasks!

    Like that:


  • Hidi
    Hidi Member Posts: 7 Member
    edited July 2023

    Context

    In regards to your question for more context, yes Traktor 3.9.0 was working previous to this issue working. I had been preparing a crate for a set and had saved my collection, then closed traktor, and then restarted my PC using the restart button in the windows menu.

    I do not have a 2nd PC to dedicate exclusively to A/V software, this is my general use PC hence why I have things like steam installed.

    After restarting my PC, that's when this issue began and I was unable to start traktor or maschine after that point, native access and the controller editor launched fine though.

    I immediately began trying all the options for fixing the issue I could find in support articles, I first tried removing only the settings file, or only my collection file, then both, but traktor never got to the point where it would repopulate either of them.

    I noticed when traktor started up, it would show up as a task in task manager but wouldn't start, and I also couldn't launch another instance of traktor because technically one was already running, so I would shut it down from task manager.

    I also saw in the log those 4 lines from my initial post here indicating to me that traktor never successfully launched.


    After deleting my settings file and collection did not work, I tried deleting the USER entry for traktor as outlined in the support article titled "My NI Software Crashes at Startup (Windows)" (I would link it, but I can't post links because my account is too new)

    That didn't work, so next I tried uninstalling traktor, rebooting, and reinstalling. That didn't work either and at this point I had already tried every other step I could find in NI's support articles, so my next step was to clean out everything related to NI software possible to ensure I was doing a clean install of everything.

    To do this I took these steps;

    • I uninstalled every piece of NI software using their uninstaller
    • I deleted the contents of Documents/Native Instruments (I backed up my traktor folders as I did not want to lose my collection files)
    • I deleted both the Appdata Roaming and Local Native Instruments folders as well as the Native Access 2 folder
    • I deleted the Program Files/Native Instruments folder
    • I deleted all of the USER registry entries for Native Instruments
    • I then restarted my pc and then installed Native Access 2 and Traktor Pro 3

    I did not use the NI regtool at the time, as it wasn't covered in the support articles I was able to find and I only saw the recommendation to use regedit to remove the entries.

    I had opened a ticket with NI support and at one point they had recommended I use the NI regtool to remove traktor, but it didn't have any different effect from me manually removing the entries with regedit.

    I unfortunately do not have a system restore point from before the issue occurred, that was one of the first things I had tried to do when I ran into the issue, I don't know why but system restores were not enabled at the time on my PC.

    You mentioned that a windows reinstall is not a solution to solve third party software issues is generally not the solution, but this was the recommendation I was given by NI's support every time I've come to them with an issue related to their software having issues, hence why I spoke of a reinstall being my last option that I really didn't want to do, and also the reason I have reinstalled windows twice in the past to fix issues related to NI software.

    I made a post here because I wasn't really getting much help from the NI support ticket, they generally weren't listening to the issue I explained, sent a lot of copy paste responses that did not match the context I explained to them, it generally didn't feel like I was making any progress and they also told me the final option was to reinstall windows like they had told me for the other issues I had in the past after not really going that in depth into narrowing down why the issue was happening.

    At that point if I have to do reinstalls this frequently because of issues with their software, I'm much more inclined to sell all my NI hardware, as much as I like the hardware. I would much rather be able to figure out the problem and not have to do a reinstall.

    Sorry for the long explanation, but that's the full context of how I arrived to this point, I've spent a solid several weeks at this point trying to fix this issue.


    In regards to the services and scheduled tasks;

    Here are screenshots of the relevant tabs;


    PS:

    In regards to what I NI software I currently have installed, I only have Native Access 2, Traktor Pro 3, the controller editor, and all the controller drivers Native Access automatically installs when I install Traktor

  • Sunborn
    Sunborn Member Posts: 2,134 Expert

    Ok, i understand. I will try my best to help you but, at this point i can not guarantee anything. My suggestions are like "most probably but nothing certain" since i am not there to actually see in your PC.

    So:

    1- You said you have installed all drivers. The fact is that you need only the S4 MK3 and Maschine MK3 drivers, so please uninstall all other drivers.

    2- Your Services: Ough.... you have too many unnecessary things running automatically! If your really what to go for serious audio production (not necessarily on a pro level) you have to sacrifice some of this stuff. Some of them are really not necessary to run automatically in the background all the time and you should change them to Manual. Few others might very well to cause a conflict!

    For example the M-Audio service which is last in your image. Do you have an M-Audio Controller or Sound Card? Then, it is fine. But if you don't have any M-Audio hardware, then you must (not should, but must!) uninstall it or even delete it if there is no uninstaller.

    Or the Bonjour service. This is for MAC mostly. But you are on Windows! So, unless you have connected an Apple device such as an i-pad, i-phone etc. or you use Itunes, it has to be removed too. In your case, i see time stamp from 2011! Which is extremely old and dangerous. If you need to use this service for the above reasons then update it to the current version ASAP.

    Or, all the "software update" services. On 90% of cases (especially on older devices) an update will be never available! I suggest to remove/disable all of them except for the brand new ones (where driver is from 2021 or later).

    I stop here for now. Take a look on my services, i also have a multi-purpose computer, like you, but it is clean and fast as hell, though a bit old. Because i never have all those services and tasks to run in the background and make conflicts and "eat" my PC resources. If, for example i want to check for an update (once a year), i open the program and click "check for updates", instead of having a silly service running 24/7 for a whole year and, usually, without a purpose. And even with so few services running i still have the 3 Google and CCleaner to Manual, not Automatic and i even removed the 3rd NI service because it is for Komplete Kontrol (i don't have a Komplete controller), not for Maschine (which i do have, so i actually need only those 2 NI services). :-)


    Note: The very least you should do, is to disable most of those services temporarily, restart and check. If Traktor starts, the conflict is in one of those services! If still not start, then i give up, i have check almost any aspect i know.

    Services that you must keep enable, are: Malwarebytes, Native Instruments, M-Audio (only if you have hardware by them) and NVIDIA (only the last service "DisplayContainerLocalSystem"). That's all you really need. I am more and more confident that the root of your problem is here, in one (or more) of those services.

  • Stevan
    Stevan Member Posts: 1,512 Expert

    Each time Traktor didn't want to start on a PC that I have had troubleshooting it was related to the antivirus software.

    PC's are great when they work... Did you optimize it for gaming?

  • Sunborn
    Sunborn Member Posts: 2,134 Expert

    That is a good advice too. So, make an exception for Traktor in your antivirus settings.

  • Hidi
    Hidi Member Posts: 7 Member
    edited July 2023

    Unfortunately I had tried completely disabling both Malwarebytes and Windows Defender when NI support was giving me suggestions, but it had no effect on the issue either, however I have added an exclusion for Traktor now in both windows defender and malwarebytes to see if that helps.

    My PC isn't really optimized around gaming, it is my general use computer, so I do play games on it but that's the extent of it.


    I uninstalled all of the NI drivers except for the S4 MK3 and Maschine MK3 (though note, I did not intentionally install all of the drivers at once, this is just what Native Access does automatically)

    Thank you for the insight on running services, I was aware of having too many startup tasks not being great for your system but hadn't really thought about what services were running before. I do have an M-Audio MIDI keyboard, however I'm not using it currently so I uninstalled the driver for it to help rule out more things. I also uninstalled some things that were in the services list that I haven't used in a very long time.

    I also set all the services to manual outside of Malwarebytes, NI, and the NVidia DisplayContainerLocalSystem and ensured they were not running after a reboot, but unfortunately there's no change in the issue after doing this.

  • Sunborn
    Sunborn Member Posts: 2,134 Expert

    That, is really frustrating, i hoped that the solution was there...

    I am out of more ideas right now, and logically your next step should be to reinstall everything (including Windows), but if you are not in a hurry, give it 2-3 days, maybe i think of something, or some other member may come with a fresh idea!

Back To Top