Traktor Pro 3.9 causes constantly flashing displays on S4 mk3. AMD GPU

markjay_boston
markjay_boston Member Posts: 20 Member
edited August 2023 in Traktor Software & Hardware

I just installed Traktor Pro 3.9 and my displays now constantly flash. Windows 11. AMD

Is anyone else experiencing this? Trying to figure out how I can downgrade to 3.8 now.

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod
    edited August 2023 Answer ✓

    Controllers with displays are flashing / flickering when used on Windows devices with AMD GPUS. This bug is filed under the reference TP-17931. It is still under investigation. the only workaround at the moment is to downgrade to 3.8, here is the installer: TRAKTOR 3.8.0 for Windows

«1

Answers

  • markjay_boston
    markjay_boston Member Posts: 20 Member

    Saved!

    How Can I Downgrade my TRAKTOR to an Earlier Version? – Native Instruments (native-instruments.com)

    And indeed starting 3.8 again shows no flashing. So definitely not a cable or OS issue.

  • lord-carlos
    lord-carlos Member Posts: 2,070 Expert

    It's a known bug, you should find other threads about it.

    No workaround yet besides using 3.8 again.

    I assume you have an AMD gpu?

  • alexssoundtrack
    alexssoundtrack Member Posts: 2 Newcomer

    I have this problem too. I contacted support last week, they asked for a video which I sent and haven't replied. I don't have the option of reverting to 3.8 as I've just only started with Traktor. Would appreciate some customer service from NI for my new hardware!

  • GeOKid
    GeOKid Member Posts: 2 Newcomer

    Same issue with my S8. Anyone found a fix for this yet?

  • lord-carlos
    lord-carlos Member Posts: 2,070 Expert
  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin
    edited July 2023

    Confirming that there's a known issue with computers with AMD gpus at the moment and the Traktor team is on it. Apologies for the inconveniences.

  • Kubrak
    Kubrak Member Posts: 2,762 Expert

    I am not sure, but my guess is that problem is on AMD CPU with iGPU, not any AMD CPU. I may be wrong....

    So, mostly notebooks or most PCs with latest AMD CPU generation (7xxx). The older PC AMD CPUs did not have iGPU, so I guess they might be OK.

    I will try APU 5700G, older AMD that has iGPU. Intel is OK on my S5 and D2.

  • SteveKDJ
    SteveKDJ Member Posts: 132 Helper

    AMD CPU is not recommended. And it is true. I recently bought an Intel Core processor, well the flash runs faster (it hasn't disappeared) but it's more compatible even so... it solved my shocking sound problem, of course it's not capital intensive...

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod
    edited August 2023 Answer ✓

    Controllers with displays are flashing / flickering when used on Windows devices with AMD GPUS. This bug is filed under the reference TP-17931. It is still under investigation. the only workaround at the moment is to downgrade to 3.8, here is the installer: TRAKTOR 3.8.0 for Windows

  • Dj X6
    Dj X6 Member Posts: 2 Newcomer

    bonjour,

    j'ai récemment (08/2023) acheté le S4Mk3 et un ordinateur portable ASUS Vivobook équipé d'un Ryzen 5 5600.

    1/ avec Traktor pro 3.9 les écrans du controleurs ne s'allument pas

    2/ avec Traktor pro 3.8 les écrans du controleur clignottent

    3/ avec Traktor pro 3.7 les écrans fonctionnent normalement

    donc je suis resté sur la version Traktor pro 3.7

    aprés plusieurs utilisations, Traktor pro 3.7 plante !!!! et ça m'est arrivé pendant une soirée !

    le problème est connu depuis 2018 et je ne comprends pas comment en 2023 les ingénieurs de NI n'ont pas solutionné ce problème !!

    Pourquoi NI ne mentionne pas que Traktor Pro 3 n'est pas compatible avec les processeurs Ryzen ??

    Y a t'il une solution ?

    ou faut t'il changer de Pc ?

    ou puis je télécharger la version de Traktor Pro 3.7 ?

    Merci e votre réponse

  • lord-carlos
    lord-carlos Member Posts: 2,070 Expert

    This is an English speaking forum, please use deepl.com or similar to translate your message so others can read it.

  • Dj X6
    Dj X6 Member Posts: 2 Newcomer
    Good morning,
    
    I recently (08/2023) purchased the S4Mk3 and an ASUS Vivobook laptop with a Ryzen 5 5600.
    
    1/ with Traktor pro 3.9 the controller screens do not light up
    
    2/ with Traktor pro 3.8 the controller screens flash
    
    3/ with Traktor pro 3.7 the screens work normally
    
    so I stayed on the Traktor pro 3.7 version
    
    after several uses, Traktor pro 3.7 crashes!!!! and it happened to me during one evening!
    
    the problem has been known since 2018 and I don't understand how in 2023 NI engineers have not solved this problem!!
    
    Why doesn't NI mention that Traktor Pro 3 is not compatible with Ryzen processors??
    
    Is there a solution ?
    
    or should you change your PC?
    
    Where can I download Traktor Pro 3.7?
    
    Thank you and your response
    


  • Frits
    Frits Member Posts: 14 Member

    I don't know why ANY software developer would even think of trying to install on a couple of different PC's before releasing software.

  • Frits
    Frits Member Posts: 14 Member
    edited October 2023


    Here is a suggestion: Provide a decent guide on how to "downgrade"!!!

    When I downgrade, the controller is no longer found, when I upgrade, there's flashing screens.

    Just purchased, followed all instructions, the thing is not working!

Back To Top