Bug Display KONTROL S4MK3

Options
Fredstudio
Fredstudio Member Posts: 12 Member

I have just acquired an S4 Mk3 from Native Instruments, it is a B-stock on their Reverb store, so practically new, arrived very well refurbished with license.

My problem concerns the display, it does not display the tracks and the information that goes with it.

I followed all the recommendations concerning this kind of bug encountered by other users among others:


Verification of the different drivers installed by windows 10


I did the test on 2 different computers a recent and powerful laptop

And another pc a little less powerful but still on W10 and up to date


I also installed the latest version of Traktor 3.9.090 sometimes it could work in my favor


I even forced traktor in administrator mode (I read that some user had solved this problem by doing so)

And the Kontrol S4 MK3 has been updated, the present firmware was not the latest, I am now in 0.6

Nothing helps


If I unplug the USB cable once Traktor has started, there is the track that appears and the display shows the info and after a few seconds freezes then more information is updated when the tracks change


during the brief moment when it works, all the information on the display is functional, for example if I turn the loop button, the value is incremented on the display as on the software.

The beat of the track counts down and the bpm fluctuates as I move its value. But after a few ten seconds nothing. the values freeze and no way to have anything, loading a new track does not change anything.


If not at startup the screen does not display anything as if there was no track in the player and when I load a track into a player it remains in this state.

I also installed the asio driver which is installed as an option, even if it only concerns the audio and sound card section, it does not change and the fault persists.


On the photo the display as it is even with a track loaded

Tagged:

Answers

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,946 mod
    Options

    Did you check if the problem persists using the controller with an earlier version of Traktor Pro 3?

  • Fredstudio
    Fredstudio Member Posts: 12 Member
    Options

    I would like to try, but my 2 computers are now with version 3.9

  • Fredstudio
    Fredstudio Member Posts: 12 Member
    Options

    I did the test with several old versions, found in Backup, one of which did not load any library, just the default Traktor samples and the fault persists.

    What happens normally when you leave Traktor with the S4, the displays keep the latest info or it should reset?

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,946 mod
    Options

    The backup versions can each have their own collection. Depends on what its root folder is set to.

    The question is if the screen is working correctly with older versions or not. If the screen does work with older versions, then the new version of Traktor is at fault. If the screen doesn't work correctly even with older versions, then the device is at fault.

    When you close Traktor, the displays should reset, showing only the logos.

  • Fredstudio
    Fredstudio Member Posts: 12 Member
    Options

    So the display does not work better with older versions. It seems that the problem comes from the Hardware of the S4, I did the test on 2 different computers with different processors, the problem is the same

  • lupino2b
    lupino2b Member Posts: 11 Member
    edited June 2023
    Options

    post error sorry



  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,769 mod
    Options

    Any screen mods installed?

  • Fredstudio
    Fredstudio Member Posts: 12 Member
    Options

    No screen mods

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,769 mod
    Options

    Try to reinstall GPU driver in your PC (Intel GPU driver as well if you use one).

  • Fredstudio
    Fredstudio Member Posts: 12 Member
    Options

    On the laptop I have 2 graphics cards, I did the test using the one integrated into the CPU and with the Nvdia Quadro P620 card, it doesn't change anything. I have the same problem on another PC, so I don't think the PC is the cause, the other PC is a ZOTAC with graphics card integrated into the processor.

    These mini display of the S4Mk3 are managed by the graphics card of the PC?

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,769 mod
    Options

    Each time I had an issue with S4 screen it was Intel driver issue and reinstalling the driver fixed it. Just a thought and something worth trying.

    Good luck!

  • Fredstudio
    Fredstudio Member Posts: 12 Member
    Options

    Thanks for the lead, I'll try that when I get home.

  • Fredstudio
    Fredstudio Member Posts: 12 Member
    Options

    I did the test of uninstalling the graphics card drivers and trying to keep only the processor one, I had uninstalled it first and reinstalled it, it didn't change anything. still the same error. I am now in configuration with use of the graphics card integrated into the processor. I do not really know what to do anymore. Can an update to Windows 11 make things better or worse?

Back To Top