Traktor S4MK3 screen bug

lddig
lddig Member Posts: 1 Newcomer

Hi all, since the last update of traktor pro 3, I have a bug on my controller, the screens blink non-stop, and I have no answer to my ticket on NI support.

If anyone can help me please T_T

Best Answers

«134

Answers

  • lupino2b
    lupino2b Member Posts: 11 Member
    edited June 2023
    Hello, I have the same problem with the 3.9 rc and s4 mk3
    


  • Drew Poi
    Drew Poi Member Posts: 4 Member

    Yeah same here me and my homie are both having issues with the new 3.9 update. Tried uninstalling and reinstalling everything including drivers. Nothing has worked. The screens start flashing as soon as Traktor opens. So you can tell it's a software issue and not a hardware issue.

  • Drew Poi
    Drew Poi Member Posts: 4 Member

    Anybody know if there's a way to downgrade back to 3.8?

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert

    Open the folder '...\Native Instruments\Traktor Pro 3\Backup'.

    Enter the folder of the past version of your choosing. Double click the exe file. Best make a shortcut on your desktop.

  • lupino2b
    lupino2b Member Posts: 11 Member
    Just a joke to push a version with bugs. No one test?
    
  • Drew Poi
    Drew Poi Member Posts: 4 Member

    Really thought wee could hear back from a NI employee by now. Does NI just leave the solutions up to the community or do the employees get on and respond too?

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert
    edited June 2023

    You should also contact TechSupport:

    SupportLink

    Click through the menu where you answer a few questions and (in the end) submit a support request. That's about all the community managers can do for you anyway. The request will typically go to where it is supposed to go. I have no idea how fast it's going to be resolved; it depends on the severity and frequency of the issue would be my guess.

    EDIT: I believe the bug may have something to do with the update of the gfx libraries used in 3.9.


  • lupino2b
    lupino2b Member Posts: 11 Member


    I have version 3.8 installed which works great. Test 3.8 works. My AMD 7850 graphics card supports
    OpenGL 4.6
    I'm running Windows 10 LTSC Enterprise.
    


  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert

    You should maybe mention that as well when you request the support ticket. Maybe another user has run into this problem and discovered a solution to solve it; i've got a feeling though this is something the NI coders will need to tackle, so it's a good idea to inform them as directly as possible.

  • Stevan
    Stevan Member Posts: 1,511 Expert

    This kind of issues happen when new hardware is in testing. S4 MK3 has other issues as well though and need an update.

  • ariesps
    ariesps Member Posts: 3 Member

    Same problem here. Waiting for an update...

  • Datapoint
    Datapoint Member Posts: 1 Newcomer

    Same problem here.

    Yoga slim 7 14are05

  • Dintsch
    Dintsch Member Posts: 3 Newcomer

    Gestern bei einem Kollegen getestet, alles hat bestens funktioniert.

    Heute habe ich alles aktualisiert, selbes Display Problem. Sobald Traktor geöffnet wird fangen die Displays an zu blinken.

    Bitte um Ratschläge.

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert

    We should all flood TechSupport with these reports for urgency.

  • Dintsch
    Dintsch Member Posts: 3 Newcomer

    Welche Betriebssysteme verwendet ihr?

    Hat jemand den Kontak zum Techsupport?

Back To Top