Logout/Login issues and Native Access malfunctions

Options
Hayo_NI
Hayo_NI Product Team Posts: 290 mod

Hey all,

On May 8th or May 9th, some of you may have noticed your Native Access malfunctioning. We tried to upgrade our backend systems to improve security, but it led to exposing a tech issue where we did not redirect you to the login screen when your session expired.

We have plans to try again, which is largely what this latest release tackles. We're still hard at work on the download improvements and uninstall, alongside researching Daemon stability concerns, but I wanted to take a moment to apologize for inconveniences there.

We're revisiting this in early June and will notify you with more info in anticipation when we start and when the process is done. Bear in mind, when we do this, your login session will likely be invalidated and you'll need to log in again, but you should no longer have your app behave oddly. We're prepared to hotfix if this is not the case, however. I will keep you posted.

Thank you for your understanding, and apologies for the inconvenience.

Comments

  • KIRI
    KIRI Member Posts: 34 Member
    Options

    So is this why I'm getting the following error code? and is there any workaround or should I just revert to using Native Access 1?


  • Vocalpoint
    Vocalpoint Member Posts: 1,127 Guru
    Options

    This is not due to anything that happened in May.

    And it appears your Native Access 2 is outdated as well. 3.4.0 is the current version. I would update first and then try it again. The install process will remove and replace the NTK Daemon service.

    Are you on Mac or Windows?

    If it's Windows - I have a workaround - if it's Mac - unfortunately I am not familiar with how NA2 works on that OS.

    VP

  • PoorFellow
    PoorFellow Moderator Posts: 3,514 mod
    Options

    N.A. 1 is considered as obsolete by N.I. , and as Sunborn says update tn newest : Native Access 2 / 3 : https://www.native-instruments.com/en/specials/native-access-2/

  • nielsdolieslager
    nielsdolieslager Member Posts: 1 Member
    Options

    Version 3.5.0 still malfunctions. macOS 12.6.8. First it becomes unresponsive two times, then I get "Unable to log in. Please restart your computer and try again."

    I've never had a day where Native Access would work without problems. I don't understand why NI continues this problematic piece of software. Downloading installers from the site and activating them with Service Center always worked.

  • Vocalpoint
    Vocalpoint Member Posts: 1,127 Guru
    Options

    @nielsdolieslager

    "Version 3.5.0 still malfunctions."

    Most likely because 3.5 is super old. You should consider giving v3.7.0 a shot

    VP

  • Hayo_NI
    Hayo_NI Product Team Posts: 290 mod
    Options

    Yes. Please uninstall 3.5.0 and install the latest version here.

  • zeus117
    zeus117 Member Posts: 4 Newcomer
    edited November 2023
    Options

    Just go back to Access 1! NOBODY cares about the new version, since it started it was full of bugs and was a joke honestly. At least version 1 works. But not with every instrument! Which is a shame and should be addressed. Version 2 is not something the customers asked for...especially not in this state.

  • zeus117
    zeus117 Member Posts: 4 Newcomer
    Options

    I honestly don't understand the entire project at all. Just provide the images like in the past and that's it. No need for such a desktop application. Especially considering how problematic it is for ages now. Authorization can happen via webpage as always, nothing else is necessary. Even your website lags, omg.

  • zeus117
    zeus117 Member Posts: 4 Newcomer
    Options

    Can you release a software AFTER you tested it properly?

  • JamesEdnayCox
    JamesEdnayCox Member Posts: 4 Newcomer
    Options

    I am a new user of NI as of today but I can't access any of my purchases because I can't login to Native Access 3.8.0... my User and Pass don't work???? Mac 13.5 M1

  • PoorFellow
    PoorFellow Moderator Posts: 3,514 mod
    edited December 2023
    Options

    If applicable then : Try using your Mac user system password for Mac system pass word pop-ups rather than your N.I. username and password !

    (Apparently not a Mac password problem , user has made this thread ! : https://community.native-instruments.com/discussion/20253/cant-login-to-native-access-new-user#latest )

    P.S.

    If you have Private Relay in your OS turned on then try disabling that !

  • o.berg4
    o.berg4 Member Posts: 9 Member
    Options

    Just a heads up if you've been having issues with Native Access around May 8th or 9th – it wasn't just you. They were tinkering with the backend to amp up security but oops, it glitched for some of us.

Back To Top