How to install Reaktor 5?

Kymeia
Kymeia Member Posts: 3,451 Expert

I'm setting up an old iMac to run things like Kore 2 and Absynth off but NA1 isn't showing Reaktor 5 anymore so how do I install it? The legacy downloads won't let me as it says I need then original installer first but that would have been using service Centre I suppose

Best Answer

Answers

  • ShelLuser
    ShelLuser Member Posts: 240 Pro

    First you need to make sure that it's listed in your products & serials overview. But second, just as important: what does it say behind the entry?

    And finally, just making sure: did you enable legacy products? =>


    ... though that option has its limits:



    found it:

    ^ I think that should help you out; when I search for Reaktor 5 I get several installer updates which I believe to be the full updated installer.

    Hope this can help!

  • Kymeia
    Kymeia Member Posts: 3,451 Expert

    Yeah the downloads from the updates link as I said won’t install because they tell me I need to original install first but I don’t get that, haven’t needed to go back to the original CDs if that’s what it wants for years and certainly not since NA came out

    Also I’m using NA1 as this is being setup as a system for the older products so it doesn’t have a legacy option but R5 has always shown up before in NA1

  • Paule
    Paule Member Posts: 1,328 Expert
    edited May 2023

    https://www.native-instruments.com/en/support/downloads/update-manager/?q=Reaktor+5&t=updates

    The updates are here.

    As I got my win10pro computer last year in summer, start NA and dl it. R5 was on Board. There was no CD/DVD need.

    Is your Mac fit for Reaktor 5?

    See here also, a question by Greg:

    https://community.native-instruments.com/discussion/11797/is-it-still-possible-to-download-and-install-reaktor-5#latest

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited May 2023

    You can find the installer here: Reaktor 5.9.4 for Mac

    What operating system is on this old iMac?

  • Kymeia
    Kymeia Member Posts: 3,451 Expert

    Mohave - thanks - is that a full installer or will it also tell me I need an original install first?

  • Kubrak
    Kubrak Member Posts: 2,724 Expert

    If you need I should have original installer. If that one fits your OS version. I have recently bought Komplete 8 and have all the installation DVDs....

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    Answer ✓
  • Kymeia
    Kymeia Member Posts: 3,451 Expert

    Thanks - I do have original DVDs somewhere from Komplete but just assumed the installers wouldn't need them as they are so old they probably don't even run on Mohave. Anyway the one posted by Jeremy appears to be full so I should be good

  • Kubrak
    Kubrak Member Posts: 2,724 Expert

    OK, the best solution NI download link is full version.

    It is strange, it is not possible to install directly from NA. I have found quite recently that NA does not install legacy piano tetralogy (New York, Berlin, Vienna, Upright), but it is possible to authorise it. Before one has to download those instruments from NI web....

  • montesumolo
    montesumolo Member Posts: 4 Member

    Hello!


    Found a solution for me on macos 10.15 Catalina. It is a transplant from a macos mojave 10.14 installation.


    You need an (external) HD with mojave installation

    You need a Komplete 9/10 or any other Legacy Original installer on HD from a prior purchase.

    You need the old/classic Native Access (white) - I used Native Access 1.14 (https://support.native-instruments.com/hc/en-us/articles/360000407909-Native-Access-Legacy-Installers-for-Older-Operating-Systems)

    Download updates from Legacy Software page

    So If you are coming from Mojave, do not install any NI files on your fresh installed Catalina; Just transplant your files from Mojave, restart and start your "old" NI Access


    ->


    Boot your Mac from ext. HD in mojave

    Install your Software from the Komplete 9/10 HD Installer (eg. Reaktor 5 and Reaktor Instruments) onto mojave HD

    Open NI Access white Version and register all

    Install Reaktor 5 update

    Boot into Catalina with no NI products installed (clean - uninstall: https://support.native-instruments.com/hc/en-us/articles/210291865-How-to-Uninstall-Native-Instruments-Software-from-a-Mac-Computer)

    Transplant all your directory files (Library, User Library), apps and PlugIns from mojave HD to the catalina HD

    This worked for me! Hope I could help!


    !!! Now on Catalina I still have Native Access 1.14 and the download and install of other items such as Omnia Choir Library, downloaded much faster and succeeded to install instantly; After trying it for 3 days on an Intel machine and an M1 Max machine with the corresponding new Native Access 3.2. Versions !!!

  • Kymeia
    Kymeia Member Posts: 3,451 Expert

    Thanks everyone but the full installer Jeremy posted works for me on Mohave so I'm sorted

Back To Top