NI Traktor Kontrol S4 MK2 DJ Controller requirements

Jesse
Jesse Member Posts: 2 Noise

Greetings,

I have my eyes on a used S4 MK2. Is it supported with my current licensed version of Traktor Pro 3.5.2 299 . Are there any other requirements I should be aware of or need? any assistance is appreciated.

Cheers!

-Jesse

Best Answers

  • ilove1981
    ilove1981 Faringdon, UKMember Posts: 12 Sine
    Answer ✓

    The S4 Mk2 is fine to use with Traktor Pro 3. I used mine for a quite a while before purchasing an S4 Mk3. I'm not aware of any other specific requirements you need to be mindful of. There may be some initial limitations, such as being unable to select/control Mixer FX but your Mk2 has controls for the FX units so you should be covered.

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    Answer ✓

    It is supported in Tp3 so you should be good to go. Check here for driver support for your device once you decide to get it.


Answers

  • ilove1981
    ilove1981 Faringdon, UKMember Posts: 12 Sine
    Answer ✓

    The S4 Mk2 is fine to use with Traktor Pro 3. I used mine for a quite a while before purchasing an S4 Mk3. I'm not aware of any other specific requirements you need to be mindful of. There may be some initial limitations, such as being unable to select/control Mixer FX but your Mk2 has controls for the FX units so you should be covered.

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    Answer ✓

    It is supported in Tp3 so you should be good to go. Check here for driver support for your device once you decide to get it.


  • Jesse
    Jesse Member Posts: 2 Noise

    Thanks for the info

Back To Top