Sound holds forever when pausing playback during a MIDI note

miamig
miamig Member Posts: 2 Noise
edited February 17 in Massive X & Synths

Hi, I'm trying here before submitting a ticket to support. In Ableton Live arrangement view, when I play a midi clip on a track with Massive X loaded and pause it while a midi note is playing, the sound keeps playing.

If I pause after a note has finished playing, no issue. When the AMP ENVELOPE trigger mode is set to ONESHOT, the sound plays the whole envelope and stops as expected. When I play the midi keyboard, no issue. The problem only occurs when ENV 1 trigger mode is GATE or LOOPGATE and input data comes from a midi clip.

So it seems to me like pausing the playback is note recognized by Massive X, and the sound remains stuck in sustain phase.

I tried with Massive and the behavior is normal : when pausing transport at any moment during a midi clip playback, the sound stops.

I'm on Live 11.1 in Mac OSX Monterey 12.2.1 on an M1 Max MBP not running through Rosetta. I use the Massive X AU plugin, version 1.3.6 (R240). I reinstalled it from Native Access but it didn't change anything.

Thanks for any help you can provide. I'll work with other synths in the meantime.

Best Answer

  • miamig
    miamig Member Posts: 2 Noise
    Answer ✓

    Update : I opened the Ableton Live Set with Rosetta and the issue disappeared. So probably an M1/Apple Silicon compatibility issue. Would love to have this sorted

Answers

  • miamig
    miamig Member Posts: 2 Noise
    Answer ✓

    Update : I opened the Ableton Live Set with Rosetta and the issue disappeared. So probably an M1/Apple Silicon compatibility issue. Would love to have this sorted

  • Uwe303
    Uwe303 Moderator Posts: 360 mod

    Normally a DAW sends midi off signals if you press pause, maybe that's not the case for ableton without rosetta running on M1 mac's

    Uwe

  • Isaac Stroke
    Isaac Stroke Member Posts: 1 Noise

    Hi ! I have the same issues than you. Massive X works fine in Ableton 10 with Rosetta. But in live 11, there is a bug just with massive X. All my others plug-in works fine. I've send a message to native instruments, I hope they have the solution.

    Good night.

  • operasix
    operasix Member Posts: 1 Noise

    Hey Native Instruments,

    how long do you want us to wait with this problem ?

    We can't work with massive x having that sustain bug not fixed :(


    good night

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 671 admin

    @operasix Confirming that this is a known issue but we don't have a timeline for this bug fix yet unfortunately.

Back To Top