Why are some sounds in my expansions not loading into machine?

Tim Pratt
Tim Pratt Member Posts: 11 Member
edited February 2022 in Maschine


first post (i know) so a noob but anyhoo i've had my maschine mk3 for a couple of months now and moving at a turtle's pace i've figured most of the general things out about the hardware and software... but keep running into problems trying to load sounds into it. i bought a couple of expansions since original purchase and some of the sounds i like most won't load... just get back error message. but it only happens to some not all. why is this? also there are elements or banks i didn't even know were in the browser that won't load... in particular one called Battery. from what i'm reading it might have to do with my system os (mac osx high sierra) . hoping someone who might have gone thru this might give me some answers.. thanks!!!

Best Answer


  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert

     most won't load... just get back error message.

    What you need to do is find a few that do not load and list what they are (presets for an instrument, samples/loops etc...), also what the error you get, screenshots of what you are selecting and the error you get will help. Could be a number of reasons but rather than run through all of them, narrowing things down a bit will certainly help.

  • Tim Pratt
    Tim Pratt Member Posts: 11 Member

    will do that and post them when done listing.

    thx so much for your fast reply!✌️

  • J2D2
    J2D2 Member Posts: 21 Member

    Hi I’m just new to Maschine but have been in audio technology for 30 years so I had this same issue. I managed to track down a solution with a bit of help from users here

    mashine mk3 has battery instrument installed but unless you purchased the actual battery plug-in then they won’t load.

    however, the mashine preset on your browser already has 99% of them in there so I guess the battery instrument is a teaser to get you to fork out another $300 on an instrument. On your mashine browser look for the Maschine bank of sounds. It’s all in there.

    NI did release a fix for Mac offering battery v3 as a free download with over 10gb of sounds. However it’s an old version that requires an update which unfortunately doesn’t work on Catalina

    might work on yours however but you just be clogging your HD with duplicates wether it’s on battery or Maschine preset.

    hope that helps.


  • J2D2
    J2D2 Member Posts: 21 Member
    Answer ✓

    Just in case it works on high sierra.

    here is the NI link to download battery 3 with an updated to 3.2 and the sound banks for battery.


    trust me , it’s a waste of HD space you already got them all on mashine soundbanks.

  • Tim Pratt
    Tim Pratt Member Posts: 11 Member

    sorry for the slow reply but this is weekend learning for me...

    well these are all instrument packs that won't load and they all have the same error message(an exclamation point saying error on left lcd and on right lcd says 'Sorry _____ won't load'


    Block Base




    i am running maschine 2.14.5 on a mac book pro w/osx 10.13.6 with a Maschine Mk3.

    thanks again!!


  • Tim Pratt
    Tim Pratt Member Posts: 11 Member

    sorry, i don't even know how to directly teply to you on this forum (?)

    yes Battery is just one of the instruments that doesn't load. i guess the same holds true with all of them?

    just leaves new users wondering why it doesn't load and if they're getting jipped somehow lol.

    thx so much!!!

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert

    So nothing for Battery loads??

    Do you see Battery listed as a plugin in Maschine preferences? Or any plugins?

  • J2D2
    J2D2 Member Posts: 21 Member

    Hey Tim. Monarch should load.

    I got a heap of download content when I purchased my mashine mk3 only last week.

    monarch was one of the major synths you get free.

    id go to the native access and make sure they are showing up there.

    if they are click on the “installed” section and it will give you an option to reinstall.

    make sure to refresh the app when your in there at the top right of the screen

  • J2D2
    J2D2 Member Posts: 21 Member

    hey Tim,

    do you have the Reaktor 6 player loaded up in you native access ?

    if so go onto your software and load up the Reaktor 6 player and in there you should find the plugins you seem to be missing

    here is a screenshot of mine setup. Im pretty new to Maschine myself so I'm finding it difficult finding my way around a totally new workflow and setup, however I'm pushing myself to learn to navigate to find what I'm looking for before trying to create a masterpiece

  • Tim Pratt
    Tim Pratt Member Posts: 11 Member

    my mac runs system 10.13.4 which (i believe) won't let me install reaktor 6. everything else in my original downloads were installed except reaktor 6 player and i've tried doing so like 3 times. weird to me that somethings are available for my os but need mojave to install kontakt and other things i was looking to purchase. probably invest in another laptop this year but it's not like i've mastered anything in this yet so i'll get it as i go.

    really appreciate ur help! thx!!

Back To Top