Using a volume pedal

Gus
Gus Member Posts: 20 Member

I have NI 14 on Kontakt7 and I'm controlling it through MIDI with a Kurzweil keyboard. What I'd like to control the volume with a pedal (which is plugged into the keyboard and doesn't do anything). Or at the very least I could control the volume with the standard master volume slider on the Kurzweil -- which doesn't do anything either.

Can someone suggest a way for me to do this? Much appreciation.

Best Answers

  • stephen24
    stephen24 Member Posts: 279 Pro
    edited March 2023 Answer ✓

    You need to make sure your pedal and the volume control in your instrument are using the same cc#. The "standard controller" for the master volume slider is cc#7, and the standard sustain pedal transmits cc#64. If (as is likely) there's no facility to change the cc# of the pedal to #7, you will need to disable "accept standard controllers...", then (in the same panel) set MIDI controller #64 to "controller only" and automate the volume slider, or whatever is controlling volume, with cc#64.

    I know very little about modern digital piano pedals, but you may find especially with a cheap one that it won't give every value between 0 and 127 (not really necessary for a sustain pedal) so your volume could be a bit jerky.

  • Gee_Flat
    Gee_Flat Member Posts: 906 Guru
    edited March 2023 Answer ✓

    Yeah.... I never said it would achieve anything, I was only pointing you in the right direction. 😀

    Which instrument? Someone like @Uwe303 will open it up and help you troubleshoot it and probably find the answer. But its 3AM in Germany as we speak.

  • stephen24
    stephen24 Member Posts: 279 Pro
    Answer ✓

    If your problem still isn't solved, the key to my advice is the first sentence of my previous post. Things have to match. The other thing that must match is the channel number. I know nothing about volume pedals, but unless your pedal sends multiple messages on all 16 channels, in addition to the cc# you will also need to check that your instrument is set to omni or to the same channel as the pedal.

    When you get a problem like this, it's always useful to check MIDI traffic with a MIDI monitor. There is one in the Kontakt scripts.

Answers

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert
    edited March 2023

    Make sure in "Instrument Options > Controller" (click the wrench or gears) that the checkbox for "Accept Standard controllers for Volume and Pan is selected...

  • Gus
    Gus Member Posts: 20 Member

    On Kontakt7 at least, there appears to be no Instrument Options > Controller. There is "Options", but then that's where I arrive at a dead end.

  • Gee_Flat
    Gee_Flat Member Posts: 906 Guru
    edited March 2023


    Wrong gear. Load an instrument and top left of the instrument there is set of gears that @Blindeddie is talking about. That 's where the 'Instrument Options' are. Volume and Pan are on by default.

    If you create a 'New Instrument' it will have a wrench and then instrument options are available within 'Edit' mode.

  • Gus
    Gus Member Posts: 20 Member

    Yes, now I have it. I've tried numerous combinations of the four options under Instrument Options > Controller. None of them does anything to affect the success of either pedal (volume or sustain) to work. Is it necessary to reboot after resetting those?

    Thanks very much!

  • stephen24
    stephen24 Member Posts: 279 Pro
    edited March 2023 Answer ✓

    You need to make sure your pedal and the volume control in your instrument are using the same cc#. The "standard controller" for the master volume slider is cc#7, and the standard sustain pedal transmits cc#64. If (as is likely) there's no facility to change the cc# of the pedal to #7, you will need to disable "accept standard controllers...", then (in the same panel) set MIDI controller #64 to "controller only" and automate the volume slider, or whatever is controlling volume, with cc#64.

    I know very little about modern digital piano pedals, but you may find especially with a cheap one that it won't give every value between 0 and 127 (not really necessary for a sustain pedal) so your volume could be a bit jerky.

  • Gus
    Gus Member Posts: 20 Member

    I take it the "standard controller" you speak of is a MIDI standard used by NI? Because I was finding it hard to understand why Kurzweil would wire their MIDI products different from industry standard. Your suggestions (which I very much appreciate) changed nothing when I tried them.

    And then I loaded another instrument from the library simply called Violin Solo. Surprisingly for this instrument the volume pedal works exactly as it should. So does the pitch wheel. I played with the controller settings, and I realized that nothing changes the behaviour. It simply works exactly as expected, settings be damned.

    BTW, I have no issue with the sustain pedal. It has always worked perfectly the way it is. That just leaves the problem of making the pedal work with the other NI instrument libraries. Very strange indeed.

  • Gee_Flat
    Gee_Flat Member Posts: 906 Guru
    edited March 2023 Answer ✓

    Yeah.... I never said it would achieve anything, I was only pointing you in the right direction. 😀

    Which instrument? Someone like @Uwe303 will open it up and help you troubleshoot it and probably find the answer. But its 3AM in Germany as we speak.

  • stephen24
    stephen24 Member Posts: 279 Pro
    Answer ✓

    If your problem still isn't solved, the key to my advice is the first sentence of my previous post. Things have to match. The other thing that must match is the channel number. I know nothing about volume pedals, but unless your pedal sends multiple messages on all 16 channels, in addition to the cc# you will also need to check that your instrument is set to omni or to the same channel as the pedal.

    When you get a problem like this, it's always useful to check MIDI traffic with a MIDI monitor. There is one in the Kontakt scripts.

Back To Top