Busy season in progress... Please note that due to a high volume of requests, the response time from our support is currently longer than usual. Chat is temporarily not available. We thank you for your understanding.

Traktor Pro 3 M1 Max Issues: Freezes and tracks won't play

mozzatron Member Posts: 7 Sine
edited February 11 in Traktor Software & Hardware

Hi all

I'm running the latest version of Traktor Pro 3 with a new fully spec'd M1 Max Macbook Pro

I cannot get it to work at all. When i open the program and load a track into a deck, it won't play. When i then try to shut traktor down it freezes and i have to force quit.

Any ideas what the craic is?

Best Answers


  • TeLLy
    TeLLy CanadaMember Posts: 71 Tri
    edited February 11 Answer ✓

    Traktor's still not 100% compatible with M1 Pro. If you can before it freezes, go into settings and turn off Multicore CPU support. Should sort the issue till next update.

  • c0nsul
    c0nsul GermanyMember Posts: 57 Tri

    If you cannot enter Traktor preferences, you can edit your TSI-file with text editor and disable multi core processing.

    Make sure Traktor is closed and open your tsi-file with text editor:

    Go to line 397 (Use command+F to look for "Status.Multicore Support" Type="5" to find the right line) and change

    <Entry Name="Status.Multicore Support" Type="5" Value="1"></Entry>


    <Entry Name="Status.Multicore Support" Type="5" Value="0"></Entry>

    to disable multi core processing.

    Save and close text editor. Now, Traktor should start with just using 1 CPU core (which works for me until there is a fix).

    Let us know, if that helped.

  • mozzatron
    mozzatron Member Posts: 7 Sine

    Cheers guys

    Turned off the multicore processor support and that sorted out the issue

  • maximilian_ofc
    maximilian_ofc Member Posts: 3 Noise

    @c0nsul Thanks for your Help. Can you just kindly tell me or try to explain where the TSI-File is located. Thank you a lot for your help.

  • c0nsul
    c0nsul GermanyMember Posts: 57 Tri
    edited February 10

    You're welcome, @maximilian_ofc

    Go to Documents -> Native Instruments -> Traktor 3.5.2 -> "Traktor Settings.tsi"

  • maximilian_ofc
    maximilian_ofc Member Posts: 3 Noise

    @c0nsul thx a lot mate u saved me!!

  • Tim Slawik
    Tim Slawik Member Posts: 12 Sine

    Do you have a safe run always? No Problems anymore? Because i need it for Club Performance. Would you say it runs without freeze or anything else? (External mixing)

  • cazco
    cazco Member Posts: 43 Sine

    Hey Traktor friends on the M1 Pro, How are you finding the fix of turning off multicore? Is it stable? Has anyone road tested this a few times?

  • mozzatron
    mozzatron Member Posts: 7 Sine
    Answer ✓

    Hey guys. Since turning of Multicare support it seems to work good. Had no issues

Back To Top