Feedback Komplete Kontrol 3.1.X

Options
B.Minor
B.Minor Member Posts: 178 Advisor
edited February 14 in Komplete Kontrol

First of all, thanks to NI for providing your new KK 3.1.1 release which finally allows window resizing. From my perspective still one important thing is missing (which also applies to Kontakt 7 btw.):

In order to create a "real" full screen app, please finally activate the "maximize" icon in the KK3 top menu bar (currently grayed-out only), subsequently allowing users to maximize KK to its full and "monitor-filling" screen size by just one single click. Thank you.

However, the reason for my feedback is that I have experienced some inconsistencies when operating the current KK 3.1.1 release in conjunction with my NI S61/MK2 keyboard. As a pre-requisite and to comprehend what I'm talking about, let's assume that the "PIN" icon/switch in the KK3 browser menu is not activated. In theory, this should "force" any related VST plugin view to appear after its associated preset has actually been selected out of the KK preset browser list and loaded accordingly.

Case 1 - Navigating via PC keyboard (without MK2 controls):

When clicking on any particular NKS preset appearing in the KK3 app browser list (or when scrolling through the same preset list by using the PC keyboard's arrow keys etc.), the currently selected entry can be "pre-heard" accordingly. By pressing "ENTER" on the PC keyboard, the related sound for the currently highlighted preset/library will be finally loaded into memory while the KK3 browser view will also be automatically exchanged by a related VST plugin view (which is actually occupying the same window). Now, that's not what has been really appreciated by users, but this seems to be the "new way" KK3 is supposed to work. Fair enough, let's move on.

Another way to achieve the same result is to use the PC mouse and to double-click directly on a particular entry within the KK3 browser list; the associated VST plugin window will also be presented correctly on the screen by taking over the window space of the previously opened browser. However, whenever double-clicking in such a way, the "pre-hear" function will be even triggered twice, which was still not the case in KK2. Well, that's not really an issue; however, it's somehow annoying and should be pointed out. After all, it soon feels like an "audible bug" whenever working with the mouse and using the browser for longer than a few minutes only. Maybe NI can take a look and improve that situation. Thanks.

Case 2 - Navigating via MK2 keyboard (and this is the actual problem I'd like to report):

When performing exactly the same procedure as before directly from an MK2 keyboard, namely first browsing via the MK2 knobs through the actually presented NKS preset list and then stopping at a particular entry, the related sound(s) can also be "pre-heard" properly. No complains here; the current preset selection will not only be properly reflected on the MK2 display, it will also be shown on the app's screen, as it should.

However, after pressing the "LOAD" softbutton on the MK2 keyboard (or pressing the "3D KNOB" there instead) the preset will be finally loaded up, but only the MK2 display will change its actual view. Loading a particular preset via MK2 will obviosuly not trigger the related VST plugin view to appear on the PC screen simultaneously, even if the "PIN" icon/button in the KK3 app (supposed to prevent the content browser view from being changed) has always been turned off. The expected communication between MK2 and the KK3 app is simply not existing in this special situation (or is currently not working as intended).

In other words, especially when exclusively navigating on an MK2 kexboard directly, there is currently no way to open the associated VST plugin window of a newly loaded preset in the app via MK2 controls, unless the VST plugin window will first be opened manually within the KK3 app, e.g. by using PC peripherals. Please fix this, as this is obviously a bug, not a feature.

Special EDIT:

And even if the VST plugin view has been finally activated manually within the KK app as described above, the "browser content view" cannot be recalled again from the MK2's controls only. Even if pushing the "BROWSER" button there, the VST plugin view will remain to be displayed within KK3, instead of switching back accordingly to the browser view. Please also consider this reverse case.

Thanks again.

@Matthew_NI:

I'm fully aware that NI's main focus is currently set on the new MK3 keybard and its related interworking with the KK3 app, but please don't forget to test with older hardware as well. Please always keep in mind to (re)implement all those functionalities that have flawlessly been working already in KK2. If NI really intends to win back the favor of existing users owning older NI gear (or those who are willing to switch to newer ones in the future), please honestly compare previous features carefully with the ones you plan in the future and align those by introducing related KK3 equivalents as soon as possible.

In fact, in the described case above you wouldn't even have to bother to switch between two different KK3 views within the same app window when it would be much easier to present both views at the same time (like it was possible before). Exactly that's what has anyway been requested many times by die-hard users, as only this can be "the real thing" when it comes to "resizing options" and "full screen views". Thanks for listening.

Comments

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,886 mod
    Options

    However, after pressing the "LOAD" softbutton on the MK2 keyboard (or pressing the "3D KNOB" there instead) the preset will be finally loaded up, but only the MK2 display will change its actual view. Loading a particular preset via MK2 will obviosuly not trigger the related VST plugin view to appear on the PC screen simultaneously, even if the "PIN" icon/button in the KK3 app (supposed to prevent the content browser view from being changed) has always been turned off. The expected communication between MK2 and the KK3 app is simply not existing in this special situation (or is currently not working as intended).

    This is not a bug, it is intended behaviour. I think the idea was for the software and hardware views to be relatively independent from each other. However I do think it should be an option for the 2 views to follow each other.

  • B.Minor
    B.Minor Member Posts: 178 Advisor
    edited February 1
    Options


    Well, I can only hope that this current behavior was not intentional and will change in the next update. After all, it's ridiculous to forbid a feasable and well-established workflow that was already based on NI's exclusive keyboard control before. That approach allowed to use the MK2 keyboard control only without missing the detailed VST plugin view displayed on the PC screen in parallel.

    If users would always have to interrupt their flow by turning back to the KK app just in order to change KK views there (and not having the chance to change those views via the MK2's "BROWSER" and "PLUGIN" buttons for example), it will be really a pain in the...

    That's why I also mentioned that it would be best (or even the only targeted solution that makes any sense) to bring back the KK2-approved option to have both views available at the same time in the KK app. We can only pray for that to happen.😔

  • PulseCode
    PulseCode Member Posts: 132 Helper
    Options

    @B.Minor are you experiencing any crashes while opening different libraries in 3.1.1?


    such as this?

  • BIF
    BIF Member Posts: 673 Pro
    edited February 13
    Options

    Just dropping an anchor here to let you all know that 3.1.2 just hit Native Access. I'm sure we'll see a bug list for it later today...if one hasn't already been posted, that is.

    EDIT: In NA, the release notes says "fixed issue causing a crash in Cubase when showing/hiding user interface"

  • JesterMgee
    JesterMgee Member Posts: 2,650 Expert
    Options

    Yeah, like how some bugs are fixed, except the long standing issues some of us reported years ago that are STILL making it unusable in Ableton with many 3rd party plugins.

    Seems they can only work at the speed of fixing 1 bug a month so for the current list to be fixed, that should put us in about 2122

  • BIF
    BIF Member Posts: 673 Pro
    Options

    In their defense, February is only half-over. I'm hoping for at least one more update later this month. Anything less is just a cat playing with its food.

    Also in their defense, eventually, the bugs should (maybe?) eventually become simpler, and the team can begin to work multiples. The cat needs to bring home several mice with each cycle.

    But you're not wrong. Fixing only one bug per month and working on only one bug at a time will never meet the definition of "moving the needle". And they MUST move the needle...HARD. It can't be from zero to 1. It's gotta be from zero to 4 or 8. And they need to do it again in the next sprint cycle. And again in the one after that.

    Dribs and drabs won't do it. I'm still hoping for some serious needle-moving.

  • B.Minor
    B.Minor Member Posts: 178 Advisor
    edited February 14
    Options


    Sorry for my late reply. In order to reproduce the issue you reported above, I had to go back to my KK3.1.1 configuration first. Usually I'm immediately reverting back to KK2.9.6 after having tested NI's latest KK update, as their new KK3 concept still lacks of any basic functionality which even KK2 provided already. However, toggling between different KK setups within a few seconds is not a big deal for me, as I'm using a special Windows batch script I wrote and described in this thread.

    Now, even after massively loading different libraries from different vendors into KK3.1.1, one after another, I didn't experience any crashes like you did, not even while KK3 was running within Cubase Pro 13. Maybe I was just lucky. I also tried to load some "Retro Machines MK2" patches which you indicated in your screenshot above.

    After also having installed NI's latest KK3.1.2 update one hour ago, I tested again; however, I couldn't spot any loading issues. So, maybe the problem you reported might be caused by something specific related to your computer setup. Sorry, but I guess I can't help you here.

    At this point I also have to express my deepest disappointment with NI. There is simply nothing to "defend" or to "excuse" here. If a company is releasing an "update" in early October 2023, which only introduces issues for the majority of existing useres out there, breaks well-established workflows and doesn't seem to be at least "trying" to cope up again with its predecessor's functionalities and feature sets, this is simply unacceptable.

    More than four months have passed in the meantime, and there is not even a silverlining on the horizon that NI is really willing (or able) to introduce those improvements so many customers have asked for, even though NI has positively agreed already to go for them "soon". As you already pointed out, NI customers are really no fools, spending their precious time here in these forums for nothing. If thinking about it, it's a priceless service which a company like NI can even get for free, namely to have loyal users who are investing their time and giving their honest feedback, hoping that this might be in our all mutual interest. But as it seems, we are talking and reporting into a black hole.

  • PulseCode
    PulseCode Member Posts: 132 Helper
    Options

    @B.Mr.Wree I am back to 2.9.6 super stable zero issues, 1st when I started playing around with 3.1.2 I did not experience any issue it's after you play around with it for a while and load different libraries, NI’s own libraries.. and suddenly bam! I got that error ... it's sporadic and it happens on the desktop configuration stated in my signature and on my i7 12700H CPU with 40GM RAM and 4th gen Nvme drive laptop. When I go back to 2.9.6 both systems go back to zero issues. 

  • FelixP
    FelixP Member Posts: 9 Member
    Options
    > @PulseCode said:
    > @B.Mr.Wree I am back to 2.9.6 super stable zero issues, 1st when I started playing around with 3.1.2 I did not experience any issue it's after you play around with it for a while and load different libraries, NI’s own libraries.. and suddenly bam! I got that error ... it's sporadic and it happens on the desktop configuration stated in my signature and on my i7 12700H CPU with 40GM RAM and 4th gen Nvme drive laptop. When I go back to 2.9.6 both systems go back to zero issues. 

    @PulseCode Could you please attach a crash dump so that we can have a look into this? If the extension ".dmp" is not allowed, please rename it to ".txt". That worked before for an other user and helped us tremendously to pin down his problem. Many thanks!
  • PulseCode
    PulseCode Member Posts: 132 Helper
    Options
  • PulseCode
    PulseCode Member Posts: 132 Helper
    Options
  • JesterMgee
    JesterMgee Member Posts: 2,650 Expert
    Options

    Yeah, problem is I have been an active Beta member for years and submitted detailed reports of numerous issues as a pretty heavy user but some bugs, like the one that crippled the use of half the plugins out there when loaded as VST3 in Ableton was not only not actioned, but the ticket was closed without any notice (I assumed it was still open since I did not receive any notice it was actioned, just seemingly deleted) and as many have been pointing out, this is STILL a problem 2 years later.

    So forgive me for having less faith than others when it comes to things being done as I have been waiting literally years for some things to just be fixed, let alone improved.

  • FelixP
    FelixP Member Posts: 9 Member
    Options
    @PulseCode Many thanks for the dumps. We will continue the investigation.
Back To Top