Cueing tracks in Sync Mode - Pressing play never starts at right time

Options
NeilDil
NeilDil Member Posts: 18 Member
edited January 2023 in Traktor Software & Hardware

Hi everyone,

Has anyone else found this to be difficult?

9/10 times I press play when both tracks are synced, I appear to be pressing play at the precise moment needed, but the track will jump to the next beat in the grid. So this means it'll start the sound after the time I've actually intended it to start.

To get around this, I've always skipped the cue to where the drop is, pressed play and moved the cue around manually till it's in place, then I move the cue back 32bars or so to anticipate where I want it to start blending in from. However, like on CDJs or vinyl, I'd much prefer to be able to do this from simply pressing play at my desired cue point, without the risk of it not actually playing from that point - but, staying in time with the other tune.

I've tried cueing with sync off, but if you want to later switch sync on, it will skips beats / go off grid during the process of changing tempo or going into sync mode, ruining the mix.


I've used a Traktor S4 since 2011, for playing Jungle & Drum'n'Bass, also running a mobile disco. So I've had loads of time to try different methods, but this is so irritating, it makes me want to get some XDJs 700s just so I can mix without this issue.


I'd do it without sync but its convenient if you want 4 tracks playing at the same tempo. If it was possible to type in an exact tempo or nudge tempo manually it'd make life easier, because mixing out of sync mode turns out to be a game of how precise you can move the tempo fader in order to get the speed to the exact tempo as the other. Other than obtaining the same tempo, sync has no other useful function for me.


Anyone else been here? Does Serato rid this problem in the way its sync function is designed? Or are there other ways to get around this?

Comments

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,648 admin
    Options

    Not sure I've seen similar reports here before 🤔 If you want our support team to have a look, feel free to get in touch with us here: https://bit.ly/n1trakt

  • zephry
    zephry Member Posts: 595 Pro
    edited January 2023
    Options

    I assume you are mixing fast and wanting to (beatjuggle or dub? Do some skilled work),

    First thing to do is turn off quantize, this will make your cues more accurate. I also have heard that lower latency settings can help with this. But don't compromise your cpu usage if you have drops or pops. It still is synced to the grid but the jump isn't as noticeable.

    Snap setting set to off can help too if you are trying to hit certain spots slightly off grid, but that can result in beats being syncopated. Snap is for where the cue point or saved loop aligns to the grid when you set it. To get around the syncopation I used a couple of cues or have Flux activated to juggle the track.

    Keep in mind I am not the best at this and have only done a few planned out sets. I rarely use cue points. So someone else may have a flawless way of sync and cue point work.

    People have asked for quantize options in Traktor, for better cues.

  • djcarstenschmidt
    djcarstenschmidt Member Posts: 1 Member
    Options

    Hello everyone, I have the same problem and I would be grateful for any help! I can understand NeilDil considering switching to the competition but hesitant to do so as the better price/performance ratio must clearly be attributed to NI. 

    @NeilDil I also get around the jump problem very often just by using the jogweel like a turntable and vinyl. Either scratch in at the cue point or hold the track with the jogweel in front of the cue point and release the jogweel at the desired point. If you read this everywhere, nobody knows these old school methods anymore! Pity! 

    About 30 years ago, when I was a teenager, I started DJing very small (2 simple CD players and a simple HiFi amplifier), then gradually added mixers, pitchable CD players and turntables. About 15 years ago I started my first steps in purely digital DJing with a Reloop DigitalJockey 2 and NI Traktor 2 NE. I then switched to Traktor 3 Pro, in 2021 I bought the Traktor S2 MK3.

    I translated this post from German to English using Google Translate.

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,969 mod
    Options

    Apart from setting Quant to off, there is also a setting for the type of Sync. If you have it set to TempoSync instead of BeatSync, you will be able to manually adjust your needle position via triggering a HotCue or TempoBending, breaking the BeatSync, without changing the tempo while synced.


  • NeilDil
    NeilDil Member Posts: 18 Member
    Options


    @Zephyr


    Thanks for the suggestions. I've tried it like you say, with Quantisize off and Snap setting off.

    & you're right yes, I do like to get technical beat juggling etc, although this is a pretty

    straight forward function in my opinion, which of course, doesn't buy you as much time as you'd like

    when it comes to mixing 3 or 4 tunes alongside eachother. If I could treat each deck like a CDJ it'd

    make life so much easier. Hopefully there could be a better way for me to mix, failing no other option or any potential edit to the software/a tsi. Otherwise, I'm going to try going without sync again, but that's problematic when using 4 decks, it doesn't take long for a tune .2 BPM out of tempo to slowly confuse you & have you wondering which snare is the one you're about to nudge, which wouldn't be a problem if you were able to nudge as closely as 0.01 BPM.


    @djcarstenschmidt thanks for your input. Good to hear others can relate to this,

    whilst I'm also sorry to hear you have the same issue too. Ideally I want my S4 going

    through my 4 channel mixer so I can play vinyl alongside it, but this problem makes it difficult.


    @Sûlherokhh Thanks for the suggestion here.


    This is something I've tried n the past. I have temposync selected so I can nudge the cue point

    when it is out of place whilst synced. But it doesn't solve the issue, only corrects it after I've

    pressed play. That means each time I cue I need to cue again, then beat jump 16 bars or so back in order

    to anticipate where I need to be in the mix. 


    The problem is getting the track to play precisely when I press play. This doesn't happen

    when sync is on, it almost always plays slightly after and then I need to nudge it back into time.


    It wouldn't be so bad if I could just cue the track without sync on, then switch sync on once

    I've got it aligned, but when I do that, it ends up jumping to the wrong places and ruins the mix.

    (I discovered that whilst playing live after a couple of months getting used to it).


    If sync is off, it's almost impossible to get one track to the exact BPM as the other, otherwise

    that'd be a perfect option. It doesn't need to be synced, just needs to be identical BPM.


    So I'm having to get around this by treating each track like a warped vinyl, I can't expect

    to ever get both tracks playing the same BPM unless I press sync, but I can't cue reliably in sync.


    It'd be incredible if there was a possibility of writing this option into a version on traktor.

    I think a lot of DJs would jump towards traktor who generally would otherwise buy pioneer equipment.


    Even if you could just type the BPM in, or nudge it by single numbers, that'd fix the problem.

  • NeilDil
    NeilDil Member Posts: 18 Member
    Options

    @

    Kaiwan_NI Thanks, I've just sent a request for the team to look into this and see what possibilities are out there.

    All the best, Neil



  • NeilDil
    NeilDil Member Posts: 18 Member
    Options

    Update - I opened a ticket with Native Instruments tech support team.


    After 4 months of trying everything possible with the team at tech support, there is no fix for this whilst in Sync mode.

    There's no 100% guarantee that whilst in sync mode, pressing play will start the track at the exact precise moment you press it. Sometimes the track will play from the snare, instead of the kick drum, this has been demonstrated by the team on their setup also.


    I hope there is a way around this. All I want to do is match tempo with the track playing, without using sync.

    It's near impossible to manually adjust tempo as you can't move it in segments of 0.01 BPM, it's usually 1BPM at least.

    I can see this is possible looking at the Master Clock Tempo as there's a + -, allowing you to change by 0.01, but it only relates to sync mode.


    Is it possible to assign + - buttons to elsewhere on the Traktor S4 MK2 using a customized TSI? Ideally they could replace 'Flux' and 'Reset' buttons which are just above the tempo fader. It would work similar to a CDJ then and rid the problem of Sync making it difficult to cue tracks.


    I've always used Traktor S4 as a Vinyl DJ who never wanted to conform to CDJs, I wanted my own system which would be identical anywere I go, it's taken me to some amazing places around the world. Better, I can juggle 4 tunes and this helps set me aside from other DJs who use x2 CDJs. I also don't have to learn their equipment whilst performing, should their setup be different since I just plug into their main mixer.


    I want to play DNB & Jungle digitally but I find it so frustrating to mix in this way. I really don't want to but the only other option is for me to buy a pair of XDJ 700s, or XDJ 1000s. No one who comes round for a mix at my house can get the hang of mixing on traktor for the same reasons, whilst it might be a lot easier with techno or house played at 120BPM. So hopefully theres a way, because I don't want to spent £2000 on more equipment when I can use what I have, but if there's absolutely no way around it, I'll have to go with Pioneer and keep my Traktor S4 for doing mobile disco chart music.

    I think if more people was aware of a way around it, it'd encourage more people to go with Traktor, instead of the money hungry giants pioneer, who I've always steered away from.

  • Autumn_Attic
    Autumn_Attic Member Posts: 1 Newcomer
    Options

    Hey!

    I have the same issue and it's driving me crazy! My cue points are set, the grid aligns, and yet in both tempo synch and beat synch mode one of my songs will not play when I hit either cue button or play button with synch on. It waits a half beat or so.

    I don't run into this all the time, but often enough that I have to really wonder what's going on?

  • LostInFoundation
    LostInFoundation Member Posts: 4,320 Expert
    Options

    I think the problem here is that people using sync turned on think they are pushing buttons exactly at the right moment, but probably (even due to the fact the buttons need a little fraction of time to act) they are doing it just slightly too late, and therefore Traktor waits next synced “right” moment

    I understood this when adapting my finger drumming to devices (specially touch screens) which acts on finger release, and not on finger press

    A good test for this would be trying to push the buttons just a fraction of second before you think it’s the right moment, and see if Traktor always behaves correctly this way

Back To Top