M32 - suddenly keyboard works only as MIDI input and not KK protocol

WojtekHef Member Posts: 2 Newcomer
edited December 2022 in Komplete Kontrol


As I understand M32 should work the same as Maschine MK3 - meaning it uses it's own protocol for controlling Maschine/KK AND keys/pads. And it worked perfectly until today. I updated KK and Maschine and now M32 stopped working through the protocol. The only way to play it is by enabling MIDI in my DAW - but this creates a problem for me - I need to be able to change sounds and to be able to do it - I need to change instances. I can change instances, control knobs and keys are working correctly EXCEPT for keyboard - it doesn't work. If I enable MIDI input for M32 - it works but through MIDI - which means it plays every instance on KK/Maschine - no matter which one is selected in the plugin itself. I have identical configuration with Maschine MK3 and it works as it supposed to = I dont need to activate MIDI and I can change instances. I checked standalone in KK - and M32 works the same - only control keys/knobs and not the keyboard works - keyboard works only if I enagle MIDI in preferences.

So 2 things:

  1. where can I find previous version of Maschine (more important) and KK (less important) software (I suppose this is where the bug is)? I have a gig on Friday and rehearsal tomorrow so it's kinda not ideal that its not working. I never update right before gigs - so I did it earlier but I found out about not being able to switch instances only today sadly :O
  2. maybe there is some kind of internal reset for M32? I tried firmware tool but I have latest firmware and there is not option to rewrite it.
  3. Any ideas? :)

Best Answer


This discussion has been closed.
Back To Top