Welcome to the new and improved Native Instruments online community. Join our active forum of 40,000+ members for discussions and much more.

Logic Pro X & issues w/ multiple NI devices

GuessuR Member Posts: 8 Sine

I'm having an issue with my NI devices & transport control. I own a Maschine MK3, a Komplete Kontrol S61, and a Komplete Kontrol M32. All this is connected to a MacBook Pro with a M1 Max chip (running Monterey in Rosetta) via a powered USB 3.0 hub. Whenever I start Logic, it's a ***** shoot whether or not the transport controls will work properly. A lot of times, the transport controls on the MIDI keyboards will trigger notes instead. On special occasions, the keys will start minimizing windows and all other sorts of stuff that have nothing to do with triggering notes. Other times, the Maschine transport won't work. I've followed all the instructions as far as setting up Maschine for host transport control, and integrating Komplete Kontrol with my DAW. I'm constantly deleting the devices and reinstalling in the control surface setup...sometimes it works, sometimes not. I've also followed all the guidelines for using powered USB hubs. I noticed that the disclaimer regarding issues with Maschine & Komplete Kontrol devices on M1 Max chips has been removed. Is anyone else having these issues? What can I do to get rid of this extremely annoying issue?


  • seadragon
    seadragon Member Posts: 21 Sine
    edited December 2022

    Do things work properly if you remove one of the KK keyboards from the mix? I'm curious as I have a Maschine mk3, S61 mk2 and am literally taking delivery of a S88 mk2 this afternoon. I've been reading of various issues when trying to use 2 KK keyboards together and I wonder if this has anything to do with the issues you are experiencing.

  • Broadpath
    Broadpath Member Posts: 11 Sine
    edited December 2022

    I'm having the same issues as well, and have posted about it in the Community. This is a continuing issue with my single KK S61 mk2 in that it often requires starting and restarting Logic twice or even three times for the KK to be recognized as a control surface. It functions as a MIDI input when this happens but the remaining control functions typically require a reboot of logic. The primary suggestion given, i.e. providing full disk access to KK and Logic, didn't alleviate the problem. Once it kicks in, all works swimmingly but the crapshoot you describe can certainly be annoying.

    I have the issue where the transport controls will trigger notes, but I haven't yet experienced the keys minimizing windows;.

    In my case, my KK is not connected to my powered hub, but directly to one of my Mac Studio's (M1 Max) USB A ports. I am also running Logic under Rosetta to accommodate some remaining VIs that are not fully Silicon/VST3 compatible, such as Arturia products. I have no other devices functioning as a control surface within Logic that might cause a conflict.

    To date, the problem has not been resolved in spite of the best efforts and suggestions of others and I still haven't found a solution on my own. I also have a recently purchased Maschine Mikro mk3 that doesn't load all of its available VIs within Logic (though fine in standalone) but that's another story. All considered, it's likely the pitfalls of current platform transitions that will hopefully work themselves out as the industry aligns itself to them.

    I'm sure there are others who don't have these issues, as well as others with entirely different issues. Hopefully, as more of us communicate these issues, they'll find their way to the developers who can fix them, to at least find the underlying conflicts. At this point, no way I'm touching a Ventura upgrade until I hear the all-clear!

  • GuessuR
    GuessuR Member Posts: 8 Sine

    I tried starting up with only one keyboard connected. First time it worked fine, and still worked when I connected the 2nd keyboard. I waited a few days and tried it again...the 1st keyboard worked, but when I connected the 2nd the transport buttons triggered notes.

  • Broadpath
    Broadpath Member Posts: 11 Sine
    edited December 2022

    Just an update to this for my own use case - The problem seems to have resolved by a change in USB ports. I have a Mac Studio that provides two USB A ports in addition to it's Thunderbolt/USB C ports. My KK was connected directly to one of the A ports and my USB3 industrial-strength powered hub was connected to the other. I rearranged my peripherals by connecting everything (all 4 of my external drives and controllers) to the hub and the hub to one of the C ports with an A to C adapter. Other C ports serve my monitors and audio interface.

    So far, the KK has been immediately seen each time I boot up Logic since making this change. I also have far less issues with overall USB disconnects which was a regular occurrence when using the A ports.

    I'm not sure how much this helps you as I know the MBPs don't have USB A ports. In trying to solve this issue, I have been finding information where the USB A ports on the Mac Studios have been prone to disconnects for several users across other applications which prompted me to test this theory. Not sure why or how universal the problem is but so far, everything seems fine. I won't predict yet that it's fixed, but here I am at the moment....

    I only bring this up here as it might point to other issues within the USB busses across the M1 family. I didn't read where you tried another port or even another hub but you might want to check those possibilities out before further frustration sets in. I think we're still dealing with the after effects of the platform change and probably will for a while for both the Apple side and developer side of this process.

    Hope this helps in some small way - good luck!

Back To Top