Can't activate product, hangs on "Registering..." Anyone else have this issue?

Options
Topher
Topher Member Posts: 1 Newcomer

I've been trying to activate Guitar Rig Pro 6 for 3 hours now. Installed both versions of Native Access, uninstalled and reinstalled all programs, restarted my PC...


Gotta be honest guys, I paid $100. Not being able to use the product I paid for because your DRM is buggy isn't cool.

Tagged:

Answers

  • Uwe303
    Uwe303 Moderator Posts: 3,245 mod
    Options

    Hello,

    have you tried to go online and look under the "my products" page, maybe it is already registered, there was a bug with exactly that behavior. Then maybe log off your account and log in again in native access. It's only strange, that it happens with both versions.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
    Options

    @Topher Do you have more information available? Do you get an error message ? A demo message ? Have you contacted our support about it?

  • Giles
    Giles Member Posts: 10 Member
    Options

    Similar issue here - on NA 3.0.1 but it seems to be stuck installing Komplete Control even if I reinstall NA. I can't update or install anything.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
    Options

    @Giles The title of the thread here is "stuck on registering" your issue seems to indicate another issue. Have you tried these steps? Fixing Software Update Installation Issues (Windows)

Back To Top