Mixing Kontakt 7 and Komplete Kontrol 2.8 in Ableton

DunedinDragon
DunedinDragon Member Posts: 256 Pro
edited November 2022 in Komplete Kontrol

Something I just came across today. I have an Ableton Live 11 project which has several tracks using Kontakt 7 libraries and one track using a Komplete Kontrol 2.8 track. The Komplete Kontrol track inteacts and behaves normally with my Komplete S49 keyboard in terms of menu and light indicator interactions until I select one of the Kontakt 7 implementations in the project. From that point on the keyboard seems to be completely detached from keyboard indicators and interactions even if I reselect the Komplete Kontrol library in the same way as if I were interacting with a standard Kontakt 7 track. Is this a known bug?

Comments

  • DunedinDragon
    DunedinDragon Member Posts: 256 Pro

    Well, the mystery deepens. I discovered I needed to select the Komplete S49 as the input device in Komplete Kontrol to reconnect it. However I then discovered if I had two instances of Komplete Kontrol with two different instruments, once I select one of them it will stay connected and even if I select the S49 for the second device (actually it never shows as being connected), and there doesn't appear to be a way to disconnect the first one. To say the least, this is a really confusing interface. I hope it's by mistake rather than by design.

  • JesterMgee
    JesterMgee Member Posts: 2,434 Expert

    Firstly, the KK keyboard only offers "Smart Features" when connected to an instance of Komplete Kontrol and not Kontakt direct so if you want the smart features, you need Kontakt in a Komplete instance.

    Second, in Live it should switch to the instance of KK on a track when you ARM the track. If you use the keyboard to switch tracks this should happen automatically but if you are selecting a track manually with the mouse then no, it will not connect to that instance automatically.

  • DunedinDragon
    DunedinDragon Member Posts: 256 Pro

    Nope...doesn't work that way. If I have one instance of Kontakt and one of Komplete Kontrol, I have to designate the S49 keyboard as the input for Komplete Kontrol to get the keyboard to function correctly. If I go back and select Kontakt for recording, the MIDI keyboard still works as input with no keyboard specific lights or functionality, but when I re-select the Komplete Kontrol track for recording I have to go back and specifically re-designate the S49 keyboard as my input device in order to get the keyboard specific functionality for that library.

  • JesterMgee
    JesterMgee Member Posts: 2,434 Expert

    Do your transport buttons and track navigation all work?

  • DunedinDragon
    DunedinDragon Member Posts: 256 Pro

    Those work regardless of whether it's a Kontakt 7 or Komplete Kontrol instance since it's seen as a simple MIDI keyboard in both cases. It's only the smart keyboard features that are not enabled.

  • JesterMgee
    JesterMgee Member Posts: 2,434 Expert

    Um, yesthey should work regardless of what you are using in Live because they are control surface controls and these controls are not "simple MIDI" controls and cannot be mapped as MIDI functions at all, they only send data using the DAW port which can only be used by a script in a DAW to integrate it with the controls.... This is part of the "Smart Keyboard" feature and the reason I was asking was to determine if your control surface script was loaded because that also handles auto-switching between instances and the other "smart stuff".

    So, if you forget Kontakt for a moment and do a test using just Komplete Kontrol on 3 tracks, if you use the 4D encoder to shift between tracks in Live (does it actually shift tracks) and when you do does it auto-enable the selected KK instance?

    Can you post a screenshot of the MIDI preference page in Live?

  • DunedinDragon
    DunedinDragon Member Posts: 256 Pro

    When I load both instances as Komplete Kontrol I have the same problem if having to re-select the S49 for that track in order to enable the specific smart keyboard lights and browsing abilities. If anything my Ableton MIDI config may not be right. Here' the config screen:



  • JesterMgee
    JesterMgee Member Posts: 2,434 Expert

    Yeah your midi prefs are all over the shop.

    First issue, you have THREE different control surface slots set. You should have only 1 (even if you think you need more, just setup what is required by default for your tests).

    Second you have the KK DAW port checked as a Track Input, DAW port should not be selected in the midi section for anything, it’s control surface only.

  • DunedinDragon
    DunedinDragon Member Posts: 256 Pro

    Thanks. I have no idea how all that nonsense ended up in my configuration, but one glance and I knew it was a mess. Should have some time today to start cleaning it up.

  • JesterMgee
    JesterMgee Member Posts: 2,434 Expert

    Well, it doesn’t set itself so you would have done it and that’s my guess as to at least part of the issue.

  • DunedinDragon
    DunedinDragon Member Posts: 256 Pro

    Very insightful Captain Obvious....however setting it up appropriately per the instructions in the KK manual doesn't fix it.

  • JesterMgee
    JesterMgee Member Posts: 2,434 Expert

    Ok then, will leave it up to you to figure out. Good luck.

Back To Top