Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

Komplete Kontrol mk1 host integration issue in Ableton Live 11.1 (KBDSW-6954)

Stormchild
Stormchild Member Posts: 50 Helper
edited February 2022 in Komplete Kontrol

After updating to Ableton Live 11.1, none of the host integration features are working on my Komplete Kontrol S49 mk1.

  • Transport controls don't work
  • I can no longer navigate between tracks or clips
  • My keyboard does not switch between MIDI and NKS mode when I switch tracks in Live.

I installed the Komplete Kontrol remote script in Ableton Live's package contents (same as always), and I can still see and configure "Komplete Kontrol Mk1" as a control surface in Live, with "Komplete Kontrol S49 (Port 1)" selected for both Input and Output. And yes, I have the "Komplete Kontrol VST.adg" device loaded on a MIDI track. Everything is exactly the same as before…it just doesn't work.

I can manually switch between MIDI and NKS modes, but not being able to switch tracks or use the transport controls is a pretty big problem.

Best Answer

  • Stormchild
    Stormchild Member Posts: 50 Helper
    Answer ✓

    Rebooting fixed some of the problem. The issue was I didn’t have the “Komplete Kontrol S49 - DAW” device in my list, which is the one you’re supposed to assign for the control surface Input and Output. Once I set that back up, the transport controls and mode switching started working again.

    However, I still can’t navigate tracks or clips with the arrow buttons.

    It turns out if I switch to the “Komplete Kontrol AU.adg” plugin instead of the VST version, navigation works again. But with the VST version, the arrow buttons do nothing (even though the Komplete Kontrol plugin itself works fine). Seems like something changed in the way Ableton Live handles VSTs. Am I the only one seeing this?

    Anyway, since the AU version works fine, I guess I’ll just use that instead.

«1

Answers

Back To Top