KK S MK2 Ableton Live 10 DAW integration instructions

Hzz
Hzz Member Posts: 5 Newcomer
edited November 2022 in Komplete Kontrol

Are NI instructions correct for Komplete Kontrol S MK2 Ableton Live 10 DAW integration?

Nothing works for me leaving all MIDI Ports unconfigured


Tagged:

Best Answer

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert
    Answer ✓

    Set that to YES

  • Hzz
    Hzz Member Posts: 5 Newcomer

    Thanks Jester!

    That's a major flaw in the instructions

    Now it works, except for DAW integration

    Regards

    Hector

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert

    Not read the setup instructions (not something I usually need) but in all fairness it is probably explaining how to setup the Control Surface integration, usually most people click to the fact that you have to set the MIDI input for the device you are using as an input to the DAW.

    All I see is this for setup of KK in Live, doesn't mention to leave all ports disabled:

    DAW integration should be working from the look of your screenshot, the selection boxes under the Control Surface look fine. They should configure automatically or checking these you should see the DAW driver selected for input and output.

    What exactly "isn't working"? None of the buttons illuminate? Press Play/Stop isn't working? Etc?

  • Hzz
    Hzz Member Posts: 5 Newcomer

    Thanks again Jester,

    The mixer in the MK2 keyboard isn't working (the Mixer button is not lighted and clicking it does nothing) and the transport buttons (PLAY, REC ...) send MIDI notes instead of transport commands.

    If I switch the keyboard off and on again and do the same with Ableton closing it and opening again, after many times suddenly the Mixer works fine as well as the transport buttons, without doing anything in the keyboard or in Ableton (I have tried switching on and off only the keybioard and only Ableton and in both cases after many times it starts working so I cannot say where the problem is). It doesn`t seem a configuration problem; when it works it does it fine and it keeps working fine until I switch the keyboard off or close Ableton.

    I have opened a ticket with NI.

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert

    Hmmm, that is strange. Can you post a screenshot again of your midi settings now?

    if midi is triggered from the control buttons like play/stop then it sounds like the DAW port is selected as a midi input.

  • Hzz
    Hzz Member Posts: 5 Newcomer

    This is my MIDI port configuration. It works fine when it works

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert
    edited November 2022

    Yep, deselect these (you really only needed to follow the very specific instruction I initially gave and select just that initial port, possibly the remote port too)

    Those are your DAW ports which are already configured/mapped in the Control Surface section. If you enable these as MIDI inputs then the presses of buttons now send MIDI note data (unwanted)

    There are 3 ports available, the DAW one is for DAW control and should only ever be set in control surface selections and never as a MIDI input, the -1 is the actual MIDI IN port from the keyboard (the one that you set as the midi input device in a DAW) and the EXT is the external port on the keyboard, the DIN plug for connecting an external MIDI device.

  • Hzz
    Hzz Member Posts: 5 Newcomer

    Thanks again!

    This is a very interesting information that I was not able to find (Still don't know what Remote is)

    I have configured the MIDI ports as you say, just KOMPLETE KONTROL - 1 Track and Remote ON and try several times today. Many times it worked the first time but others didn't and I had to switch the keyboard off and on two or three times. It seems that the probability of working is much higher now, but the problem is still there. What a extrange error!

    Regards

    Héctor

Back To Top