Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

Maschine MK3 Third Party Plugins and latency

Damilu
Damilu Member Posts: 1 Member
edited November 2022 in Maschine

Hi everyone,

I've been trying to add thrid party plugins to my sound for a long time. It works, but as soon as I press the sound and the third party plugin loads, the sound starts 2 to 3 seconds later. As soon as I remove the plugin, the sound loads normally. How can I fix this?

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod
    Answer ✓

    Some 3rd party plug-ins induce a delay (due to processing), unfortunately, the Maschine software doesn't have Plug-In delay compensation, it's a common feature request. Hopefully this gets addressed in the future.

Answers

  • The P.O.T.Y
    The P.O.T.Y Member Posts: 41 Member

    Had that problem with a few 3rd party plugins also. It became a lil easier with just an added step. If its something like a "pro" plug-in that is just "heavy" on cpu/gui etc. try it on the GROUP section of the SOUNDS as plugin and automate on/off with in specific pattern. That way it is not constantly working during playback. Or create a GROUP (A2) and load your time-based plugins (and dynamics if choose) push the signal to that SOUND (plug-in) and the delay start should not happen. Because your sending the signal at start/play aside from start/play processing the signal for a delayed playback start. I do this with Soundshifter plugin, where the pitch change is seamless when start/play. Because I am sending the audio signal to process. Not the plug-in processing the MIDI triggered audio. Some plug-ins that manipulate MIDI and Audio work without a delay playback. But ones that are really made to just manipulate Audio will create delay or artifacts. Because the MIDI input/note to trigger audio playback ms delay has to process first, for the plugin that may Audio manipulate too process next. Causing mad delay if engaged at start of session.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod
    Answer ✓

    Some 3rd party plug-ins induce a delay (due to processing), unfortunately, the Maschine software doesn't have Plug-In delay compensation, it's a common feature request. Hopefully this gets addressed in the future.

  • Mike Vamp
    Mike Vamp Member Posts: 12 Member

    Hi Jeremy,

    I encounter cracks when I start and stop or retrigger my scenes or pattern. I am also using third-party plugins. Could this be the reason why that happens? I left a discussion to see if others have this problem too.

    Thank you for your help.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    @Mike Vamp I can't find the discussion you mentioned about cracks or performance issues.

  • Mike Vamp
    Mike Vamp Member Posts: 12 Member
    edited November 2022

    Hi Jeremy, it had to be approved. It s online now : ) Thank you in advance.

Back To Top