Busy season in progress... Please note that due to a high volume of requests, the response time from our support is currently longer than usual. Chat is temporarily not available. We thank you for your understanding.

Edit of User library seems broken (on windows)

larserik
larserik Member Posts: 6 Sine

I got some third party sample libraries (Goldbaby and WaveAlchemy) that I have configured int he Preferences->Library ->Users section.

Doing some house cleaning I want to move the libraries to a new drive but I can't edit the location.

Example:

I have a library from Goldbaby located at d:\samples\goldbaby\tdmc-machine\

Don't want the samples there so to flatten out the library path moved the library one level up and renamed the parent folder. So now the library location is: d:\samples\goldbaby tdmc-machine\

So to edit the user library configuration for the new location I was thinking I could just edit the path:

So this is what I do:

  1. Dubble click the row for the library
  2. An "Browse for Folder" shows up.
  3. I select the new location
  4. Press Ok.

Now Maschine software says "An entry with the same location already exists". Please choose a new location." What?

Weird. So I close down the preferences and open them up again only to see a duplicate. So it appears the old path and the new path are configured at once. Now I have two TDMC user libraries configured. One with the old path and the other with the new path.

Trying to delete the old one by using the "Remove" button doesnt work. (I select the row and press "Remove". Nothing happens.)

So now I'm thinking that I should first remove the library from the preferences and then move the folders and later add the library to Maschine but I can't at this stage not remove any libraries at all from the preferences.

What to do?

PS. I'm on Windows 11 and I'm using the latest version 2.15.2 of Maschine.

Best Answer

  • larserik
    larserik Member Posts: 6 Sine
    Answer ✓

    So I had to delete the C:\Users\<my user name>\AppData\Local\Native Instruments\Maschine 2\ folder and start over from scratch.

    Guessing the data in that folder was corrupted or something like that because now adding, removing and changeing paths works just fine.

Answers

  • larserik
    larserik Member Posts: 6 Sine
    Answer ✓

    So I had to delete the C:\Users\<my user name>\AppData\Local\Native Instruments\Maschine 2\ folder and start over from scratch.

    Guessing the data in that folder was corrupted or something like that because now adding, removing and changeing paths works just fine.

Back To Top