OS Compatabiliy with Komplete 14

academyofrock
academyofrock Member Posts: 9 Member
edited October 2022 in Komplete General

I have a 2018 Mac and have kept it on Catalina to avoid any conflicts with Mac / NI. Does anyone know if the new Komplete 14 will be OK running on Catalina?

Tagged:

Best Answer

Answers

  • Monochrome
    Monochrome Member Posts: 1,067 Expert
    Answer ✓

    The official system requirements say "macOS 10.15, 11 or 12 (latest update)". 10.15 is Catalina.

  • academyofrock
    academyofrock Member Posts: 9 Member

    Thank you so much. I have had so many problems with Mac OS in the past that I'm very cautious now :-)

  • Marzio2002
    Marzio2002 Member Posts: 2 Newcomer

    But I read in the specification of the products that Native Instruments Komplete 14 runs only on MacOs 11, 12, 13. I'm so confused because in other sites I read that is support also MacOs 10.15.

Back To Top