Butch Vig Drums - Playing patterns in pattern view while working with DAW

Piotr Kasprzyk
Piotr Kasprzyk Member Posts: 4 Sine

Hello,

I have just spotted that mouse clicking a pattern box in the pattern view of the Butch Vig Drums plug-in apart from playing back the pattern, also creates a midi clip in my DAW. A separate track is being created on every click no matter if I start or stop the playback. Is it possible to switch creating files off? It is very inconvenient and causes a lot of mess.

The clips are being created only when I am using the mouse to click the pattern boxes. When I am using the midi controller (for example pressing C3 key) Kontakt only plays back the pattern.

I am using Reaper and Komplete Kontrol.

I thought it was a bug, so I have reinstalled the Butch Vig Drums, but it did not help.

Best regards,

Piotr Kasprzyk,

Gliwice, Poland

Best Answers

  • Uwe303
    Uwe303 Moderator Posts: 1,478 mod
    Answer ✓

    Hello,

    this is normal, just use with mouse the play button or the two select next\prev midi file buttons. Only thing different in reaper, that it creates a new track, in other daws i have to click and hold, then drag the midi file where i need it. But i guess you can set it somwhere in reaper.

  • Piotr Kasprzyk
    Piotr Kasprzyk Member Posts: 4 Sine
    edited September 2022 Answer ✓

    Hello,

    I would gladly set it in Reaper, but I do not know what setting name to look for - I do not know what orders Reaper to create the tracks and clips.

    Thanks for the answer,

    Best regards,

    Piotr

Answers

  • Uwe303
    Uwe303 Moderator Posts: 1,478 mod
    Answer ✓

    Hello,

    this is normal, just use with mouse the play button or the two select next\prev midi file buttons. Only thing different in reaper, that it creates a new track, in other daws i have to click and hold, then drag the midi file where i need it. But i guess you can set it somwhere in reaper.

  • Piotr Kasprzyk
    Piotr Kasprzyk Member Posts: 4 Sine
    edited September 2022 Answer ✓

    Hello,

    I would gladly set it in Reaper, but I do not know what setting name to look for - I do not know what orders Reaper to create the tracks and clips.

    Thanks for the answer,

    Best regards,

    Piotr

  • Uwe303
    Uwe303 Moderator Posts: 1,478 mod

    i will try to find out

  • Piotr Kasprzyk
    Piotr Kasprzyk Member Posts: 4 Sine

    Thank you!

  • Uwe303
    Uwe303 Moderator Posts: 1,478 mod

    OMG,

    i´m, sooo stupid, it of course behaves the same in reaper as in any other daw, just press and hold the mouse button on a groove. Then you can drag and drop it to the instrument channel, with the kontakt instance, with the drums belongs to.

  • Piotr Kasprzyk
    Piotr Kasprzyk Member Posts: 4 Sine
    edited September 2022

    Hello, Uwe,

    Yes, I know the thing. This is the expected behaviour - I drag by the handle and drop to the proper place, usually on my Kontakt tracks, because they understand the midi drums.

    But the thing that I am suprised, is that the plugin creates a clip every time I click (only click, not drag!) a pattern with the mouse. When it starts playing, it creates one, and when it stops, it creates another. And new tracks are being created along. So, choosing a groove to use involves creating at least a few of not needed midi clips in new tracks.

    It is not connected with the playing the grooves itself, but with clicking: pressing C3 (or other key in the C3-D#4 range) on the attached keyboard starts the groove playback, but does not create a clip.

    I thought it was something wrong either with Butch Vig Drums or with the Reaper. But if it cannor be changed - this is fine - I'll try not to use mouse in this context and if I do, I'll just delete the redundant midi pieces. And tracks.

    Thank you for your time,

    Regards,

    Piotr

Back To Top