Maschine 2 Software and trouble with Windows 10 and MK1 Hardware

GioStuttgart
GioStuttgart Member Posts: 2 Noise
edited September 2 in Maschine

Dear all,

I have the following configuration:


  • Hardware Maschine MK1
  • Software Maschine 2.15.2
  • Windows 10
  • Maschine Controller Driver 3.0.1

According to NI the Maschine 2 software will run on older hardware without a problem and few weeks ago I've had NO issues. Today I've realized some trouble while booting up the pc. The backlight of the display from the MK1 turns on but no information on the display. When you start the Maschine Software all the other buttons will turn on but still no information on the display. So you need to disconect the device from USB port and connect again and then the hardware works perfect.


I've tried this on another windows PC but same problem - so no issue with my computer.


So I've installed Maschine 2 on my Macbook Pro 2019 with Big Sur 11.6.8 without installing the controller driver 2.8.0 and connected the old hardware with an USB to USB-C adapter and the hardware works perfect!!!!!


Maybe somebody can help. Is this a hardware defect or a windows issue?


Many thanks

George

Best Answer

Answers

  • 6xes
    6xes Member Posts: 110 Tri

    what you have described regarding the backlit display occurs intermittently when im using my mk1

    its something i havent pinned down as to the cause of it...

    that said... you would have noticed also that when the Maschine software is running... and then connection of the MK1 device is made... it blinks a couple of times... and works.

    If you should ever figure out what causes the backlit display from not showing.. please let us know **winks

  • GioStuttgart
    GioStuttgart Member Posts: 2 Noise

    @6xes


    many thanks for your reply. Yesterday I've did some test:

    • if I use the MK1 with windows every time I switch on the PC anew I need to reconnect the device to use it
    • no problem with a mac computer. If you switch off the mac you will see the NI logo on the both displays.

    I assume this is a driver issue.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @GioStuttgart What version of Controller Editor is installed on your computer? Does the Maschine software runs as administrator ? How to Run a Program as an Administrator Do you have an antivirus active or firewall? Have you tried another USB cable?

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod
    Answer ✓

    @GioStuttgart You didn't get back to us on that subject. If you still need help on that matter, please get in touch here: http://bit.ly/NIsupport_maschine

This discussion has been closed.
Back To Top